summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoeljunior2018-03-04 10:53:27 +0000
committerNoeljunior2018-03-04 10:53:27 +0000
commit15faba6074c4e3171fe6abf0eb9ece817596e344 (patch)
tree25e09b2b7a37f1a81e4a83af528708d335a8b6a0
parent606caf1e873bd25063cbfb5fdc35057247e1dfdb (diff)
downloadaur-15faba6074c4e3171fe6abf0eb9ece817596e344.tar.gz
Using NicoHood repository
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 32 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 726b4d48b154..d1cd9aaf9fee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = gtk-theme-arc-solid-git
- pkgdesc = A flat theme without transparent elements for GTK 3, GTK 2 and Gnome-Shell. Latest commit from the master branch on Github.
- pkgver = 663.8290cb8
+ pkgdesc = A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)
+ pkgver = 712.51d88f1
pkgrel = 1
- url = https://github.com/horst3180/arc-theme
+ url = https://github.com/nicohood/arc-theme
arch = any
license = GPL3
makedepends = git
- depends = gtk3
- depends = gtk-engine-murrine
+ makedepends = gtk3
+ makedepends = sassc
+ optdepends = arc-icon-theme: recommended icon theme
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ optdepends = gnome-themes-standard: for gtk2 themes
provides = arc-gtk-theme
conflicts = arc-gtk-theme
- source = arc-theme::git+https://github.com/horst3180/arc-theme.git
- sha256sums = SKIP
+ source = arc-theme::git+https://github.com/nicohood/arc-theme.git
+ sha512sums = SKIP
pkgname = gtk-theme-arc-solid-git
diff --git a/PKGBUILD b/PKGBUILD
index 4a95a17e7fc7..9a1a14de2fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Noeljunior <liamgliam {at} gmail {dot} com>
+# Maintainer: Noeljnuior <liamgliamgmailcom>
+
+# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
# Contributor: zach <zach {at} zach-adams {dot} com>
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
+# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
pkgname=gtk-theme-arc-solid-git
_pkgname=arc-theme
-_pkgauthor=horst3180
-pkgver=663.8290cb8
+pkgdesc="A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)"
+pkgver=712.51d88f1
pkgrel=1
-pkgdesc="A flat theme without transparent elements for GTK 3, GTK 2 and Gnome-Shell. Latest commit from the master branch on Github."
arch=('any')
-url="https://github.com/horst3180/${_pkgname}"
+# Upstream url: https://github.com/horst3180/arc-theme
+# Now using soft fork: https://github.com/horst3180/arc-theme/issues/840
+url="https://github.com/nicohood/arc-theme"
license=('GPL3')
-depends=('gtk3' 'gtk-engine-murrine')
-makedepends=('git')
-source=(${_pkgname}::"git+https://github.com/horst3180/${_pkgname}.git")
-sha256sums=('SKIP')
+optdepends=('arc-icon-theme: recommended icon theme'
+ 'gtk-engine-murrine: for gtk2 themes'
+ 'gnome-themes-standard: for gtk2 themes')
+makedepends=('git' 'gtk3' 'sassc')
+source=(${_pkgname}::"git+https://github.com/nicohood/${_pkgname}.git")
+sha512sums=('SKIP')
conflicts=('arc-gtk-theme')
provides=('arc-gtk-theme')
@@ -24,10 +30,14 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}"
- ./autogen.sh --prefix=/usr --disable-transparency
+ cd ${_pkgname}
+ ./autogen.sh --prefix=/usr
+
+ cd ../${_pkgname}
+ ./autogen.sh --prefix=/usr --disable-transparency
}
package() {
- make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
}