summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume2016-05-09 18:41:02 -0400
committerGuillaume2016-05-09 18:41:02 -0400
commitd39fbb1c790bf347f2e3c973ec0928615f59995b (patch)
tree37103007297f94ed21c25153bde02092879b4a92
downloadaur-d39fbb1c790bf347f2e3c973ec0928615f59995b.tar.gz
First commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40541abf1182
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gtk-theme-arc-solid-git
+ pkgdesc = A flat theme for GTK 3, GTK 2 and Gnome-Shell. With --disable-transparency build option. Latest commit from Github.
+ pkgver = 520.5ec25f4
+ pkgrel = 1
+ url = https://github.com/horst3180/arc-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = gtk-engine-murrine
+ conflicts = gtk-theme-arc,
+ conflicts = gtk-theme-arc-git
+ source = arc-theme::git+https://github.com/horst3180/arc-theme.git
+ sha256sums = SKIP
+
+pkgname = gtk-theme-arc-solid-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d34f12f3f52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gui||aume <michaudg[at]gmail[dot]com>
+# Contributor: zach <zach {at} zach-adams {dot} com>
+
+pkgname=gtk-theme-arc-solid-git
+_pkgname=arc-theme
+_pkgauthor=horst3180
+pkgver=520.5ec25f4
+pkgrel=1
+pkgdesc="A flat theme for GTK 3, GTK 2 and Gnome-Shell. With --disable-transparency build option. Latest commit from Github."
+arch=('any')
+url="https://github.com/horst3180/${_pkgname}"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine')
+makedepends=('git')
+source=(${_pkgname}::"git+https://github.com/horst3180/${_pkgname}.git")
+sha256sums=('SKIP')
+conflicts=('gtk-theme-arc', 'gtk-theme-arc-git')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --prefix=/usr --disable-transparency
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+}