summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoeljunior2017-11-18 16:40:04 +0000
committerNoeljunior2017-11-18 16:40:04 +0000
commit7e6c15f27e8ac12dd3a4fd8d2279c623830cdf29 (patch)
tree01a9f577042c4925808b4b1059b9de27ea2934e7
downloadaur-gtk-theme-arc-solid-grey-git.tar.gz
the first
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..815e9cc53e9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gtk-theme-arc-solid-grey-git
+ pkgdesc = A flat, grey theme without transparent elements for GTK 3, GTK 2 and Gnome-Shell. Latest commit from the master branch on Github.
+ pkgver = r727.ac2e88f
+ pkgrel = 1
+ url = https://github.com/eti1337/arc-grey-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = gtk-engine-murrine
+ provides = gtk-theme-arc-grey
+ conflicts = gtk-theme-arc-grey
+ source = arc-grey-theme::git+https://github.com/eti1337/arc-grey-theme.git
+ sha256sums = SKIP
+
+pkgname = gtk-theme-arc-solid-grey-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e852d9f42fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Noeljunior <liamgliam {at} gmail {dot} com>
+# Contributor: Alexandre Moine <nobrakal {at} cthugha {dot} org>
+# Contributor: < eti {at} eti {dot} tf >
+# Contributor: zach <zach {at} zach-adams {dot} com>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
+
+pkgname=gtk-theme-arc-solid-grey-git
+_pkgname=arc-grey-theme
+_pkgauthor=eti1337
+pkgver=r727.ac2e88f
+pkgrel=1
+pkgdesc="A flat, grey theme without transparent elements for GTK 3, GTK 2 and Gnome-Shell. Latest commit from the master branch on Github."
+arch=('any')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine')
+makedepends=('git')
+source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+sha256sums=('SKIP')
+conflicts=('gtk-theme-arc-grey')
+provides=('gtk-theme-arc-grey')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ # echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --prefix=/usr --disable-transparency
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+}