summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeteros2017-03-29 02:21:55 +0000
committerTeteros2017-03-29 02:21:55 +0000
commit9b0526ec16f340ff1dfa9914c43edce8dde56ee4 (patch)
treefec9bbf2962e126d21624b8619573dabf4580930
downloadaur-9b0526ec16f340ff1dfa9914c43edce8dde56ee4.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a2956747d53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gtk-theme-e17gtk-git
+ pkgdesc = A dark GTK2/GTK3 theme with sharp corners, which is designed for use in Enlightenment and gives the elegant look of Enlightenment to GTK widgets.
+ pkgver = V3.22.0.r5.g05b9dca
+ pkgrel = 1
+ url = https://github.com/tsujan/E17gtk
+ arch = any
+ license = GPL
+ makedepends = git
+ optdepends = enlightenment
+ optdepends = qt5-styleplugins: GTK+ rendering for QT5
+ source = E17gtk::git+https://github.com/tsujan/E17gtk
+ md5sums = SKIP
+
+pkgname = gtk-theme-e17gtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..683f3a6b9991
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Teteros <teteros -at- openmailbox -dot- org>
+_pkgname=E17gtk
+pkgname=gtk-theme-e17gtk-git
+pkgver=V3.22.0.r5.g05b9dca
+pkgrel=1
+pkgdesc="A dark GTK2/GTK3 theme with sharp corners, which is designed for use in Enlightenment and gives the elegant look of Enlightenment to GTK widgets."
+arch=('any')
+url="https://github.com/tsujan/${_pkgname}"
+license=('GPL')
+optdepends=('enlightenment'
+ 'qt5-styleplugins: GTK+ rendering for QT5')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/tsujan/${_pkgname}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/themes"
+ mv "${_pkgname}" "${pkgdir}/usr/share/themes/${_pkgname}"
+}