summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJim Sangwine2018-05-10 10:50:01 +0800
committerJim Sangwine2018-05-10 10:50:01 +0800
commit8504b8a268652cba70850c12b673851b4cbd0734 (patch)
tree2c4e48e98faf442c0cbc8ab3d11f524ca0c35b33
downloadaur-gtk-theme-flat-color-git.tar.gz
First PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c690934af86b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gtk-theme-flat-color-git
+ pkgdesc = A flat GTK theme designed to be easily re-colored. This is the theme used in wpgtk.
+ pkgver = 20180507.ff68c61
+ pkgrel = 1
+ url = https://github.com/deviantfero/wpgtk-templates/tree/master/FlatColor
+ arch = any
+ license = LGPL
+ makedepends = gtk2
+ makedepends = gtk3
+ optdepends = gtk2: GTK+2 theme
+ optdepends = gtk3: GTK+3 theme
+ provides = gtk-theme-flat-color-git
+ conflicts = gtk-theme-flat-color-git
+ source = git+https://github.com/deviantfero/wpgtk-templates.git
+ sha256sums = SKIP
+
+pkgname = gtk-theme-flat-color-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19e3f93c8b5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jim Sangwine <jim at sangwine dot net>
+# Maintainer: Fernando Vasquez <fmorataya.04 at gmail dot com>
+
+pkgname=gtk-theme-flat-color-git
+pkgver=20180507.ff68c61
+pkgrel=1
+pkgdesc='A flat GTK theme designed to be easily re-colored. This is the theme used in wpgtk.'
+arch=('any')
+url='https://github.com/deviantfero/wpgtk-templates/tree/master/FlatColor'
+license=('LGPL')
+depends=()
+makedepends=('gtk2'
+ 'gtk3'
+ )
+optdepends=('gtk2: GTK+2 theme'
+ 'gtk3: GTK+3 theme'
+ )
+provides=('gtk-theme-flat-color-git')
+conflicts=('gtk-theme-flat-color-git')
+source=('git+https://github.com/deviantfero/wpgtk-templates.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "wpgtk-templates"
+ local date=$(date --date "$(git show -s --format=%ci)" +%Y%m%d)
+ local commit=$(git rev-parse --short HEAD)
+ echo $date.$commit
+}
+
+package() {
+ install -dm755 $pkgdir/usr/share/themes
+ cp -R wpgtk-templates/FlatColor $pkgdir/usr/share/themes/FlatColor
+ rm -rf $pkgdir/usr/share/themes/FlatColor/.git
+ printf "\e[32;1m\n* * * * * * * * * * * * * * * * * * * * * * * * * * *\e[0m"
+ printf "\e[32;1m\n* To change theme colors edit the following files: *\e[0m"
+ printf "\e[32;1m\n* *\e[0m"
+ printf "\e[32;1m\n* /usr/share/themes/FlatColor/gtk-2.0/gtkrc *\e[0m"
+ printf "\e[32;1m\n* /usr/share/themes/FlatColor/gtk-3.0/gtk.css *\e[0m"
+ printf "\e[32;1m\n* /usr/share/themes/FlatColor/gtk-3.20/gtk.css *\e[0m"
+ printf "\e[32;1m\n* * * * * * * * * * * * * * * * * * * * * * * * * * *\e[0m\n"
+}