summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-03 13:17:09 -0600
committerMark Wagie2021-06-03 13:17:09 -0600
commit9d3d251ae7f12807ca0e5e63161f94ec680e89ad (patch)
tree6ac23607124c333ad1365fb0c01b9f67163ca389
parent76dedef4902107557855eb66d404db2cb630e30f (diff)
downloadaur-9d3d251ae7f12807ca0e5e63161f94ec680e89ad.tar.gz
0.2.2
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD51
3 files changed, 57 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b5f8a5fa34f..d1fae22af7c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,34 @@
pkgbase = gtk-theme-framework
pkgdesc = GTK themes built with the GTK Theme Framework
- pkgver = 0.2.1
+ pkgver = 0.2.2
pkgrel = 1
url = https://github.com/jaxwilko/gtk-theme-framework
arch = any
license = GPL3
- makedepends = sassc
- makedepends = inkscape
- makedepends = optipng
+ makedepends = git
depends = gtk3
- depends = gtk-engine-murrine
- depends = gtk-engines
+ optdepends = gtk-engine-murrine: GTK2 theme support
+ optdepends = gtk-engines: GTK2 theme support
conflicts = material-gtk-framework
replaces = material-gtk-framework
options = !strip
- source = gtk-theme-framework-0.2.1.tar.gz::https://github.com/jaxwilko/gtk-theme-framework/archive/v0.2.1.tar.gz
+ source = gtk-theme-framework-0.2.2.tar.gz::https://github.com/jaxwilko/gtk-theme-framework/archive/v0.2.2.tar.gz
source = git+https://github.com/vinceliuice/vimix-icon-theme.git
- sha256sums = 90fdab6c78b8cbb262cc9b99125a156bcdda1133f8d69a71d94b7ca6baae9fe9
+ sha256sums = 0d698d525607095d1e99122b79f2cbeacc79361693115d2a0ae2cf7ed8f2b988
sha256sums = SKIP
pkgname = palenight-gtk-theme
+ pkgdesc = Palenight GTK theme & icon set: built with the GTK Theme Framework
pkgname = amarena-gtk-theme
+ pkgdesc = Amarena GTK theme & icon set: built with the GTK Theme Framework
pkgname = gruvterial-gtk-theme
+ pkgdesc = Gruvterial GTK theme & icon set: built with the GTK Theme Framework
+
+pkgname = oceanic-gtk-theme
+ pkgdesc = Oceanic GTK theme & icon set: built with the GTK Theme Framework
+
+pkgname = spacx-gtk-theme
+ pkgdesc = Spacex GTK theme & icon set: built with the GTK Theme Framework
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index ac77756874f9..d3e082a56628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
-pkgname=('palenight-gtk-theme' 'amarena-gtk-theme' 'gruvterial-gtk-theme')
+pkgname=('palenight-gtk-theme'
+ 'amarena-gtk-theme'
+ 'gruvterial-gtk-theme'
+ 'oceanic-gtk-theme'
+ 'spacx-gtk-theme')
pkgbase=gtk-theme-framework
-pkgver=0.2.1
+pkgver=0.2.2
pkgrel=1
pkgdesc="GTK themes built with the GTK Theme Framework"
arch=('any')
url="https://github.com/jaxwilko/gtk-theme-framework"
license=('GPL3')
-depends=('gtk3' 'gtk-engine-murrine' 'gtk-engines')
-makedepends=('sassc' 'inkscape' 'optipng')
+depends=('gtk3')
+makedepends=('git')
+optdepends=('gtk-engine-murrine: GTK2 theme support'
+ 'gtk-engines: GTK2 theme support')
conflicts=('material-gtk-framework')
replaces=('material-gtk-framework')
options=('!strip')
source=("$pkgbase-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'git+https://github.com/vinceliuice/vimix-icon-theme.git')
-sha256sums=('90fdab6c78b8cbb262cc9b99125a156bcdda1133f8d69a71d94b7ca6baae9fe9'
+sha256sums=('0d698d525607095d1e99122b79f2cbeacc79361693115d2a0ae2cf7ed8f2b988'
'SKIP')
prepare() {
@@ -24,18 +30,9 @@ prepare() {
fi
}
-build() {
- cd "$pkgbase-$pkgver"
-
- # Remove precompiled assets
- rm -rf dist
-
- ./main.sh -vcf
- ./main.sh -t amarena -vcf
- ./main.sh -t gruvterial -vcf
-}
-
package_palenight-gtk-theme() {
+ pkgdesc="Palenight GTK theme & icon set: built with the GTK Theme Framework"
+
cd "$pkgbase-$pkgver"
install -d "$pkgdir"/usr/share/{icons,themes}
./main.sh -v -id "$pkgdir/usr/share/themes" \
@@ -43,6 +40,8 @@ package_palenight-gtk-theme() {
}
package_amarena-gtk-theme() {
+ pkgdesc="Amarena GTK theme & icon set: built with the GTK Theme Framework"
+
cd "$pkgbase-$pkgver"
install -d "$pkgdir"/usr/share/{icons,themes}
./main.sh -t amarena -v -id "$pkgdir/usr/share/themes" \
@@ -50,8 +49,28 @@ package_amarena-gtk-theme() {
}
package_gruvterial-gtk-theme() {
+ pkgdesc="Gruvterial GTK theme & icon set: built with the GTK Theme Framework"
+
cd "$pkgbase-$pkgver"
install -d "$pkgdir"/usr/share/{icons,themes}
./main.sh -t gruvterial -v -id "$pkgdir/usr/share/themes" \
-op "$pkgdir/usr/share/icons"
}
+
+package_oceanic-gtk-theme() {
+ pkgdesc="Oceanic GTK theme & icon set: built with the GTK Theme Framework"
+
+ cd "$pkgbase-$pkgver"
+ install -d "$pkgdir"/usr/share/{icons,themes}
+ ./main.sh -t oceanic -v -id "$pkgdir/usr/share/themes" \
+ -op "$pkgdir/usr/share/icons"
+}
+
+package_spacx-gtk-theme() {
+ pkgdesc="Spacex GTK theme & icon set: built with the GTK Theme Framework"
+
+ cd "$pkgbase-$pkgver"
+ install -d "$pkgdir"/usr/share/{icons,themes}
+ ./main.sh -t spacx -v -id "$pkgdir/usr/share/themes" \
+ -op "$pkgdir/usr/share/icons"
+}