summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2017-08-10 11:49:45 +0200
committerFerdinand Bachmann2017-08-10 11:53:27 +0200
commit58a45bc9f6b4dff2a1b16b49838d291042d9c9b3 (patch)
treeb7e2c89dd76cfa90d64f1ebe71ff4f620f37d6e9
parenta12d8883dd91fdcf0c692739ccdb908343e00867 (diff)
downloadaur-58a45bc9f6b4dff2a1b16b49838d291042d9c9b3.tar.gz
update to new major version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96db49fa6593..ca01161a38b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Sep 19 15:36:07 UTC 2016
+# Thu Aug 10 09:53:11 UTC 2017
pkgbase = gtk-theme-numix-solarized-git
pkgdesc = Solarized versions of Numix GTK2 and GTK3 theme, compatible with GTK 3.20
- pkgver = 20160919.b2d221f
+ pkgver = 20170810.510b549
pkgrel = 1
url = https://github.com/Ferdi265/numix-solarized-gtk-theme
arch = any
@@ -11,6 +11,8 @@ pkgbase = gtk-theme-numix-solarized-git
makedepends = make
makedepends = ruby-sass
makedepends = glib2
+ makedepends = inkscape
+ makedepends = optipng
depends = gtk-engine-murrine
conflicts = gtk-theme-numix-solarized
source = git+https://github.com/Ferdi265/numix-solarized-gtk-theme.git
diff --git a/PKGBUILD b/PKGBUILD
index 9d4e378299a6..3ed3c91736d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: theferdi265 at gmail dot com
pkgname=gtk-theme-numix-solarized-git
-pkgver=20160919.b2d221f
+pkgver=20170810.510b549
pkgrel=1
pkgdesc="Solarized versions of Numix GTK2 and GTK3 theme, compatible with GTK 3.20"
arch=('any')
@@ -9,7 +9,7 @@ url="https://github.com/Ferdi265/numix-solarized-gtk-theme"
license=('GPL3')
conflicts=('gtk-theme-numix-solarized')
depends=('gtk-engine-murrine')
-makedepends=('git' 'make' 'ruby-sass' 'glib2')
+makedepends=('git' 'make' 'ruby-sass' 'glib2' 'inkscape' 'optipng')
source=('git+https://github.com/Ferdi265/numix-solarized-gtk-theme.git')
md5sums=('SKIP')
@@ -22,5 +22,9 @@ pkgver() {
package() {
cd "numix-solarized-gtk-theme"
- make DESTDIR="${pkgdir}" install
+ themes=( *.colors )
+
+ for theme in ${themes[@]/.colors/}; do
+ make THEME="$theme" DESTDIR="$pkgdir" install
+ done
}