summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-09 23:55:46 +0100
committerNarrat2020-01-09 23:56:21 +0100
commitad59b780ebe57e1464d3e1b7ca9f11bc8e083c66 (patch)
tree4a8dd6d7c7243a92109819a674c4b63051025111
downloadaur-ad59b780ebe57e1464d3e1b7ca9f11bc8e083c66.tar.gz
Plano: Initial commit
Like gtk-theme-plano-git but built from releases
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7fc06064788
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gtk-theme-plano
+ pkgdesc = flat GTK+ theme
+ pkgver = 3.34.2
+ pkgrel = 1
+ url = https://github.com/lassekongo83/plano-theme
+ arch = any
+ license = GPL3
+ depends = gtk-engines
+ optdepends = ttf-roboto: for the GNOME shell theme
+ optdepends = gtk-engine-murrine: for the GTK2 theme
+ conflicts = gtk-theme-plano-git
+ source = plano-theme-3.34.2.tar.gz::https://github.com/lassekongo83/plano-theme/archive/v3.34-2.tar.gz
+ sha256sums = d94556d38b52f0444f712ddd8356e9b7a5338c95c79bd6203e328e15be1214ed
+
+pkgname = gtk-theme-plano
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80fdfccc1224
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lex Black <autumn-wind@web.de>
+
+pkgname=gtk-theme-plano
+_pkgname=plano-theme
+_pkgauthor=lassekongo83
+pkgver=3.34.2
+pkgrel=1
+pkgdesc='flat GTK+ theme'
+arch=('any')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+license=('GPL3')
+depends=('gtk-engines')
+optdepends=('ttf-roboto: for the GNOME shell theme'
+ 'gtk-engine-murrine: for the GTK2 theme')
+conflicts=('gtk-theme-plano-git')
+source=(${_pkgname}-${pkgver}.tar.gz::https://github.com/lassekongo83/${_pkgname}/archive/v${pkgver/%.2/-2}.tar.gz)
+sha256sums=('d94556d38b52f0444f712ddd8356e9b7a5338c95c79bd6203e328e15be1214ed')
+
+
+package() {
+ install -d "${pkgdir}"/usr/share/themes/Plano
+
+ for file in index.theme gnome-shell gtk-2.0 gtk-3.0 openbox-3 xfwm4
+ do
+ cp -R "${srcdir}/${_pkgname}-${pkgver/%.2/-2}/${file}" "${pkgdir}"/usr/share/themes/Plano
+ done
+
+ # fix permissions and ownership
+ find "${pkgdir}"/ -type d -exec chmod 755 '{}' \;
+ find "${pkgdir}"/ -type f -exec chmod 644 '{}' \;
+ chown -R root.root "${pkgdir}"/*
+}