summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach2017-03-26 17:12:48 -0600
committerZach2017-03-26 17:12:48 -0600
commitd3fae60f1bae2aa76c4682c3b377111a4f0e0eaf (patch)
treef19f7e4f2c7469faa33f1c13a48efd4036d8c51f
downloadaur-d3fae60f1bae2aa76c4682c3b377111a4f0e0eaf.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2082cb728c9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Mar 26 23:10:50 UTC 2017
+pkgbase = gtk-theme-plano-git
+ pkgdesc = A flat theme for GNOME & Xfce4. Latest commit from the master branch on Github.
+ pkgver = 140.f7dba06
+ pkgrel = 1
+ url = https://github.com/lassekongo83/plano-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ source = plano-theme::git+https://github.com/lassekongo83/plano-theme.git
+ sha256sums = SKIP
+
+pkgname = gtk-theme-plano-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b30f7df2eec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: zach <zach {at} zach-adams {dot} com>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
+
+pkgname=gtk-theme-plano-git
+_pkgname=plano-theme
+_pkgauthor=lassekongo83
+pkgver=140.f7dba06
+pkgrel=1
+pkgdesc="A flat theme for GNOME & Xfce4. Latest commit from the master branch on Github."
+arch=('any')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+license=('GPL3')
+makedepends=('git')
+source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d $pkgdir/usr/share/themes
+
+ mv "${srcdir}/${_pkgname}" "$pkgdir/usr/share/themes/Plano"
+}