summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWernerFP2018-06-17 21:02:43 +0200
committerWernerFP2018-06-17 21:02:43 +0200
commit15821e1814f85f45cd694c6ac498e7051f16213c (patch)
tree938e95c8838694ff9a32ef5d3c2fa69ffcfec7ec
downloadaur-15821e1814f85f45cd694c6ac498e7051f16213c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c94e696e3b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gtk-theme-shades-of-gray
+ pkgdesc = A dark GTK-theme with ergonomic contrasts (GNOME, Xfce, Openbox); tweaks for Firefox and Thunderbird are included.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/WernerFP/Shades-of-gray-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ optdepends = gtk-engines: for gtk2 themes
+ conflicts = gtk-theme-shades-of-gray
+ source = https://github.com/WernerFP/Shades-of-gray-theme/archive/1.0.2.tar.gz
+ md5sums = e9d887b27353aafb539c502854964c91
+
+pkgname = gtk-theme-shades-of-gray
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57d101187e05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Werner Redelius <echo d2VybmVyZnBAcG9zdGVvLmRlDQo= | base64 -d>
+# https://github.com/WernerFP/Shades-of-gray-theme
+
+_gituser=WernerFP
+_gitname=Shades-of-gray-theme
+
+pkgname=gtk-theme-shades-of-gray
+pkgbase=${pkgname}
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='A dark GTK-theme with ergonomic contrasts (GNOME, Xfce, Openbox); tweaks for Firefox and Thunderbird are included.'
+arch=('any')
+url="https://github.com/$_gituser/$_gitname"
+license=('GPL3')
+conflicts=('gtk-theme-shades-of-gray')
+depends=('gtk3')
+optdepends=('gtk-engine-murrine: for gtk2 themes'
+ 'gtk-engines: for gtk2 themes')
+makedepends=('git')
+source=("https://github.com/$_gituser/$_gitname/archive/$pkgver.tar.gz")
+md5sums=('e9d887b27353aafb539c502854964c91')
+
+package() {
+ cd "$srcdir/$_gitname-$pkgver"
+ rm {LICENSE,README.md,preview_01.png}
+ DESTDIR="$pkgdir/usr/share/themes"
+ mkdir -p "$DESTDIR"
+ mv Shades-of-gray "$DESTDIR/"
+ mv Shades-of-gray-Arch "$DESTDIR/"
+ mv Shades-of-gray-Cerulean "$DESTDIR/"
+ mv Shades-of-gray-Firebrick "$DESTDIR/"
+ mv Shades-of-gray-Harvest "$DESTDIR/"
+ mv Shades-of-gray-Orient "$DESTDIR/"
+ mv Shades-of-gray-Patina "$DESTDIR/"
+} \ No newline at end of file