summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach2016-08-01 11:29:09 -0600
committerZach2016-08-01 11:29:09 -0600
commitba00ecafd19601260ab980d684a05806e7a8b616 (patch)
tree76d608dbd8c20ad85e218c979bb76eb170fd0802
downloadaur-ba00ecafd19601260ab980d684a05806e7a8b616.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75da4fcc40c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Aug 1 17:28:46 UTC 2016
+pkgbase = gtk-theme-solarc-git
+ pkgdesc = A flat theme with transparent elements. Based on the Arc theme: https://github.com/horst3180/arc-theme
+ pkgver = 568.aa5f66d
+ pkgrel = 1
+ url = https://github.com/apheleia/solarc-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = gtk-engine-murrine
+ provides = gtk-theme-solarc
+ conflicts = gtk-theme-solarc
+ source = solarc-theme::git+https://github.com/apheleia/solarc-theme.git
+ sha256sums = SKIP
+
+pkgname = gtk-theme-solarc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd2ae3aa04cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zach <zach {at} zach-adams {dot} com>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
+
+pkgname=gtk-theme-solarc-git
+_pkgname=solarc-theme
+_pkgauthor=apheleia
+pkgver=568.aa5f66d
+pkgrel=1
+pkgdesc="A flat theme with transparent elements. Based on the Arc theme: https://github.com/horst3180/arc-theme"
+arch=('any')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine')
+makedepends=('git')
+source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+sha256sums=('SKIP')
+conflicts=('gtk-theme-solarc')
+provides=('gtk-theme-solarc')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --prefix=/usr
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+}