summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhorsemanoffaith2016-11-16 13:33:49 -0800
committerhorsemanoffaith2016-11-16 13:33:49 -0800
commit7f309f97285be6bd834fcd4f827833187f6b2739 (patch)
tree35cea181ed1a074857b57ab4ad99f1c4f8cba6cc
parent2e59d94e84d6aaf6935a55e37036bf557cd78547 (diff)
downloadaur-7f309f97285be6bd834fcd4f827833187f6b2739.tar.gz
update to version 2.24.31
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD45
2 files changed, 35 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61c167923f66..2b0936416fa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk2-ubuntu
pkgdesc = GObject-based multi-platform GUI toolkit (legacy)
- pkgver = 2.24.30+95+g876b5f7
+ pkgver = 2.24.31
pkgrel = 1
url = http://www.gtk.org/
install = gtk2.install
@@ -8,34 +8,33 @@ pkgbase = gtk2-ubuntu
arch = x86_64
license = LGPL
makedepends = gobject-introspection
- makedepends = python2
- makedepends = git
makedepends = gtk-doc
+ makedepends = python2
depends = atk
- depends = pango
+ depends = cairo
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ depends = libcups
+ depends = librsvg
+ depends = libxcomposite
depends = libxcursor
+ depends = libxdamage
+ depends = libxi
depends = libxinerama
depends = libxrandr
- depends = libxi
- depends = libxcomposite
- depends = libxdamage
+ depends = pango
depends = shared-mime-info
- depends = cairo
- depends = libcups
- depends = gtk-update-icon-cache
- depends = librsvg
- depends = desktop-file-utils
- optdepends = gnome-themes-standard: Default widget theme
optdepends = adwaita-icon-theme: Default icon theme
- provides = gtk2=2.24.30+95+g876b5f7
+ optdepends = gnome-themes-standard: Default widget theme
+ provides = gtk2=2.24.31
conflicts = gtk2
- source = git://git.gnome.org/gtk+#commit=876b5f75faab5d8f3c60c3ec035b2ecd4ac5b67e
- source = https://launchpad.net/ubuntu/+archive/primary/+files/gtk+2.0_2.24.30-1ubuntu1.debian.tar.xz
+ source = http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-2.24.31.tar.xz
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/gtk+2.0_2.24.30-4ubuntu2.debian.tar.xz
source = gtkrc
source = gtk-query-immodules-2.0.hook
source = xid-collision-debug.patch
- sha512sums = SKIP
- sha512sums = d948b64130e3acc02743b212d7afa96cee0da1f9adb9855989749c33f53e1f5fcc3328e14d83e733699f2f3f9657f79efb01afcea6f06760a1b6eea9c65dbd75
+ sha512sums = 75b846661308d94b5236e7e1c367deabf57753792ca87e92f9769822dd5ec90e00cd8d5574adcc12162e3702e1ae6dc152278a1d218f9bd9e4d1c8dc1dd520c1
+ sha512sums = d6d97558e03dea63b2dfcc4c5a01ab9ceb5b5802b0dcecfd7ac9c52127d4966cc311748066b8f1eb85f489bbb48af7a0316db2074c4c9c40668115eda495320f
sha512sums = b124433dd4b20d1d62f073df87e253ca23b3b51625cce55f29a220a4369eda5108c0de07fdc686f570232322c3ff04f7758383f2be5aeace40f843907aa3696d
sha512sums = be7a807046f27e5796f6069dfd2c88f9b7508e3b9e209d97c1575e0d809b279aacacd0e1247f1f7643fa47eede2d987bf433cd17cea0524526ad31982ae8d90d
sha512sums = 89e3223c86731a76b12d39245f1ec4cf8b4860ab1d11d74a10e5deb0db302f20b4bb5d9034da1d8aeb96369dbdeddcdd2f28943270dc501476c694562b960159
diff --git a/PKGBUILD b/PKGBUILD
index ae1e22526ab9..f7def7bb26dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,44 @@
+# Maintainer: Michael Healy <horsemanoffaith@gmail.com>
# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
# Original Maintainer: György Balló <ballogy@freestart.hu>
# Contributor: Christopher Reimer <github@creimer.net>
# vercheck-pkgbuild: auto
-# vercheck-ubuntu: name=gtk+2.0, repo=xenial
+# vercheck-ubuntu: name=gtk+2.0, repo=zesty
# vercheck-archlinux: name=gtk2, repo=extra, arch=x86_64
# vercheck-gnome: name=gtk+, majorver=2.24
pkgname=gtk2-ubuntu
-_ubuntu_rel=1ubuntu1
+_ubuntu_rel=4ubuntu2
_ubuntu_ver=2.24.30
-pkgver=2.24.30+95+g876b5f7
+pkgver=2.24.31
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (legacy)"
arch=(i686 x86_64)
url="http://www.gtk.org/"
license=(LGPL)
-depends=(atk pango libxcursor libxinerama libxrandr libxi libxcomposite
- libxdamage shared-mime-info cairo libcups gtk-update-icon-cache
- librsvg desktop-file-utils)
-makedepends=(gobject-introspection python2 git gtk-doc)
-optdepends=('gnome-themes-standard: Default widget theme'
- 'adwaita-icon-theme: Default icon theme')
+depends=(atk cairo desktop-file-utils gtk-update-icon-cache libcups librsvg libxcomposite libxcursor libxdamage libxi libxinerama libxrandr pango shared-mime-info)
+makedepends=(gobject-introspection gtk-doc python2)
+optdepends=('adwaita-icon-theme: Default icon theme'
+ 'gnome-themes-standard: Default widget theme')
provides=("gtk2=${pkgver}")
conflicts=(gtk2)
install=gtk2.install
-_commit=876b5f75faab5d8f3c60c3ec035b2ecd4ac5b67e
-source=("git://git.gnome.org/gtk+#commit=${_commit}"
+source=("http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-${pkgver}.tar.xz"
"https://launchpad.net/ubuntu/+archive/primary/+files/gtk+2.0_${_ubuntu_ver:-${pkgver}}-${_ubuntu_rel}.debian.tar.xz"
gtkrc
gtk-query-immodules-2.0.hook
xid-collision-debug.patch)
-sha512sums=('SKIP'
- 'd948b64130e3acc02743b212d7afa96cee0da1f9adb9855989749c33f53e1f5fcc3328e14d83e733699f2f3f9657f79efb01afcea6f06760a1b6eea9c65dbd75'
+sha512sums=('75b846661308d94b5236e7e1c367deabf57753792ca87e92f9769822dd5ec90e00cd8d5574adcc12162e3702e1ae6dc152278a1d218f9bd9e4d1c8dc1dd520c1'
+ 'd6d97558e03dea63b2dfcc4c5a01ab9ceb5b5802b0dcecfd7ac9c52127d4966cc311748066b8f1eb85f489bbb48af7a0316db2074c4c9c40668115eda495320f'
'b124433dd4b20d1d62f073df87e253ca23b3b51625cce55f29a220a4369eda5108c0de07fdc686f570232322c3ff04f7758383f2be5aeace40f843907aa3696d'
'be7a807046f27e5796f6069dfd2c88f9b7508e3b9e209d97c1575e0d809b279aacacd0e1247f1f7643fa47eede2d987bf433cd17cea0524526ad31982ae8d90d'
'89e3223c86731a76b12d39245f1ec4cf8b4860ab1d11d74a10e5deb0db302f20b4bb5d9034da1d8aeb96369dbdeddcdd2f28943270dc501476c694562b960159')
-pkgver() {
- cd gtk+
- git describe --tags | sed 's/-/+/g'
-}
-
prepare() {
- cd gtk+
+ cd "gtk+-${pkgver}"
- patch -p1 -i ../xid-collision-debug.patch
+ patch -Np1 -i ../xid-collision-debug.patch
sed -i '1s/python$/&2/' gtk/gtk-builder-convert
local patches=(
@@ -67,21 +60,19 @@ prepare() {
print-dialog-show-options-of-remote-dnssd-printers.patch
gtk-shell-shows-menubar.patch
backport_search_printer_location.patch
- menubar_toolbar_dragging.patch
- #printing-initialize-auth_info.patch
- #gdkcairo-Avoid-integer-overflow.patch
+ menubar_toolbar_dragging.patch
)
for i in "${patches[@]}"; do
msg "Applying ${i}"
patch -p1 -i "../debian/patches/${i}"
done
-
- NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd gtk+
+ cd "gtk+-${pkgver}"
+
+ autoreconf -vfi
CXX=/bin/false ./configure \
--prefix=/usr \
@@ -98,7 +89,7 @@ build() {
}
package() {
- cd gtk+
+ cd "gtk+-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 ../gtkrc \