summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrliang2019-01-10 17:04:41 -0200
committerrliang2019-01-10 17:04:41 -0200
commite313a733c507fed8f8ccf4f5e1f464c1c8a8f4a8 (patch)
tree29adfe29a5e5e2b308963e4b57c44d5aa737f112
downloadaur-e313a733c507fed8f8ccf4f5e1f464c1c8a8f4a8.tar.gz
Initial commit
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD65
-rw-r--r--gtk-query-immodules-3.0.hook11
-rw-r--r--gtk3.install3
-rw-r--r--settings.ini4
5 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..740dfa617840
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,55 @@
+pkgbase = gtk3-adwaita-3-32-git
+ pkgdesc = GObject-based multi-platform GUI toolkit
+ pkgver = 3.24.2+98+g78d2b673b4
+ pkgrel = 1
+ url = https://www.gtk.org/
+ install = gtk3.install
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = git
+ makedepends = glib2-docs
+ makedepends = sassc
+ depends = atk
+ depends = cairo
+ depends = libxcursor
+ depends = libxinerama
+ depends = libxrandr
+ depends = libxi
+ depends = libepoxy
+ depends = gdk-pixbuf2
+ depends = dconf
+ depends = libxcomposite
+ depends = libxdamage
+ depends = pango
+ depends = shared-mime-info
+ depends = at-spi2-atk
+ depends = wayland
+ depends = libxkbcommon
+ depends = adwaita-icon-theme
+ depends = json-glib
+ depends = librsvg
+ depends = wayland-protocols
+ depends = desktop-file-utils
+ depends = mesa
+ depends = cantarell-fonts
+ depends = colord
+ depends = rest
+ depends = libcups
+ depends = libcanberra
+ depends = gtk-update-icon-cache
+ provides = gtk3
+ provides = gtk3-print-backends
+ conflicts = gtk3
+ conflicts = gtk3-print-backends
+ replaces = gtk3-print-backends<=3.22.26-1
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#branch=wip/jimmac/adwaita-3-32
+ source = settings.ini
+ source = gtk-query-immodules-3.0.hook
+ sha256sums = SKIP
+ sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
+ sha256sums = de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845
+
+pkgname = gtk3-adwaita-3-32-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31af3b9252dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Ricardo Liang (rliang) <ricardoliang@gmail.com>
+
+pkgname=gtk3-adwaita-3-32-git
+pkgver=3.24.2+98+g78d2b673b4
+pkgrel=1
+pkgdesc="GObject-based multi-platform GUI toolkit (with new Adwaita theme)"
+arch=(x86_64)
+url="https://www.gtk.org/"
+provides=(gtk3 gtk3-print-backends)
+conflicts=(gtk3 gtk3-print-backends)
+replaces=("gtk3-print-backends<=3.22.26-1")
+depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
+ libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
+ adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
+ cantarell-fonts colord rest libcups libcanberra gtk-update-icon-cache)
+makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
+install=gtk3.install
+license=(LGPL)
+_branch=wip/jimmac/adwaita-3-32
+source=("git+https://gitlab.gnome.org/GNOME/gtk.git#branch=$_branch"
+ settings.ini
+ gtk-query-immodules-3.0.hook)
+sha256sums=('SKIP'
+ '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
+ 'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845')
+
+pkgver() {
+ cd gtk
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd gtk
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd gtk
+
+ CXX=/bin/false ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-schemas-compile \
+ --enable-x11-backend \
+ --enable-broadway-backend \
+ --enable-wayland-backend \
+ --enable-gtk-doc
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+
+ DESTDIR="$pkgdir" make -C gtk install
+
+ install -Dt "$pkgdir/usr/share/gtk-3.0" -m644 settings.ini
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-query-immodules-3.0.hook
+
+ rm "$pkgdir/usr/bin/gtk-update-icon-cache"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gtk-query-immodules-3.0.hook b/gtk-query-immodules-3.0.hook
new file mode 100644
index 000000000000..c7703cf432c1
--- /dev/null
+++ b/gtk-query-immodules-3.0.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gtk-3.0/3.0.0/immodules/*.so
+
+[Action]
+Description = Probing GTK3 input method modules...
+When = PostTransaction
+Exec = /usr/bin/gtk-query-immodules-3.0 --update-cache
diff --git a/gtk3.install b/gtk3.install
new file mode 100644
index 000000000000..c0c44539de6f
--- /dev/null
+++ b/gtk3.install
@@ -0,0 +1,3 @@
+pre_remove() {
+ rm -f /usr/lib/gtk-3.0/3.0.0/immodules.cache
+}
diff --git a/settings.ini b/settings.ini
new file mode 100644
index 000000000000..921d1ddeec01
--- /dev/null
+++ b/settings.ini
@@ -0,0 +1,4 @@
+[Settings]
+gtk-icon-theme-name = Adwaita
+gtk-theme-name = Adwaita
+gtk-font-name = Cantarell 11