aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Pinchuk2017-04-22 18:33:16 +0300
committerVladimir Pinchuk2017-04-22 18:33:16 +0300
commit84e52cdfe9b5a096f84892f938780fa0379eb19d (patch)
treed71883ca72ed43965bdc55fa51e3959758855299
parent9bdcae1cc973930a8e1812bd6d8630351e890315 (diff)
downloadaur-84e52cdfe9b5a096f84892f938780fa0379eb19d.tar.gz
Now local_only=0 in file chooser regardless of application's will
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--never_local_only.patch40
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 099735fe2f5e..665951791ea9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -52,6 +52,7 @@ pkgbase = gtk3-cosy
source = print-dialog__appearance.patch
source = print-dialog__default-previewer.patch
source = typeahead.patch
+ source = never_local_only.patch
source = https://github.com/GNOME/gtk/archive/3.22.12.tar.gz
source = settings.ini
source = gtk-query-immodules-3.0.hook
@@ -66,6 +67,7 @@ pkgbase = gtk3-cosy
sha256sums = f14cd9983ada3fab3f22ce6ef7fcdd6afb9253f0bf5b9de20255fe0e8c56d685
sha256sums = 886f9ca521285974617eff66e5060b429c4be56b205444e457b6bfdd24f60ca4
sha256sums = 958e7188f23ed5937bcb0f5c09c87332bcea0ca66b0333390d0de73b2ccbae82
+ sha256sums = 58239e4945feca905788c192716073939e3dc8ceeb5d25e9fa024f0b1ed328ca
sha256sums = bec9108c4892041988635f7e276724828b17a0522b211c190530a1f76f88cbae
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845
diff --git a/PKGBUILD b/PKGBUILD
index bded4630edc8..e738010b65e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,7 @@ source=(
"print-dialog__appearance.patch"
"print-dialog__default-previewer.patch"
"typeahead.patch"
+ "never_local_only.patch"
"https://github.com/GNOME/gtk/archive/$pkgver.tar.gz"
settings.ini
@@ -44,6 +45,7 @@ sha256sums=('d8214e11bfcee96552ce5911b1d172ce8076313685d5897f9bd0655df546341b'
'f14cd9983ada3fab3f22ce6ef7fcdd6afb9253f0bf5b9de20255fe0e8c56d685'
'886f9ca521285974617eff66e5060b429c4be56b205444e457b6bfdd24f60ca4'
'958e7188f23ed5937bcb0f5c09c87332bcea0ca66b0333390d0de73b2ccbae82'
+ '58239e4945feca905788c192716073939e3dc8ceeb5d25e9fa024f0b1ed328ca'
'bec9108c4892041988635f7e276724828b17a0522b211c190530a1f76f88cbae'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845')
@@ -62,6 +64,7 @@ prepare() {
patch "$gtk_source/gtkfilechooserwidget.c" "file-chooser__single-click.patch"
patch "$gtk_source/ui/gtkfilechooserwidget.ui" "file-chooser__disable-other-locations.patch"
patch "$gtk_source/gtkfilechooserwidget.c" -i "typeahead.patch"
+ patch "$gtk_source/gtkfilechooserwidget.c" -i "never_local_only.patch"
# print dialog
patch "$gtk_source/gtksettings.c" "print-dialog__default-previewer.patch"
diff --git a/never_local_only.patch b/never_local_only.patch
new file mode 100644
index 000000000000..d66a7c3b91df
--- /dev/null
+++ b/never_local_only.patch
@@ -0,0 +1,40 @@
+--- gtk-orig/gtk/gtkfilechooserwidget.c 2017-04-08 22:15:58.000000000 +0300
++++ gtk-mod/gtk/gtkfilechooserwidget.c 2017-04-22 15:42:26.970387421 +0300
+@@ -2614,7 +2614,7 @@
+ g_signal_connect_swapped (priv->location_entry, "hide-entry",
+ G_CALLBACK (location_entry_close_clicked), impl);
+
+- _gtk_file_chooser_entry_set_local_only (GTK_FILE_CHOOSER_ENTRY (priv->location_entry), priv->local_only);
++ _gtk_file_chooser_entry_set_local_only (GTK_FILE_CHOOSER_ENTRY (priv->location_entry), 0);
+ _gtk_file_chooser_entry_set_action (GTK_FILE_CHOOSER_ENTRY (priv->location_entry), priv->action);
+ _gtk_file_chooser_entry_set_file_filter (GTK_FILE_CHOOSER_ENTRY (priv->location_entry),
+ priv->current_filter);
+@@ -2977,6 +2977,7 @@
+ set_local_only (GtkFileChooserWidget *impl,
+ gboolean local_only)
+ {
++ local_only=0;
+ GtkFileChooserWidgetPrivate *priv = impl->priv;
+
+ if (local_only != priv->local_only)
+@@ -2984,9 +2985,9 @@
+ priv->local_only = local_only;
+
+ if (priv->location_entry)
+- _gtk_file_chooser_entry_set_local_only (GTK_FILE_CHOOSER_ENTRY (priv->location_entry), local_only);
++ _gtk_file_chooser_entry_set_local_only (GTK_FILE_CHOOSER_ENTRY (priv->location_entry), 0);
+
+- gtk_places_sidebar_set_local_only (GTK_PLACES_SIDEBAR (priv->places_sidebar), local_only);
++ gtk_places_sidebar_set_local_only (GTK_PLACES_SIDEBAR (priv->places_sidebar), 0);
+
+ if (local_only && priv->current_folder &&
+ !_gtk_file_has_native_path (priv->current_folder))
+@@ -8652,7 +8653,7 @@
+ impl->priv = gtk_file_chooser_widget_get_instance_private (impl);
+ priv = impl->priv;
+
+- priv->local_only = TRUE;
++ priv->local_only = FALSE;
+ priv->preview_widget_active = TRUE;
+ priv->use_preview_label = TRUE;
+ priv->select_multiple = FALSE;