summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Jochmaring2016-01-28 23:31:33 +0100
committerJonas Jochmaring2016-01-28 23:31:33 +0100
commit9e7da6d426b74ae88587f16e48e15a9e7016fe01 (patch)
tree3632b6164a59ffb72d356bdf9b8c8619fa5d6af6
parentbd531548681dc2d87e9e3852f9b33b818c163235 (diff)
downloadaur-9e7da6d426b74ae88587f16e48e15a9e7016fe01.tar.gz
updated to 3.18.7-1
-rw-r--r--.SRCINFO17
-rw-r--r--0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch85
-rw-r--r--0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch94
-rw-r--r--PKGBUILD17
4 files changed, 12 insertions, 201 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1150c47ce2aa..485456eb385d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jan 9 23:43:05 UTC 2016
+# Thu Jan 28 22:31:16 UTC 2016
pkgbase = gtk3-light
pkgdesc = GTK3 without colord.
- pkgver = 3.18.6
- pkgrel = 2
+ pkgver = 3.18.7
+ pkgrel = 1
url = http://www.gtk.org/
install = gtk3.install
arch = i686
@@ -11,6 +11,7 @@ pkgbase = gtk3-light
license = LGPL
makedepends = gobject-introspection
makedepends = libcanberra
+ makedepends = gtk-doc
depends = atk
depends = cairo
depends = gtk-update-icon-cache
@@ -32,17 +33,13 @@ pkgbase = gtk3-light
depends = rest
depends = gtk-update-icon-cache
optdepends = libcanberra: gtk3-widget-factory demo
- provides = gtk3=3.18.6
+ provides = gtk3=3.18.7
conflicts = gtk3
options = !docs
backup = etc/gtk-3.0/settings.ini
- source = https://download.gnome.org/sources/gtk+/3.18/gtk+-3.18.6.tar.xz
- source = 0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
- source = 0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+ source = https://download.gnome.org/sources/gtk+/3.18/gtk+-3.18.7.tar.xz
source = settings.ini
- sha256sums = 78cabf0fd5a662f8723f62d5ac633072c76c557c1d700454c9c3deaa37e441ef
- sha256sums = 0402c3b7801810beb0f24ad20e4fb2eb7519cf3984f39e093a6e2752a0f7d9de
- sha256sums = 94722b06284e76f628fc8933617ac19c14f6775a5250fe3c382defab63d7b10e
+ sha256sums = a76e1cb0ac45ce5c2734f6778f2731a5c6a23d1ff6bd4db357774f014ee68820
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
pkgname = gtk3-light
diff --git a/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch b/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
deleted file mode 100644
index d187d40246dd..000000000000
--- a/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From affd6e70734d7897324409d6fc0beb7b4eb7235a Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Wed, 6 Jan 2016 14:54:33 -0500
-Subject: [PATCH 1/2] x11: Only do cursor name fallback for standard names
-
-Always returning a left_ptr if we can't find anything better
-broke firefox application-specific fallback for missing cursors.
-Keep that working by only doing the fallback for the CSS cursor
-names, not for things like hashes.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=760141
----
- gdk/x11/gdkcursor-x11.c | 24 ++++++++++++++++++++----
- 1 file changed, 20 insertions(+), 4 deletions(-)
-
-diff --git a/gdk/x11/gdkcursor-x11.c b/gdk/x11/gdkcursor-x11.c
-index 540f48e..d619f58 100644
---- a/gdk/x11/gdkcursor-x11.c
-+++ b/gdk/x11/gdkcursor-x11.c
-@@ -611,17 +611,23 @@ static const struct {
- const gchar *css_name, *traditional_name;
- } name_map[] = {
- { "default", "left_ptr" },
-+ { "help", "left_ptr" },
-+ { "context-menu", "left_ptr" },
- { "pointer", "hand" },
- { "progress", "left_ptr_watch" },
- { "wait", "watch" },
- { "cell", "crosshair" },
- { "crosshair", "cross" },
- { "text", "xterm" },
-+ { "vertical-text","xterm" },
- { "alias", "dnd-link" },
- { "copy", "dnd-copy" },
-+ { "move", "dnd-move" },
- { "no-drop", "dnd-none" },
- { "not-allowed", "crossed_circle" },
- { "grab", "hand2" },
-+ { "grabbing", "hand2" },
-+ { "all-scroll", "left_ptr" },
- { "col-resize", "h_double_arrow" },
- { "row-resize", "v_double_arrow" },
- { "n-resize", "top_side" },
-@@ -636,6 +642,8 @@ static const struct {
- { "ns-resize", "v_double_arrow" },
- { "nesw-resize", "fd_double_arrow" },
- { "nwse-resize", "bd_double_arrow" },
-+ { "zoom-in", "left_ptr" },
-+ { "zoom-out", "left_ptr" },
- { NULL, NULL }
- };
-
-@@ -650,7 +658,7 @@ name_fallback (const gchar *name)
- return name_map[i].traditional_name;
- }
-
-- return "left_ptr";
-+ return NULL;
- }
-
- GdkCursor*
-@@ -683,9 +691,17 @@ _gdk_x11_display_get_cursor_for_name (GdkDisplay *display,
- xdisplay = GDK_DISPLAY_XDISPLAY (display);
- xcursor = XcursorLibraryLoadCursor (xdisplay, name);
- if (xcursor == None)
-- xcursor = XcursorLibraryLoadCursor (xdisplay, name_fallback (name));
-- if (xcursor == None)
-- xcursor = XcursorLibraryLoadCursor (xdisplay, "left_ptr");
-+ {
-+ const char *fallback;
-+
-+ fallback = name_fallback (name);
-+ if (fallback)
-+ {
-+ xcursor = XcursorLibraryLoadCursor (xdisplay, fallback);
-+ if (xcursor == None)
-+ xcursor = XcursorLibraryLoadCursor (xdisplay, "left_ptr");
-+ }
-+ }
- if (xcursor == None)
- return NULL;
- }
---
-2.7.0
-
diff --git a/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch b/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
deleted file mode 100644
index 94b69fb6d9ae..000000000000
--- a/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 81a287478a4db9ce650cc764474b9c173b137dee Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Wed, 6 Jan 2016 14:56:06 -0500
-Subject: [PATCH 2/2] wayland: Only do cursor name fallback for standard names
-
-Always returning a left_ptr if we can't find anything better
-broke firefox application-specific fallback for missing cursors.
-Keep that working by only doing the fallback for the CSS cursor
-names, not for things like hashes.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=760141
----
- gdk/wayland/gdkcursor-wayland.c | 29 +++++++++++++++++++++--------
- 1 file changed, 21 insertions(+), 8 deletions(-)
-
-diff --git a/gdk/wayland/gdkcursor-wayland.c b/gdk/wayland/gdkcursor-wayland.c
-index 8aee5ae..bdfa316 100644
---- a/gdk/wayland/gdkcursor-wayland.c
-+++ b/gdk/wayland/gdkcursor-wayland.c
-@@ -87,17 +87,23 @@ static const struct {
- const gchar *css_name, *traditional_name;
- } name_map[] = {
- { "default", "left_ptr" },
-+ { "help", "left_ptr" },
-+ { "context-menu", "left_ptr" },
- { "pointer", "hand" },
- { "progress", "left_ptr_watch" },
- { "wait", "watch" },
- { "cell", "crosshair" },
- { "crosshair", "cross" },
- { "text", "xterm" },
-+ { "vertical-text","xterm" },
- { "alias", "dnd-link" },
- { "copy", "dnd-copy" },
-+ { "move", "dnd-move" },
- { "no-drop", "dnd-none" },
- { "not-allowed", "crossed_circle" },
- { "grab", "hand2" },
-+ { "grabbing", "hand2" },
-+ { "all-scroll", "left_ptr" },
- { "col-resize", "h_double_arrow" },
- { "row-resize", "v_double_arrow" },
- { "n-resize", "top_side" },
-@@ -112,6 +118,8 @@ static const struct {
- { "ns-resize", "v_double_arrow" },
- { "nesw-resize", "fd_double_arrow" },
- { "nwse-resize", "bd_double_arrow" },
-+ { "zoom-in", "left_ptr" },
-+ { "zoom-out", "left_ptr" },
- { NULL, NULL }
- };
-
-@@ -126,7 +134,7 @@ name_fallback (const gchar *name)
- return name_map[i].traditional_name;
- }
-
-- return "left_ptr";
-+ return NULL;
- }
-
- static gboolean
-@@ -144,17 +152,22 @@ _gdk_wayland_cursor_update (GdkWaylandDisplay *wayland_display,
- cursor->scale);
- c = wl_cursor_theme_get_cursor (theme, cursor->name);
- if (!c)
-- c = wl_cursor_theme_get_cursor (theme, name_fallback (cursor->name));
-+ {
-+ const char *fallback;
-+
-+ fallback = name_fallback (cursor->name);
-+ if (fallback)
-+ {
-+ c = wl_cursor_theme_get_cursor (theme, name_fallback (cursor->name));
-+ if (!c)
-+ c = wl_cursor_theme_get_cursor (theme, "left_ptr");
-+ }
-+ }
-
- if (!c)
- {
- g_warning (G_STRLOC ": Unable to load %s from the cursor theme", cursor->name);
--
-- /* return the left_ptr cursor as a fallback */
-- c = wl_cursor_theme_get_cursor (theme, "left_ptr");
--
-- if (!c)
-- return FALSE;
-+ return FALSE;
- }
-
- cursor->wl_cursor = c;
---
-2.7.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 06a62b6e0720..10ebc6167e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
pkgname=gtk3-light
-pkgver=3.18.6
-pkgrel=2
+pkgver=3.18.7
+pkgrel=1
pkgdesc="GTK3 without colord."
arch=('i686' 'x86_64')
url="http://www.gtk.org/"
@@ -16,7 +16,7 @@ install=gtk3.install
depends=('atk' 'cairo' 'gtk-update-icon-cache' 'libcups' 'libxcursor' 'libxinerama' 'libxrandr' 'libxi' 'libepoxy'
'libxcomposite' 'libxdamage' 'pango' 'shared-mime-info' 'at-spi2-atk' 'wayland' 'libxkbcommon'
'adwaita-icon-theme' 'json-glib' 'rest' 'gtk-update-icon-cache')
-makedepends=('gobject-introspection' 'libcanberra')
+makedepends=('gobject-introspection' 'libcanberra' 'gtk-doc')
optdepends=('libcanberra: gtk3-widget-factory demo')
provides=("gtk3=$pkgver")
conflicts=('gtk3')
@@ -24,21 +24,14 @@ options=('!docs') # Remove '!docs' if you want gtk3 docs
backup=(etc/gtk-3.0/settings.ini)
license=('LGPL')
source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
- 0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
- 0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
settings.ini)
-sha256sums=('78cabf0fd5a662f8723f62d5ac633072c76c557c1d700454c9c3deaa37e441ef'
- '0402c3b7801810beb0f24ad20e4fb2eb7519cf3984f39e093a6e2752a0f7d9de'
- '94722b06284e76f628fc8933617ac19c14f6775a5250fe3c382defab63d7b10e'
+sha256sums=('a76e1cb0ac45ce5c2734f6778f2731a5c6a23d1ff6bd4db357774f014ee68820'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202')
prepare() {
cd gtk+-$pkgver
- # Fix zoom in/out cursors in GTK3 builds of Firefox
- # https://bugzilla.gnome.org/show_bug.cgi?id=760141
- patch -Np1 -i ../0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
- patch -Np1 -i ../0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {