aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Gąsior2018-06-01 23:51:21 +0200
committerTomasz Gąsior2018-06-01 23:51:21 +0200
commit5f22b91027f6836be74730533cdae4c010915e95 (patch)
treeee2401392222d1baef99b0a69144b58219dddf49
parent02d3c7c8586d899ef756c2636aa8749a8ebc7ae4 (diff)
downloadaur-5f22b91027f6836be74730533cdae4c010915e95.tar.gz
Window background patch fixed.
- Window background patch is activated only when window manager does not support client side shadows. This change fixes bug in Awesome and i3 wm-s. It's temporary fix.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD4
-rw-r--r--README.md2
-rw-r--r--fixes__window-background.patch15
5 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91a3a85defe6..5c5e4acad294 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtk3-mushrooms
pkgdesc = GTK3 patched for classic desktops like MATE/XFCE (see README).
pkgver = 3.22.30
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/TomaszGasior/gtk3-mushrooms
arch = x86_64
license = LGPL
@@ -82,7 +82,7 @@ pkgbase = gtk3-mushrooms
sha256sums = 99b12d7af7efc6a014e6afcab1ee82ea0feb0b5a4e9bbd663d1c45354cd34f2b
sha256sums = 7a604d453beb9c425b8ed4a60b5e9435c3f4ee10438490641c0ade448401306a
sha256sums = d4d27ccc5735ee1d2c8483da659ded3a05e9d33b3fe41d8ed77495e9ec38be96
- sha256sums = ba3dc10e116edc96e53867953bfa00d408fcc6ec55913553669be90bea5ad90d
+ sha256sums = ad9e393da9d6f8c6750fff122b2f2b6ba1f6ba99439259ce4b5f3c9bbaca7e41
sha256sums = 37e3278dd33542b706eb9e1db56997b194a7e2f1fd729a8511369387a74b22bd
sha256sums = acd3babd22add981690728e84a89fb8bb332b7ac746e9db7cdb27c47f1ac0042
sha256sums = c213812e1fafeb5565f7e329c4501195f04adcfe377b88439a6d51d478edc071
diff --git a/.gitignore b/.gitignore
index 39c600442b2f..a4687e07de84 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@ src
*.tar.gz
gtk-query-immodules-3.0.hook
settings.ini
+*._patch \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 21d29e531016..9e4f025e680d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ __arch_pkg_commit="fbcc57e8a97827926b6624bb8bc570f675c7188d"
pkgname=gtk3-mushrooms
pkgver=3.22.30
-pkgrel=5
+pkgrel=6
pkgdesc="GTK3 patched for classic desktops like MATE/XFCE (see README)."
url="https://github.com/TomaszGasior/gtk3-mushrooms"
conflicts=(gtk3 gtk3-print-backends)
@@ -83,7 +83,7 @@ sha256sums=(
"99b12d7af7efc6a014e6afcab1ee82ea0feb0b5a4e9bbd663d1c45354cd34f2b"
"7a604d453beb9c425b8ed4a60b5e9435c3f4ee10438490641c0ade448401306a"
"d4d27ccc5735ee1d2c8483da659ded3a05e9d33b3fe41d8ed77495e9ec38be96"
- "ba3dc10e116edc96e53867953bfa00d408fcc6ec55913553669be90bea5ad90d"
+ "ad9e393da9d6f8c6750fff122b2f2b6ba1f6ba99439259ce4b5f3c9bbaca7e41"
"37e3278dd33542b706eb9e1db56997b194a7e2f1fd729a8511369387a74b22bd"
"acd3babd22add981690728e84a89fb8bb332b7ac746e9db7cdb27c47f1ac0042"
"c213812e1fafeb5565f7e329c4501195f04adcfe377b88439a6d51d478edc071"
diff --git a/README.md b/README.md
index a3aadde3aca4..86dcb0a599bb 100644
--- a/README.md
+++ b/README.md
@@ -52,4 +52,4 @@ Fixes
* Menu bars are not covered by too high popup menus. See https://gitlab.gnome.org/GNOME/gtk/issues/1016.
* Labels are wrapped similarly to GTK2. This patch fixes too wide windows in applications improperly ported from GTK2.
* Errors in console output because of integration with Accessibility Toolkit are hidden. See https://unix.stackexchange.com/questions/230238.
-* Window background is set properly to theme background, only on Xorg when compositor is disabled. \ No newline at end of file
+* Window background is set to theme background, only on Xorg when window manager doesn't support client side shadows. This patch fixes bug in i3 and Awesome window managers. See https://github.com/i3/i3/issues/3297. \ No newline at end of file
diff --git a/fixes__window-background.patch b/fixes__window-background.patch
index 7d1a8d78ed17..4ccb52c4d1dc 100644
--- a/fixes__window-background.patch
+++ b/fixes__window-background.patch
@@ -1,15 +1,18 @@
diff --color -U 5 -r -Z -B ./org/gtk/gtkwindow.c ./mod/gtk/gtkwindow.c
---- ./org/gtk/gtkwindow.c 2017-10-27 22:06:52.000000000 +0200
-+++ ./mod/gtk/gtkwindow.c 2017-10-30 21:27:43.370340735 +0100
-@@ -7428,10 +7428,12 @@
+--- ./org/gtk/gtkwindow.c 2018-01-15 14:21:38.000000000 +0100
++++ ./mod/gtk/gtkwindow.c 2018-06-01 23:18:47.828882837 +0200
+@@ -7435,10 +7435,15 @@
}
-
+
gtk_widget_set_window (widget, gdk_window);
gtk_widget_register_window (widget, gdk_window);
gtk_widget_set_realized (widget, TRUE);
-+ if (!gdk_screen_is_composited (priv->screen) && !gtk_widget_get_app_paintable (widget))
++#ifdef GDK_WINDOWING_X11
++ if (GDK_IS_X11_DISPLAY (gtk_widget_get_display (widget)) && !gtk_widget_get_app_paintable (widget) &&
++ !gdk_x11_screen_supports_net_wm_hint (priv->screen, gdk_atom_intern_static_string ("_GTK_FRAME_EXTENTS")))
+ gtk_style_context_set_background (gtk_widget_get_style_context (widget), gdk_window);
-
++#endif
+
attributes.x = allocation.x;
attributes.y = allocation.y;
attributes.width = allocation.width;