aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Gąsior2017-06-03 17:38:49 +0200
committerTomasz Gąsior2017-06-03 17:38:49 +0200
commit84a3d8f6ba10e635a818b6b4a919df187495d8dc (patch)
tree2f02771d50a37fdf02bbe900464f9ce3d0440a04
parent355dd3a35639251e6c07f50782acea620421cad5 (diff)
downloadaur-84a3d8f6ba10e635a818b6b4a919df187495d8dc.tar.gz
Fix of CUPS support in print dialog.
-rw-r--r--PKGBUILD8
-rw-r--r--README.md2
2 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fe9e943c81d..f20170e5b0fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gtk3-mushrooms
pkgver=3.22.15
-pkgrel=2
+pkgrel=3
pkgdesc="GTK3 library with my modifications (see README)."
url="http://www.gtk.org/"
install=gtk3.install
@@ -69,9 +69,8 @@ build() {
cd "$srcdir/gtk-$pkgver"
CXX=/bin/false ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --enable-x11-backend --disable-schemas-compile --disable-gtk-doc-html \
- --disable-installed-tests --disable-colord --disable-maintainer-mode \
- --disable-cups --disable-cloudprint --disable-papi --disable-man
+ --enable-x11-backend --disable-schemas-compile --disable-gtk-doc-html --disable-man \
+ --disable-installed-tests --disable-colord --disable-maintainer-mode
#https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -98,4 +97,5 @@ package() {
install -Dm644 ../gtk-query-immodules-3.0.hook "$pkgdir/usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook"
rm "$pkgdir/usr/bin/gtk-update-icon-cache"
+ rm `find "$pkgdir/usr/lib/gtk-3.0/3.0.0/printbackends/"* | grep -v "\-lpr.so" | grep -v "\-file.so"`
}
diff --git a/README.md b/README.md
index 716a10b2e966..baee519d3709 100644
--- a/README.md
+++ b/README.md
@@ -3,7 +3,7 @@
This is a set of patches for GTK3 library that makes it better for me and maybe for you too. ;-) I have not wide knowledge about programming in C, so quality of this patches can be not good. But it works! See list of patches below.
-This package is based on official GTK3 package from Arch Linux. In my version library is compiled without Broadway backend, Wayland support, documentation and example applications. I do not recommend using this package with GNOME desktop. It is for classic GTK-based environments like MATE or XFCE.
+This package is based on official GTK3 package from Arch Linux. In my version library is compiled without Broadway backend, Wayland support, documentation and example applications. Using this package with GNOME desktop is not recommended. It is for classic GTK-based environments like MATE or XFCE.
Client Side Decorations
---