aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Gąsior2017-09-09 21:02:54 +0200
committerTomasz Gąsior2017-09-09 21:02:54 +0200
commitce041c4ba89f01eeb139f528fe810262c4ed16a9 (patch)
treeb9e646da213fb9bc1a12f0ef7a19de2714b03f1d
parent62f18c9b4c1e90c2441d4d13995206f30559aaab (diff)
downloadaur-ce041c4ba89f01eeb139f528fe810262c4ed16a9.tar.gz
GTK updated.
- dconf as optional dependence. It is possible to use GTK3 and GSettings-based applications without dconf. dconf can be replaced by gconf (with GSETTINGS_BACKEND=gconf environment variable) or with memory backend. - Source of GTK code changed from GitHub to download.gnome.org.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD21
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 920d1b425be6..a266064c1951 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtk3-mushrooms
pkgdesc = GTK3 library with my modifications (see README).
- pkgver = 3.22.19
- pkgrel = 2
+ pkgver = 3.22.20
+ pkgrel = 1
url = http://www.gtk.org/
arch = i686
arch = x86_64
@@ -17,7 +17,6 @@ pkgbase = gtk3-mushrooms
depends = libxi
depends = libepoxy
depends = gdk-pixbuf2
- depends = dconf
depends = libxcomposite
depends = libxdamage
depends = pango
@@ -32,9 +31,10 @@ pkgbase = gtk3-mushrooms
depends = mesa
depends = gtk-update-icon-cache
optdepends = gtk3-print-backends: printing
+ optdepends = dconf: default GSettings backend
optdepends = adwaita-icon-theme: default icon theme
optdepends = cantarell-fonts: default font
- provides = gtk3=3.22.19
+ provides = gtk3=3.22.20
conflicts = gtk3
source = csd__clean-headerbar.patch
source = csd__disabled-by-default.patch
@@ -58,7 +58,7 @@ pkgbase = gtk3-mushrooms
source = print-dialog__appearance.patch
source = print-dialog__default-previewer.patch
source = smaller-adwaita.css
- source = https://github.com/GNOME/gtk/archive/3.22.19.tar.gz
+ source = https://download.gnome.org/sources/gtk+/3.22/gtk+-3.22.20.tar.xz
source = settings.ini::https://git.archlinux.org/svntogit/packages.git/plain/trunk/settings.ini?h=packages/gtk3&id=eb853c7714b8675246344169980ace3f4e18aac3
source = gtk-query-immodules-3.0.hook::https://git.archlinux.org/svntogit/packages.git/plain/trunk/gtk-query-immodules-3.0.hook?h=packages/gtk3&id=eb853c7714b8675246344169980ace3f4e18aac3
sha256sums = 7a1f4259502eea2f610df3ed8f82fc929fce1ebe92422327f54aa41ddf47e7f8
@@ -83,7 +83,7 @@ pkgbase = gtk3-mushrooms
sha256sums = b479fe0a82db21475fde30d9daad4360552b67957479773a1216058c7ff46629
sha256sums = 23cdd8b8034e73bb852d42feaabf4f995983a032be479d9ce84e5858c0bd5c41
sha256sums = 0554ba2085fb8cec8e3b926efc250ae5c15cf47f2612c10cdd0e849bfb8d05a5
- sha256sums = 4b86fbb917fd6242684e815482b6c495015ae86260f8919c9cb5bcdbd25a3e3f
+ sha256sums = 70c90998a7809f60dc0a7439a68c34e59077dadb631657a6f9cab6a5539c02d9
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845
diff --git a/.gitignore b/.gitignore
index 8948decea19e..28b8c7a7bc46 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,7 +2,7 @@ pkg
src
*.pkg.tar.xz
-*.tar.gz
+*.tar.xz
gtk-query-immodules-3.0.hook
settings.ini
diff --git a/PKGBUILD b/PKGBUILD
index 9ba7a142a8f4..b6deb66d8667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
__arch_pkg_commit="eb853c7714b8675246344169980ace3f4e18aac3"
pkgname=gtk3-mushrooms
-pkgver=3.22.19
-pkgrel=2
+pkgver=3.22.20
+pkgrel=1
pkgdesc="GTK3 library with my modifications (see README)."
url="http://www.gtk.org/"
conflicts=(gtk3)
@@ -15,12 +15,13 @@ provides=("gtk3=$pkgver")
arch=(i686 x86_64)
license=(LGPL)
depends=(
- atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
+ atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
json-glib librsvg wayland-protocols desktop-file-utils mesa gtk-update-icon-cache
)
optdepends=(
'gtk3-print-backends: printing'
+ 'dconf: default GSettings backend'
'adwaita-icon-theme: default icon theme'
'cantarell-fonts: default font'
)
@@ -54,8 +55,8 @@ source=(
# Theme CSS stylesheet.
"smaller-adwaita.css"
- # GTK source code from GitHub.
- "https://github.com/GNOME/gtk/archive/$pkgver.tar.gz"
+ # GTK source code.
+ "https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz"
# ArchLinux package files.
"settings.ini::https://git.archlinux.org/svntogit/packages.git/plain/trunk/settings.ini?h=packages/gtk3&id=$__arch_pkg_commit"
@@ -88,8 +89,8 @@ sha256sums=(
# Theme CSS stylesheet.
"0554ba2085fb8cec8e3b926efc250ae5c15cf47f2612c10cdd0e849bfb8d05a5"
- # GTK source code from GitHub.
- "4b86fbb917fd6242684e815482b6c495015ae86260f8919c9cb5bcdbd25a3e3f"
+ # GTK source code.
+ "70c90998a7809f60dc0a7439a68c34e59077dadb631657a6f9cab6a5539c02d9"
# ArchLinux package files.
"01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202"
@@ -137,7 +138,7 @@ __patch_gtk_code()
prepare()
{
- cd "$srcdir/gtk-$pkgver"
+ cd "$srcdir/gtk+-$pkgver"
# Make building faster by skipping tests, code examples and unused elements.
__patch_makefiles
@@ -150,7 +151,7 @@ prepare()
build()
{
- cd "$srcdir/gtk-$pkgver"
+ cd "$srcdir/gtk+-$pkgver"
CXX=/bin/false ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--enable-x11-backend --enable-wayland-backend --disable-schemas-compile \
@@ -164,7 +165,7 @@ build()
package()
{
- cd "$srcdir/gtk-$pkgver"
+ cd "$srcdir/gtk+-$pkgver"
make -j 15 DESTDIR="$pkgdir" install
install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"