aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Gąsior2018-01-21 19:56:06 +0100
committerTomasz Gąsior2018-01-21 19:56:06 +0100
commitdf0622d0b0fb5065cb3428a35ec12190254bfb94 (patch)
tree1eaa67ab98f4d957bd2085b6112a0a34e94f78ec
parente9ceba3686453c69d386bf220bfcd393567fd60a (diff)
downloadaur-df0622d0b0fb5065cb3428a35ec12190254bfb94.tar.gz
Too large menu fix.
If menu is too large, menu bar is covered by popup menu.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--README.md9
-rw-r--r--fixes__atk-bridge-errors.patch (renamed from other__atk-bridge-errors.patch)0
-rw-r--r--fixes__too-large-menu-covers-bar.patch20
-rw-r--r--fixes__window-background.patch (renamed from other__window-background.patch)0
6 files changed, 42 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb75b5d9844a..ed09617ad60d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtk3-mushrooms
pkgdesc = GTK3 library with my modifications (see README).
pkgver = 3.22.26
- pkgrel = 3
+ pkgrel = 4
url = http://www.gtk.org/
arch = x86_64
license = LGPL
@@ -55,18 +55,19 @@ pkgbase = gtk3-mushrooms
source = file-chooser__places-sidebar.patch
source = file-chooser__single-click.patch
source = file-chooser__typeahead.patch
- source = other__atk-bridge-errors.patch
+ source = fixes__atk-bridge-errors.patch
+ source = fixes__too-large-menu-covers-bar.patch
+ source = fixes__window-background.patch
source = other__hide-insert-emoji.patch
source = other__mnemonics-delay.patch
- source = other__window-background.patch
source = popovers__color-chooser.patch
source = popovers__file-chooser-list.patch
source = popovers__menu-button.patch
source = popovers__places-sidebar.patch
source = smaller-adwaita.css
source = https://download.gnome.org/sources/gtk+/3.22/gtk+-3.22.26.tar.xz
- source = settings.ini::https://git.archlinux.org/svntogit/packages.git/plain/trunk/settings.ini?h=packages/gtk3&id=ced279e9020925d34991926230a754bd1650da2f
- source = gtk-query-immodules-3.0.hook::https://git.archlinux.org/svntogit/packages.git/plain/trunk/gtk-query-immodules-3.0.hook?h=packages/gtk3&id=ced279e9020925d34991926230a754bd1650da2f
+ source = settings.ini::https://git.archlinux.org/svntogit/packages.git/plain/trunk/settings.ini?h=packages/gtk3&id=3ed0d6c684888661be2a74a200571d981a3275d0
+ source = gtk-query-immodules-3.0.hook::https://git.archlinux.org/svntogit/packages.git/plain/trunk/gtk-query-immodules-3.0.hook?h=packages/gtk3&id=3ed0d6c684888661be2a74a200571d981a3275d0
sha256sums = 68b26360764a2ea7e057a2aaa29c6fdfe164b9987866e038d8d0188a025477fb
sha256sums = b2f7d5d3a784b7f833d64c2a278f1d082bec5c53b4cc19602c808223625dedeb
sha256sums = 3d4d9cac36285e19972650a33bdba815096cb256e3f0991914ed3c8c19cfb650
@@ -82,9 +83,10 @@ pkgbase = gtk3-mushrooms
sha256sums = 0cd2cd0365cb532d25ef4587882062f230dfb09f36485c568bdf27c8534831b2
sha256sums = 7b987cc9bd7ca9722bfb881b30b082c0d7409e3cd68592f5e7a1f401d73e7672
sha256sums = 99b12d7af7efc6a014e6afcab1ee82ea0feb0b5a4e9bbd663d1c45354cd34f2b
+ sha256sums = d4d27ccc5735ee1d2c8483da659ded3a05e9d33b3fe41d8ed77495e9ec38be96
+ sha256sums = 3067face12ad74d664ab7951f59026c01eb8070bef007b522eb84aef1576674a
sha256sums = 8009a7eb0e33606526fd73306cf5ade3284ba843694328b32b98b4334410996d
sha256sums = c213812e1fafeb5565f7e329c4501195f04adcfe377b88439a6d51d478edc071
- sha256sums = 3067face12ad74d664ab7951f59026c01eb8070bef007b522eb84aef1576674a
sha256sums = 7f3e5da1622e243243ea9b1e487460f608dc375e79d800d2f0d826fd30be68ed
sha256sums = ef4fed3a364db8eb9c15c9ce0e733035722f168dc88b385df2178fc1168ada54
sha256sums = fe421b6197b4e98254019896ec79ea6b29a2140e7950ce3018ae0e1e4047b0c0
diff --git a/PKGBUILD b/PKGBUILD
index b411cd025caf..06215fff8dca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# This file is based on original PKGBUILD of GTK3 package.
# https://git.archlinux.org/svntogit/packages.git/plain/trunk/PKGBUILD?h=packages/gtk3
-__arch_pkg_commit="ced279e9020925d34991926230a754bd1650da2f"
+__arch_pkg_commit="3ed0d6c684888661be2a74a200571d981a3275d0"
pkgname=gtk3-mushrooms
pkgver=3.22.26
-pkgrel=3
+pkgrel=4
pkgdesc="GTK3 library with my modifications (see README)."
url="http://www.gtk.org/"
conflicts=(gtk3 gtk3-print-backends)
@@ -47,10 +47,11 @@ source=(
"file-chooser__places-sidebar.patch"
"file-chooser__single-click.patch"
"file-chooser__typeahead.patch"
- "other__atk-bridge-errors.patch"
+ "fixes__atk-bridge-errors.patch"
+ "fixes__too-large-menu-covers-bar.patch"
+ "fixes__window-background.patch"
"other__hide-insert-emoji.patch"
"other__mnemonics-delay.patch"
- "other__window-background.patch"
"popovers__color-chooser.patch"
"popovers__file-chooser-list.patch"
"popovers__menu-button.patch"
@@ -82,9 +83,10 @@ sha256sums=(
"0cd2cd0365cb532d25ef4587882062f230dfb09f36485c568bdf27c8534831b2"
"7b987cc9bd7ca9722bfb881b30b082c0d7409e3cd68592f5e7a1f401d73e7672"
"99b12d7af7efc6a014e6afcab1ee82ea0feb0b5a4e9bbd663d1c45354cd34f2b"
+ "d4d27ccc5735ee1d2c8483da659ded3a05e9d33b3fe41d8ed77495e9ec38be96"
+ "3067face12ad74d664ab7951f59026c01eb8070bef007b522eb84aef1576674a"
"8009a7eb0e33606526fd73306cf5ade3284ba843694328b32b98b4334410996d"
"c213812e1fafeb5565f7e329c4501195f04adcfe377b88439a6d51d478edc071"
- "3067face12ad74d664ab7951f59026c01eb8070bef007b522eb84aef1576674a"
"7f3e5da1622e243243ea9b1e487460f608dc375e79d800d2f0d826fd30be68ed"
"ef4fed3a364db8eb9c15c9ce0e733035722f168dc88b385df2178fc1168ada54"
"fe421b6197b4e98254019896ec79ea6b29a2140e7950ce3018ae0e1e4047b0c0"
diff --git a/README.md b/README.md
index 2324695b850f..1647fcdd5a45 100644
--- a/README.md
+++ b/README.md
@@ -45,14 +45,19 @@ Default settings
* Current working directory is opened by default in file chooser dialog instead of section with recently used files.
* Atril instead of Evince is set as default previewer in printing dialog.
-Others
+Other
---
* Delay before showing mnemonics is removed. You don't have to wait when you press Left Alt button.
* "Insert emoji" context menu item of entry fields is hidden. You can restore it by setting `GTKM_INSERT_EMOJI` environment variable.
+* Default Adwaita theme has smaller controls (buttons, fields, tabs, etc.).
+
+Fixes
+---
+
* Window background is set properly to theme background color instead of solid black. See https://bugzilla.gnome.org/show_bug.cgi?id=771708.
* Errors in console output because of integration with Accessibility Toolkit are hidden. See https://unix.stackexchange.com/questions/230238.
-* Default Adwaita theme has smaller controls (buttons, fields, tabs, etc.).
+* Menu bars are not covered by too high popup menus.
--------
diff --git a/other__atk-bridge-errors.patch b/fixes__atk-bridge-errors.patch
index 23e84b8d74ea..23e84b8d74ea 100644
--- a/other__atk-bridge-errors.patch
+++ b/fixes__atk-bridge-errors.patch
diff --git a/fixes__too-large-menu-covers-bar.patch b/fixes__too-large-menu-covers-bar.patch
new file mode 100644
index 000000000000..5e1cd4d91771
--- /dev/null
+++ b/fixes__too-large-menu-covers-bar.patch
@@ -0,0 +1,20 @@
+diff --color -U 5 -r -Z -B ./org/gtk/gtkmenu.c ./mod/gtk/gtkmenu.c
+--- ./org/gtk/gtkmenu.c 2017-10-02 18:00:49.000000000 +0200
++++ ./mod/gtk/gtkmenu.c 2018-01-21 12:47:04.050097042 +0100
+@@ -1393,10 +1393,16 @@
+ const GdkRectangle *final_rect,
+ gboolean flipped_x,
+ gboolean flipped_y,
+ GtkMenu *menu)
+ {
++ if (GTK_IS_MENU_ITEM (menu->priv->widget) && !flipped_y && flipped_rect->y > final_rect->y)
++ {
++ gint new_height = final_rect->height - (flipped_rect->y - final_rect->y);
++ if (new_height > 200)
++ gdk_window_move_resize (window, final_rect->x, flipped_rect->y, final_rect->width, new_height);
++ }
+ g_signal_emit (menu,
+ menu_signals[POPPED_UP],
+ 0,
+ flipped_rect,
+ final_rect,
diff --git a/other__window-background.patch b/fixes__window-background.patch
index c7f70be07982..c7f70be07982 100644
--- a/other__window-background.patch
+++ b/fixes__window-background.patch