summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2016-10-10 15:26:44 +0100
committerEarnestly2016-10-10 15:26:44 +0100
commitddb2d5177e158882964d1dbf6f2587ae2402c059 (patch)
tree53789af54983c0a915c2f250263209dadf73a447
parentdb13c2b46823f921471a4a44967f7fe11dfe8d82 (diff)
downloadaur-ddb2d5177e158882964d1dbf6f2587ae2402c059.tar.gz
gtk3-optional-csd: sync with repo package, add hooks
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--gtk-query-immodules-3.0.hook11
-rw-r--r--gtk-update-icon-cache.hook13
-rw-r--r--gtk-update-icon-cache.script10
-rw-r--r--gtk3.install6
6 files changed, 69 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05e893f597d4..8ffa69c84c43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 5 22:10:56 UTC 2016
+# Mon Oct 10 14:25:35 UTC 2016
pkgbase = gtk3-optional-csd
pkgdesc = gobject-based gui toolkit with optionally enabled csd
pkgver = 3.22.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.gtk.org/
install = gtk3.install
arch = i686
@@ -36,11 +36,21 @@ pkgbase = gtk3-optional-csd
depends = librsvg
optdepends = at-spi2-atk: accessibility
provides = gtk3
+ provides = gtk3-print-backends
+ provides = gtk-update-icon-cache
conflicts = gtk3
+ conflicts = gtk3-print-backends
+ conflicts = gtk-update-icon-cache
source = https://download.gnome.org/sources/gtk+/3.22/gtk+-3.22.1.tar.xz
source = gtk3-make-csd-optional.patch
+ source = gtk-query-immodules-3.0.hook
+ source = gtk-update-icon-cache.hook
+ source = gtk-update-icon-cache.script
sha1sums = f77be19d55b58b9fe6d49140c0dc8e0335b7e620
sha1sums = b667c109d6f58ea8547a52a7b381ed65e383d778
+ sha1sums = bd93d200ae9b9bcbb1082a8fe00291f6ad89bfd5
+ sha1sums = 7e32132f9dd2a620a42b6dd175a834817b08b180
+ sha1sums = 0a1ddc049b2f1fec2e562fc6c917bdb867b707a4
pkgname = gtk3-optional-csd
diff --git a/PKGBUILD b/PKGBUILD
index b70bf2a4f28a..bf296184ad63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=gtk3-optional-csd
pkgver=3.22.1
-pkgrel=1
+pkgrel=2
pkgdesc='gobject-based gui toolkit with optionally enabled csd'
url='http://www.gtk.org/'
@@ -14,14 +14,20 @@ depends=('atk' 'cairo' 'libcups' 'libxcursor' 'libxinerama' 'libxrandr' 'libxi'
makedepends=('gobject-introspection' 'gtk-doc' 'libcanberra' 'wayland-protocols')
optdepends=('at-spi2-atk: accessibility')
-provides=('gtk3')
-conflicts=('gtk3')
+provides=('gtk3' 'gtk3-print-backends' 'gtk-update-icon-cache')
+conflicts=('gtk3' 'gtk3-print-backends' 'gtk-update-icon-cache')
source=("https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz"
- 'gtk3-make-csd-optional.patch')
+ 'gtk3-make-csd-optional.patch'
+ 'gtk-query-immodules-3.0.hook'
+ 'gtk-update-icon-cache.hook'
+ 'gtk-update-icon-cache.script')
sha1sums=('f77be19d55b58b9fe6d49140c0dc8e0335b7e620'
- 'b667c109d6f58ea8547a52a7b381ed65e383d778')
+ 'b667c109d6f58ea8547a52a7b381ed65e383d778'
+ 'bd93d200ae9b9bcbb1082a8fe00291f6ad89bfd5'
+ '7e32132f9dd2a620a42b6dd175a834817b08b180'
+ '0a1ddc049b2f1fec2e562fc6c917bdb867b707a4')
install='gtk3.install'
@@ -32,18 +38,22 @@ prepare() {
build() {
cd gtk+-"$pkgver"
- ./configure --prefix=/usr \
+ CXX=/bin/false ./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--enable-x11-backend \
--enable-wayland-backend \
--enable-broadway-backend \
- --disable-schemas-compile
+ --disable-schemas-compile \
+ --enable-gtk-doc
+
+ # XXX https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
make
}
package() {
cd gtk+-"$pkgver"
make DESTDIR="$pkgdir" install
- rm -f "$pkgdir"/usr/bin/gtk-update-icon-cache
}
diff --git a/gtk-query-immodules-3.0.hook b/gtk-query-immodules-3.0.hook
new file mode 100644
index 000000000000..c7703cf432c1
--- /dev/null
+++ b/gtk-query-immodules-3.0.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gtk-3.0/3.0.0/immodules/*.so
+
+[Action]
+Description = Probing GTK3 input method modules...
+When = PostTransaction
+Exec = /usr/bin/gtk-query-immodules-3.0 --update-cache
diff --git a/gtk-update-icon-cache.hook b/gtk-update-icon-cache.hook
new file mode 100644
index 000000000000..fca3fdc47dbb
--- /dev/null
+++ b/gtk-update-icon-cache.hook
@@ -0,0 +1,13 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/icons/*/
+Target = !usr/share/icons/*/?*
+
+[Action]
+Description = Updating icon theme caches...
+When = PostTransaction
+Exec = /usr/share/libalpm/scripts/gtk-update-icon-cache
+NeedsTargets
diff --git a/gtk-update-icon-cache.script b/gtk-update-icon-cache.script
new file mode 100644
index 000000000000..ee0f1d12d0b7
--- /dev/null
+++ b/gtk-update-icon-cache.script
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+while read -r f; do
+ if [[ -e ${f}index.theme ]]; then
+ gtk-update-icon-cache -q "$f"
+ elif [[ -d $f ]]; then
+ rm -f "${f}icon-theme.cache"
+ rmdir --ignore-fail-on-non-empty "$f"
+ fi
+done
diff --git a/gtk3.install b/gtk3.install
index 763314b2fb73..5f781e2831cb 100644
--- a/gtk3.install
+++ b/gtk3.install
@@ -1,3 +1,7 @@
+pre_remove() {
+ rm -f /usr/lib/gtk-3.0/3.0.0/immodules.cache
+}
+
post_install() {
- printf 'Use GTK_CSD=1 to enable the CSD where the CSD can be used\n'
+ printf 'Set the environment GTK_CSD=1 to enable the CSD\n'
}