summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordudemanguy2017-08-01 12:48:49 -0500
committerdudemanguy2017-08-01 12:48:49 -0500
commit4ce021ae84ec1d8b0bfdb557d278f4a99c269843 (patch)
treed5c10eba22c5f18f1d398e80a5501600fb2f60d2
parent5b9cf5e93dfb650dae4b2c2d6dcb475686f360c5 (diff)
downloadaur-4ce021ae84ec1d8b0bfdb557d278f4a99c269843.tar.gz
remove gtk-update-icon-cache
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--gtk-update-icon-cache.hook13
-rw-r--r--gtk-update-icon-cache.script10
4 files changed, 1 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f95075f60a3..85151aefb3d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Aug 1 17:24:31 UTC 2017
+# Tue Aug 1 17:48:05 UTC 2017
pkgbase = gtk3-patched-filechooser-icon-view
pkgdesc = GTK3 patched with dudemanguy's fork of wfr's filechooser-icon-view patch.
pkgver = 3.22.17
@@ -46,14 +46,10 @@ pkgbase = gtk3-patched-filechooser-icon-view
source = git+https://git.gnome.org/browse/gtk+#commit=59857e8f20aa07bbdaa621eecccb31accc717edb
source = settings.ini
source = gtk-query-immodules-3.0.hook
- source = gtk-update-icon-cache.hook
- source = gtk-update-icon-cache.script
source = https://gist.githubusercontent.com/Dudemanguy911/c172394e30e1e7d0f477ad15c719bc71/raw/2321887c13f19c0e53e3e7dc8150837546b13454/gtk3-filechooser-icon-view.patch
sha256sums = SKIP
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845
- sha256sums = 496064a9dd6214bd58f689dd817dbdc4d7f17d42a8c9940a87018c3f829ce308
- sha256sums = f1d3a0dbfd82f7339301abecdbe5f024337919b48bd0e09296bb0e79863b2541
sha256sums = 0bb72e50a53430c9ea37d210ed3d7b6e4f8a5927d0a8337ebb53b861b4b2320b
pkgname = gtk3-patched-filechooser-icon-view
diff --git a/PKGBUILD b/PKGBUILD
index df6c2f29d1e6..1837acad494b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,15 +23,11 @@ _commit=59857e8f20aa07bbdaa621eecccb31accc717edb # tags/3.22.17^0
source=("git+https://git.gnome.org/browse/gtk+#commit=$_commit"
settings.ini
gtk-query-immodules-3.0.hook
- gtk-update-icon-cache.hook
- gtk-update-icon-cache.script
https://gist.githubusercontent.com/Dudemanguy911/c172394e30e1e7d0f477ad15c719bc71/raw/$_patchver/gtk3-filechooser-icon-view.patch)
sha256sums=('SKIP'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845'
- '496064a9dd6214bd58f689dd817dbdc4d7f17d42a8c9940a87018c3f829ce308'
- 'f1d3a0dbfd82f7339301abecdbe5f024337919b48bd0e09296bb0e79863b2541'
'0bb72e50a53430c9ea37d210ed3d7b6e4f8a5927d0a8337ebb53b861b4b2320b')
pkgver() {
@@ -71,7 +67,5 @@ package() {
install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
install -Dm644 ../gtk-query-immodules-3.0.hook "$pkgdir/usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook"
- install -Dm644 ../gtk-update-icon-cache.hook "$pkgdir/usr/share/libalpm/hooks/gtk-update-icon-cache.hook"
- install -D ../gtk-update-icon-cache.script "$pkgdir/usr/share/libalpm/scripts/gtk-update-icon-cache"
}
diff --git a/gtk-update-icon-cache.hook b/gtk-update-icon-cache.hook
deleted file mode 100644
index fca3fdc47dbb..000000000000
--- a/gtk-update-icon-cache.hook
+++ /dev/null
@@ -1,13 +0,0 @@
-[Trigger]
-Type = File
-Operation = Install
-Operation = Upgrade
-Operation = Remove
-Target = usr/share/icons/*/
-Target = !usr/share/icons/*/?*
-
-[Action]
-Description = Updating icon theme caches...
-When = PostTransaction
-Exec = /usr/share/libalpm/scripts/gtk-update-icon-cache
-NeedsTargets
diff --git a/gtk-update-icon-cache.script b/gtk-update-icon-cache.script
deleted file mode 100644
index ee0f1d12d0b7..000000000000
--- a/gtk-update-icon-cache.script
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/bash
-
-while read -r f; do
- if [[ -e ${f}index.theme ]]; then
- gtk-update-icon-cache -q "$f"
- elif [[ -d $f ]]; then
- rm -f "${f}icon-theme.cache"
- rmdir --ignore-fail-on-non-empty "$f"
- fi
-done