summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordudemanguy2024-01-20 08:56:49 -0600
committerdudemanguy2024-01-20 09:00:26 -0600
commit5ccf4ece143f34bd989e960ab2c1d41cfd7e3787 (patch)
treee42c5382d1d7eeb1a04aece5c52d22d7fda64d90
parentce565c0a1f8577cbf2410243bcc2fb1964cab664 (diff)
downloadaur-5ccf4ece143f34bd989e960ab2c1d41cfd7e3787.tar.gz
3.24.40-2
-rw-r--r--.SRCINFO4
-rw-r--r--6786.patch50
-rw-r--r--PKGBUILD10
3 files changed, 61 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 685bfe5fa1ad..a9b2a8d3c56f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtk3-patched-filechooser-icon-view
pkgdesc = GTK3 patched with dudemanguy's fork of wfr's filechooser-icon-view patch.
pkgver = 3.24.40
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/Dudemanguy/gtk
install = gtk3.install
@@ -61,8 +61,10 @@ pkgbase = gtk3-patched-filechooser-icon-view
source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=f926323d04db220ba2ba9a9026a5bf54e81fbb39
source = gtk-query-immodules-3.0.hook
source = gtk3-filechooser-icon-view.patch
+ source = 6786.patch
b2sums = SKIP
b2sums = 8e6a3906126749c6d853f582e3802254cdbba099c6af7190ad576eff6ea5425404a72b1b36950a87e3afdac82295cfe246003172c3e0341a73bd931a36f3b407
b2sums = a19fce8e87f2789d0bca3a62d2858d89e4db4a14cf76930228b01d94aefb8b58867df9c63a194fd3a2542382e3968bef2eda37e1a33847cbbe77838932d9f6c3
+ b2sums = 137f4c03dd88c02f6171ab40e0c040d9c08aa5c2ee76260742ded966962b64ef4988ccb46a8261178ca1c88e0a5c2815e319d9f8e3af5c6b0a7d22eb3243b322
pkgname = gtk3-patched-filechooser-icon-view
diff --git a/6786.patch b/6786.patch
new file mode 100644
index 000000000000..b00db86d1e3e
--- /dev/null
+++ b/6786.patch
@@ -0,0 +1,50 @@
+From 6880ac90a0211095cfea753316e002bd668a4e92 Mon Sep 17 00:00:00 2001
+From: Michael Wyraz <mw@brick4u.de>
+Date: Fri, 19 Jan 2024 19:15:52 +0100
+Subject: [PATCH 1/2] don't free monitor->name twice (fixes #6345)
+
+---
+ gdk/x11/gdkscreen-x11.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/gdk/x11/gdkscreen-x11.c b/gdk/x11/gdkscreen-x11.c
+index f54bf51d04f..4ac3167b309 100644
+--- a/gdk/x11/gdkscreen-x11.c
++++ b/gdk/x11/gdkscreen-x11.c
+@@ -922,7 +922,6 @@ init_randr13 (GdkScreen *screen, gboolean *changed)
+ g_object_ref (monitor);
+ g_ptr_array_remove (x11_display->monitors, monitor);
+ gdk_display_monitor_removed (display, GDK_MONITOR (monitor));
+- free (monitor->name);
+ g_object_unref (monitor);
+ *changed = TRUE;
+ }
+--
+GitLab
+
+
+From ba58b3a23df4213e17a80816c7687a59e104769d Mon Sep 17 00:00:00 2001
+From: Michael Wyraz <mw@brick4u.de>
+Date: Fri, 19 Jan 2024 22:20:02 +0100
+Subject: [PATCH 2/2] Fix for #6342
+
+---
+ gdk/x11/gdkscreen-x11.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gdk/x11/gdkscreen-x11.c b/gdk/x11/gdkscreen-x11.c
+index 4ac3167b309..6207b5f4434 100644
+--- a/gdk/x11/gdkscreen-x11.c
++++ b/gdk/x11/gdkscreen-x11.c
+@@ -851,7 +851,7 @@ init_randr13 (GdkScreen *screen, gboolean *changed)
+ monitor = g_object_new (gdk_x11_monitor_get_type (),
+ "display", display,
+ NULL);
+- monitor->name = g_steal_pointer (&name);
++ monitor->name = g_strdup (name);
+ monitor->output = output;
+ monitor->add = TRUE;
+ g_ptr_array_add (x11_display->monitors, monitor);
+--
+GitLab
+
diff --git a/PKGBUILD b/PKGBUILD
index 1174a7262fcc..b8934dc2096a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gtk3-patched-filechooser-icon-view
pkgver=3.24.40
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="GTK3 patched with dudemanguy's fork of wfr's filechooser-icon-view patch."
arch=(x86_64)
@@ -73,10 +73,12 @@ source=(
"git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
gtk-query-immodules-3.0.hook
gtk3-filechooser-icon-view.patch
+ 6786.patch
)
b2sums=('SKIP'
'8e6a3906126749c6d853f582e3802254cdbba099c6af7190ad576eff6ea5425404a72b1b36950a87e3afdac82295cfe246003172c3e0341a73bd931a36f3b407'
- 'a19fce8e87f2789d0bca3a62d2858d89e4db4a14cf76930228b01d94aefb8b58867df9c63a194fd3a2542382e3968bef2eda37e1a33847cbbe77838932d9f6c3')
+ 'a19fce8e87f2789d0bca3a62d2858d89e4db4a14cf76930228b01d94aefb8b58867df9c63a194fd3a2542382e3968bef2eda37e1a33847cbbe77838932d9f6c3'
+ '137f4c03dd88c02f6171ab40e0c040d9c08aa5c2ee76260742ded966962b64ef4988ccb46a8261178ca1c88e0a5c2815e319d9f8e3af5c6b0a7d22eb3243b322')
pkgver() {
cd gtk
@@ -86,6 +88,10 @@ pkgver() {
prepare() {
cd gtk
+ # https://gitlab.archlinux.org/archlinux/packaging/packages/gtk3/-/issues/5
+ # https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/6786
+ git apply -3 ../6786.patch
+
# apply icon-view patch
patch -Np1 -i ../gtk3-filechooser-icon-view.patch
}