summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordudemanguy2020-04-07 08:22:39 -0500
committerdudemanguy2020-04-07 08:22:39 -0500
commitbacad362c86e14abf26a63eccddda716aadfd030 (patch)
tree435d87377574987481b6a975e9068e0bdfcc856a
parent63699c8f5d450912007d6023a4a4c2c67935ab98 (diff)
downloadaur-bacad362c86e14abf26a63eccddda716aadfd030.tar.gz
3.24.17+18+gcdd4349bfe-1
-rw-r--r--.SRCINFO2
-rw-r--r--1638.patch31
-rw-r--r--PKGBUILD2
3 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26a1556f1610..5fb9529543a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -58,7 +58,7 @@ pkgbase = gtk3-patched-filechooser-icon-view
source = gtk-query-immodules-3.0.hook
source = gtk3-filechooser-icon-view.patch
sha256sums = SKIP
- sha256sums = 45be674b2596b16d5778a85a51a31b59b3e3a198daaea34eec4400e4cdb9bd4e
+ sha256sums = 10ebcb8ec56c12e8f413c6af0c585877bca6b6530791c0c23698967a932c8e58
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229
sha256sums = 4323c38740e2ed8f97d53538f2ba2b0ea96afae95109a69e8f165ab4d3258909
diff --git a/1638.patch b/1638.patch
index 82c2506e2e3b..acdb5fe0ebbc 100644
--- a/1638.patch
+++ b/1638.patch
@@ -1,4 +1,4 @@
-From f7811616819040acc66dddd1762101d8ad87a2fa Mon Sep 17 00:00:00 2001
+From c5d9c8be2bda087ce33b36f46971dfb77f976827 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
Date: Mon, 6 Apr 2020 14:20:43 +0200
Subject: [PATCH] wayland: Always store unconfigured size
@@ -6,34 +6,29 @@ Subject: [PATCH] wayland: Always store unconfigured size
This means it'll always be as up to date GdkWindow::width/height. We
still skip the resize for non-configured windows though, to avoid
mapping with the wrong size.
+
+The commit f06ee688fe86ec8e1db1c515a7bf2ccc8decc310 also accidentally
+removed the unconfigured size setting completely, so this essentially
+adds it back, but always sets it.
+
+Closes: https://gitlab.gnome.org/GNOME/gtk/-/issues/2582
---
- gdk/wayland/gdkwindow-wayland.c | 10 +++-------
- 1 file changed, 3 insertions(+), 7 deletions(-)
+ gdk/wayland/gdkwindow-wayland.c | 2 ++
+ 1 file changed, 2 insertions(+)
diff --git a/gdk/wayland/gdkwindow-wayland.c b/gdk/wayland/gdkwindow-wayland.c
-index 6c555443bd..05a673eb61 100644
+index f6acc74366..30d4353826 100644
--- a/gdk/wayland/gdkwindow-wayland.c
+++ b/gdk/wayland/gdkwindow-wayland.c
-@@ -1145,16 +1145,12 @@ gdk_wayland_window_maybe_configure (GdkWindow *window,
+@@ -1156,6 +1156,8 @@ gdk_wayland_window_maybe_configure (GdkWindow *window,
gboolean is_xdg_popup;
gboolean is_visible;
+ impl->unconfigured_width = calculate_width_without_margin (window, width);
+ impl->unconfigured_height = calculate_height_without_margin (window, height);
- if (needs_initial_configure (window) &&
- !impl->initial_configure_received)
-- {
-- impl->unconfigured_width = calculate_width_without_margin (window,
-- width);
-- impl->unconfigured_height = calculate_height_without_margin (window,
-- height);
-- return;
-- }
-+ return;
-
- if (window->width == width &&
- window->height == height &&
+ if (should_inhibit_resize (window))
+ return;
--
2.24.1
diff --git a/PKGBUILD b/PKGBUILD
index 299480429ea2..5c13100bdfd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,7 @@ source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
gtk3-filechooser-icon-view.patch)
sha256sums=('SKIP'
- '45be674b2596b16d5778a85a51a31b59b3e3a198daaea34eec4400e4cdb9bd4e'
+ '10ebcb8ec56c12e8f413c6af0c585877bca6b6530791c0c23698967a932c8e58'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229'
'4323c38740e2ed8f97d53538f2ba2b0ea96afae95109a69e8f165ab4d3258909')