summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordudemanguy2017-11-28 10:44:32 -0600
committerdudemanguy2017-11-28 10:44:32 -0600
commitf133ff8763101ed4b71a8a2eb7f9244151fa45d6 (patch)
tree84955bfe596f59de3375eaee2c1725d75ec53420
parent0a201ed5d5376833ed700f421d6eff4be965fb0f (diff)
downloadaur-f133ff8763101ed4b71a8a2eb7f9244151fa45d6.tar.gz
update 3.22.26+47+g3a1a7135a2-3
-rw-r--r--.SRCINFO21
-rw-r--r--0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch38
-rw-r--r--PKGBUILD35
3 files changed, 67 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39cea8112155..ee518d2cd6c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Nov 9 20:56:03 UTC 2017
+# Tue Nov 28 16:43:10 UTC 2017
pkgbase = gtk3-patched-filechooser-icon-view
pkgdesc = GTK3 patched with dudemanguy's fork of wfr's filechooser-icon-view patch.
- pkgver = 3.22.26
+ pkgver = 3.22.26+47+g3a1a7135a2
pkgrel = 1
url = https://gist.github.com/Dudemanguy911/c172394e30e1e7d0f477ad15c719bc71
install = gtk3.install
@@ -10,12 +10,8 @@ pkgbase = gtk3-patched-filechooser-icon-view
arch = x86_64
license = LGPL
makedepends = gobject-introspection
- makedepends = libcanberra
makedepends = gtk-doc
makedepends = git
- makedepends = colord
- makedepends = rest
- makedepends = libcups
makedepends = glib2-docs
makedepends = sassc
depends = atk
@@ -41,14 +37,21 @@ pkgbase = gtk3-patched-filechooser-icon-view
depends = desktop-file-utils
depends = mesa
depends = cantarell-fonts
+ depends = colord
+ depends = rest
+ depends = libcups
+ depends = libcanberra
depends = glib2-patched-thumbnailer
- provides = gtk3=3.22.26
- conflicts = gtk3
- source = git+https://git.gnome.org/browse/gtk+#commit=77a4e2ec3759648e85a5172bb9fbdedcd7370023
+ provides = gtk3=3.22.26+47+g3a1a7135a2 gtk3-print-backends
+ conflicts = gtk3 gtk3-print-backends
+ replaces = gtk3-print-backends<=3.22.26.1
+ source = git+https://git.gnome.org/browse/gtk+#commit=3a1a7135a276f2b6336c7566f6342da739a41d39
+ source = 0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch
source = settings.ini
source = gtk-query-immodules-3.0.hook
source = https://gist.githubusercontent.com/Dudemanguy911/c172394e30e1e7d0f477ad15c719bc71/raw/543fa1dc7173d896f8d87bece94ae23944dd1e76/gtk3-filechooser-icon-view.patch
sha256sums = SKIP
+ sha256sums = 3a52d723db863564bea9245d5f65b1dc5c3ca20ee190fca249eb8bd8fdbc5c0b
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845
sha256sums = bc990c3f9bbe5e39184e9203cc99eff92920d1383119db49be92a01f98d71f2e
diff --git a/0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch b/0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch
new file mode 100644
index 000000000000..7df88c44617c
--- /dev/null
+++ b/0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch
@@ -0,0 +1,38 @@
+From 9577618e2ae679988231cfa2162eb48cdb6ce5a0 Mon Sep 17 00:00:00 2001
+Message-Id: <9577618e2ae679988231cfa2162eb48cdb6ce5a0.1511732020.git.jan.steffens@gmail.com>
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Sun, 26 Nov 2017 22:32:36 +0100
+Subject: [PATCH] entry: Undo ABI breakage from addition of insert_emoji
+
+---
+ gtk/gtkentry.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gtk/gtkentry.h b/gtk/gtkentry.h
+index 073e703d0deea6a6..0372752f2963c940 100644
+--- a/gtk/gtkentry.h
++++ b/gtk/gtkentry.h
+@@ -146,19 +146,19 @@ struct _GtkEntryClass
+ void (* copy_clipboard) (GtkEntry *entry);
+ void (* paste_clipboard) (GtkEntry *entry);
+ void (* toggle_overwrite) (GtkEntry *entry);
+- void (* insert_emoji) (GtkEntry *entry);
+
+ /* hooks to add other objects beside the entry (like in GtkSpinButton) */
+ void (* get_text_area_size) (GtkEntry *entry,
+ gint *x,
+ gint *y,
+ gint *width,
+ gint *height);
+ void (* get_frame_size) (GtkEntry *entry,
+ gint *x,
+ gint *y,
+ gint *width,
+ gint *height);
++ void (* insert_emoji) (GtkEntry *entry);
+
+ /*< private >*/
+
+--
+2.15.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 1871dc8a39d0..aee325865506 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,32 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=gtk3-patched-filechooser-icon-view
-pkgver=3.22.26
+pkgver=3.22.26+47+g3a1a7135a2
_patchver=543fa1dc7173d896f8d87bece94ae23944dd1e76
pkgrel=1
pkgdesc="GTK3 patched with dudemanguy's fork of wfr's filechooser-icon-view patch."
arch=(i686 x86_64)
url="https://gist.github.com/Dudemanguy911/c172394e30e1e7d0f477ad15c719bc71"
-provides=("gtk3=$pkgver")
-conflicts=("gtk3")
+provides=("gtk3=$pkgver gtk3-print-backends")
+conflicts=("gtk3 gtk3-print-backends")
+replaces=("gtk3-print-backends<=3.22.26.1")
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
- cantarell-fonts glib2-patched-thumbnailer)
-makedepends=(gobject-introspection libcanberra gtk-doc git colord rest libcups glib2-docs
- sassc)
+ cantarell-fonts colord rest libcups libcanberra glib2-patched-thumbnailer)
+makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
+
license=(LGPL)
install=gtk3.install
-_commit=77a4e2ec3759648e85a5172bb9fbdedcd7370023 # tags/3.22.26^0
+_commit=3a1a7135a276f2b6336c7566f6342da739a41d39 # gtk-3-22
source=("git+https://git.gnome.org/browse/gtk+#commit=$_commit"
+ 0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch
settings.ini
gtk-query-immodules-3.0.hook
https://gist.githubusercontent.com/Dudemanguy911/c172394e30e1e7d0f477ad15c719bc71/raw/$_patchver/gtk3-filechooser-icon-view.patch)
sha256sums=('SKIP'
+ '3a52d723db863564bea9245d5f65b1dc5c3ca20ee190fca249eb8bd8fdbc5c0b'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845'
'bc990c3f9bbe5e39184e9203cc99eff92920d1383119db49be92a01f98d71f2e')
@@ -38,7 +41,13 @@ pkgver() {
prepare() {
cd gtk+
+
+ # https://bugs.archlinux.org/task/56474
+ patch -Np1 -i ../0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch
+
+ # apply icon-view patch
patch -Np1 -i ../gtk3-filechooser-icon-view.patch
+
NOCONFIGURE=1 ./autogen.sh
}
@@ -68,17 +77,7 @@ package() {
install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
install -Dm644 ../gtk-query-immodules-3.0.hook "$pkgdir/usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook"
- # split these out to avoid file conflicts with gtk-update-icon-cache and gtk3-print-backends
+ # split these out to avoid file conflicts with gtk-update-icon-cache
rm "$pkgdir/usr/bin/gtk-update-icon-cache"
-
- cd "$pkgdir"
- for _f in usr/lib/*/*/printbackends/*; do
- case $_f in
- *-file.so|*-lpr.so) continue ;;
- esac
-
- mkdir -p "$srcdir/print-backends/${_f%/*}"
- mv "$_f" "$srcdir/print-backends/$_f"
- done
}