summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeija2019-03-24 21:41:33 +0100
committerJeija2019-03-24 21:41:33 +0100
commit17407b125cc79089b34fb36828333856b3bfcee5 (patch)
tree4580714ff0229fd7f13a72aee2527464b1a46462
parenta949347f86dbd6e8e2c3e9e0dc09e3b5fe899c82 (diff)
downloadaur-17407b125cc79089b34fb36828333856b3bfcee5.tar.gz
Update to GTK+ 3.24.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29342f8fe55e..f84ccd33b996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 1 21:31:04 UTC 2019
+# Sun Mar 24 20:41:11 UTC 2019
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.24.4+15+g80b5024239
+ pkgver = 3.24.7+25+g17665f06e3
pkgrel = 1
url = https://www.gtk.org/
install = gtk3.install
@@ -40,11 +40,12 @@ pkgbase = gtk3-typeahead
depends = rest
depends = libcups
depends = libcanberra
- provides = gtk3=3.24.4+15+g80b5024239
+ depends = fribidi
+ provides = gtk3=3.24.7+25+g17665f06e3
provides = gtk3-print-backends
conflicts = gtk3
replaces = gtk3-print-backends<=3.22.26-1
- source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=80b5024239ee358ede8203666dfe9ea790a29b70
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=17665f06e352d2c9ea3c9c9392a026d9b3d6cf98
source = settings.ini
source = gtk-query-immodules-3.0.hook
source = typeahead.patch
diff --git a/PKGBUILD b/PKGBUILD
index 05dc6a0248ef..597338e1e141 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.24.4+15+g80b5024239
+pkgver=3.24.7+25+g17665f06e3
pkgrel=1
conflicts=(gtk3)
provides=("gtk3=$pkgver" gtk3-print-backends)
@@ -13,10 +13,10 @@ install=gtk3.install
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
- cantarell-fonts colord rest libcups libcanberra)
+ cantarell-fonts colord rest libcups libcanberra fribidi)
makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
license=(LGPL)
-_commit=80b5024239ee358ede8203666dfe9ea790a29b70 # gtk-3-24
+_commit=17665f06e352d2c9ea3c9c9392a026d9b3d6cf98 # gtk-3-24
source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
settings.ini
gtk-query-immodules-3.0.hook
@@ -29,6 +29,9 @@ sha256sums=('SKIP'
prepare() {
cd gtk
+ # https://gitlab.gnome.org/GNOME/gtk/issues/1761
+ git cherry-pick -n 9b4c8d6b329c5daef9269b4ec41645f90ad73644
+
# Typeahead-specific changes
patch gtk/gtkfilechooserwidget.c -i $srcdir/typeahead.patch