summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeija2016-04-10 08:58:16 +0200
committerJeija2016-04-10 08:58:16 +0200
commit307e1bd3d87e5b4c6ac6c927065accafa133dc88 (patch)
tree2423a398a037f1cc7b1c243bbdb159de2233d535
parent277d43f6623308837aa037c4c0fe4e24e813e711 (diff)
downloadaur-307e1bd3d87e5b4c6ac6c927065accafa133dc88.tar.gz
Update to GTK+ 3.20.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD8
-rw-r--r--typeahead.patch16
3 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a83636086600..deeb0b9d18e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Mar 19 11:56:55 UTC 2016
+# Sun Apr 10 06:11:23 UTC 2016
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.18.9
+ pkgver = 3.20.2
pkgrel = 1
url = http://www.gtk.org/
install = gtk3.install
@@ -34,15 +34,16 @@ pkgbase = gtk3-typeahead
depends = rest
depends = librsvg
depends = gtk-update-icon-cache
+ depends = wayland-protocols
optdepends = libcanberra: gtk3-widget-factory demo
- provides = gtk3=3.18.9
+ provides = gtk3=3.20.2
conflicts = gtk3
- source = https://download.gnome.org/sources/gtk+/3.18/gtk+-3.18.9.tar.xz
+ source = https://download.gnome.org/sources/gtk+/3.20/gtk+-3.20.2.tar.xz
source = settings.ini
source = typeahead.patch
- sha256sums = 783d7f8b00f9b4224cc94d7da885a67598e711c2d6d79c9c873c6b203e83acbd
+ sha256sums = 1ab1d1068ea55e0046f437d69983f164df5e68cb2e9fdfb38787b867f33f69f7
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
- sha256sums = 029a05a3475bf54f1f1617e7b7a10d589a098b30e0beee1d7a0fdc42d05202ce
+ sha256sums = 4e3f2c47eeb088de08dae332ae9aedcfd1c118bf899517233b52effd2d37020b
pkgname = gtk3-typeahead
install = gtk3.install
diff --git a/PKGBUILD b/PKGBUILD
index 52ab966c3cfb..1cebbcc9c2cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.18.9
+pkgver=3.20.2
pkgrel=1
conflicts=(gtk3)
provides=("gtk3=$pkgver")
@@ -11,15 +11,15 @@ url="http://www.gtk.org/"
install=gtk3.install
depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
libxcomposite libxdamage pango shared-mime-info colord at-spi2-atk wayland libxkbcommon
- adwaita-icon-theme json-glib rest librsvg gtk-update-icon-cache)
+ adwaita-icon-theme json-glib rest librsvg gtk-update-icon-cache wayland-protocols)
optdepends=('libcanberra: gtk3-widget-factory demo')
makedepends=(gobject-introspection libcanberra gtk-doc)
license=(LGPL)
source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
settings.ini typeahead.patch)
-sha256sums=('783d7f8b00f9b4224cc94d7da885a67598e711c2d6d79c9c873c6b203e83acbd'
+sha256sums=('1ab1d1068ea55e0046f437d69983f164df5e68cb2e9fdfb38787b867f33f69f7'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
- '029a05a3475bf54f1f1617e7b7a10d589a098b30e0beee1d7a0fdc42d05202ce')
+ '4e3f2c47eeb088de08dae332ae9aedcfd1c118bf899517233b52effd2d37020b')
prepare() {
cd gtk+-$pkgver
diff --git a/typeahead.patch b/typeahead.patch
index d490950cc6a2..0102d98d4e44 100644
--- a/typeahead.patch
+++ b/typeahead.patch
@@ -1,4 +1,4 @@
-@@ -1372,6 +1372,9 @@
+@@ -1378,6 +1378,9 @@
{
GtkFileChooserWidget *impl = (GtkFileChooserWidget *) widget;
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -8,7 +8,7 @@
if (should_trigger_location_entry (impl, event))
{
-@@ -1382,12 +1385,6 @@
+@@ -1388,12 +1391,6 @@
return TRUE;
}
}
@@ -21,7 +21,7 @@
if (GTK_WIDGET_CLASS (gtk_file_chooser_widget_parent_class)->key_press_event (widget, event))
return TRUE;
-@@ -2457,7 +2454,7 @@
+@@ -2463,7 +2460,7 @@
{
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -30,7 +30,7 @@
gtk_tree_view_column_set_sort_column_id (priv->list_name_column, MODEL_COL_NAME);
gtk_tree_view_column_set_sort_column_id (priv->list_time_column, MODEL_COL_TIME);
-@@ -4360,6 +4357,7 @@
+@@ -4375,6 +4372,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->browse_files_model));
update_columns (impl, FALSE, _("Modified"));
@@ -38,7 +38,7 @@
file_list_set_sort_column_ids (impl);
set_sort_column (impl);
profile_msg (" gtk_tree_view_set_model end", NULL);
-@@ -7101,10 +7099,6 @@
+@@ -7121,10 +7119,6 @@
{
GList *l, *files, *files_with_info, *infos;
GFile *file;
@@ -49,7 +49,7 @@
files = NULL;
files_with_info = NULL;
-@@ -7132,8 +7126,6 @@
+@@ -7152,8 +7146,6 @@
g_list_free_full (infos, g_object_unref);
gtk_stack_set_visible_child_name (GTK_STACK (impl->priv->browse_files_stack), "list");
@@ -58,7 +58,7 @@
}
/* Callback used from GtkSearchEngine when the query is done running */
-@@ -7451,6 +7443,7 @@
+@@ -7471,6 +7463,7 @@
gtk_tree_sortable_set_sort_column_id (GTK_TREE_SORTABLE (priv->recent_model),
GTK_TREE_SORTABLE_DEFAULT_SORT_COLUMN_ID,
GTK_SORT_DESCENDING);
@@ -66,7 +66,7 @@
}
typedef struct
-@@ -7468,7 +7461,7 @@
+@@ -7488,7 +7481,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->recent_model));