summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeija2017-08-12 22:11:14 +0200
committerJeija2017-08-12 22:11:14 +0200
commit740ee136488381df253546508af06ba2b85caca4 (patch)
tree356fd29f2d260441b99fc2ec0e38f018bc2ea12c
parentea8936f24680f23db65df7fac2c7a1547b472ccf (diff)
downloadaur-740ee136488381df253546508af06ba2b85caca4.tar.gz
Update to GTK+ 3.22.18
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
-rw-r--r--typeahead.patch4
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f5d54d3f53..bdee5df3902f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 14 09:26:42 UTC 2017
+# Sat Aug 12 19:54:35 UTC 2017
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.22.15
+ pkgver = 3.22.18
pkgrel = 1
url = http://www.gtk.org/
install = gtk3.install
@@ -40,19 +40,20 @@ pkgbase = gtk3-typeahead
depends = wayland-protocols
depends = desktop-file-utils
depends = mesa
+ depends = cantarell-fonts
depends = gtk-update-icon-cache
optdepends = libcanberra: gtk3-widget-factory demo
optdepends = gtk3-print-backends: Printing
- provides = gtk3=3.22.15
+ provides = gtk3=3.22.18
conflicts = gtk3
- source = git://git.gnome.org/gtk+#commit=2dfcb471909158a2bea026fe65a0e17bcf6199f1
+ source = git://git.gnome.org/gtk+#commit=e1cf6281fe800c070d599aef0681ef4f776e1775
source = settings.ini
source = gtk-query-immodules-3.0.hook
source = typeahead.patch
sha256sums = SKIP
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845
- sha256sums = 33fe0e01c3eb8d7539af702eea999acb95c6c527979a2912dbf5b21a59540ceb
+ sha256sums = 405fd37cc8929b9f9dfd78cb4f9e7cdd1b02ecfde7ef82e3ad28173defccb8d5
pkgname = gtk3-typeahead
install = gtk3.install
diff --git a/PKGBUILD b/PKGBUILD
index 4f107002fa09..51ea674a8a17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.22.15
+pkgver=3.22.18
pkgrel=1
conflicts=(gtk3)
provides=("gtk3=$pkgver")
@@ -11,13 +11,14 @@ url="http://www.gtk.org/"
install=gtk3.install
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
- adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa gtk-update-icon-cache)
+ adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
+ cantarell-fonts gtk-update-icon-cache)
optdepends=('libcanberra: gtk3-widget-factory demo'
'gtk3-print-backends: Printing')
makedepends=(gobject-introspection libcanberra gtk-doc git colord rest libcups glib2-docs
sassc)
license=(LGPL)
-_commit=2dfcb471909158a2bea026fe65a0e17bcf6199f1 # tags/3.22.15^0
+_commit=e1cf6281fe800c070d599aef0681ef4f776e1775 # tags/3.22.18^0
source=("git://git.gnome.org/gtk+#commit=$_commit"
settings.ini
gtk-query-immodules-3.0.hook
@@ -25,7 +26,7 @@ source=("git://git.gnome.org/gtk+#commit=$_commit"
sha256sums=('SKIP'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845'
- '33fe0e01c3eb8d7539af702eea999acb95c6c527979a2912dbf5b21a59540ceb')
+ '405fd37cc8929b9f9dfd78cb4f9e7cdd1b02ecfde7ef82e3ad28173defccb8d5')
prepare() {
cd gtk+
diff --git a/typeahead.patch b/typeahead.patch
index 17d1f3d27839..97befb22f85f 100644
--- a/typeahead.patch
+++ b/typeahead.patch
@@ -58,7 +58,7 @@
}
/* Callback used from GtkSearchEngine when the query is done running */
-@@ -7502,6 +7494,7 @@
+@@ -7481,6 +7473,7 @@
gtk_tree_sortable_set_sort_column_id (GTK_TREE_SORTABLE (priv->recent_model),
GTK_TREE_SORTABLE_DEFAULT_SORT_COLUMN_ID,
GTK_SORT_DESCENDING);
@@ -66,7 +66,7 @@
}
typedef struct
-@@ -7519,7 +7512,7 @@
+@@ -7498,7 +7491,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->recent_model));