summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-21 11:36:00 -0600
committerMark Wagie2021-09-21 11:36:00 -0600
commit848de0bbcdeb94bd47a6425857eb53c8440f9429 (patch)
tree91f5b7cc1fe491cae236bf87c27d21515cb2cd63
parentd731d2b589f912f925be91149aa9ca38fcdb944c (diff)
downloadaur-848de0bbcdeb94bd47a6425857eb53c8440f9429.tar.gz
3.24.30+62+g8d04980f38
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a694461ee16a..c1bf2f62cc15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk3-typeahead
pkgdesc = GObject-based multi-platform GUI toolkit - Typeahead feature enabled for file chooser widget
- pkgver = 3.24.30
+ pkgver = 3.24.30+62+g8d04980f38
pkgrel = 1
url = https://www.gtk.org/
install = gtk3.install
@@ -12,6 +12,7 @@ pkgbase = gtk3-typeahead
makedepends = glib2-docs
makedepends = sassc
makedepends = meson
+ makedepends = wayland-protocols
depends = atk
depends = cairo
depends = libxcursor
@@ -31,7 +32,6 @@ pkgbase = gtk3-typeahead
depends = adwaita-icon-theme
depends = json-glib
depends = librsvg
- depends = wayland-protocols
depends = desktop-file-utils
depends = mesa
depends = cantarell-fonts
@@ -42,8 +42,9 @@ pkgbase = gtk3-typeahead
depends = fribidi
depends = iso-codes
depends = libcloudproviders
+ depends = tracker3
depends = gtk-update-icon-cache
- provides = gtk3=3.24.30
+ provides = gtk3=3.24.30+62+g8d04980f38
provides = gtk3-print-backends
provides = libgtk-3.so
provides = libgdk-3.so
@@ -51,7 +52,7 @@ pkgbase = gtk3-typeahead
conflicts = gtk3
conflicts = gtk3-print-backends
replaces = gtk3-print-backends<=3.22.26-1
- source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=d4e2d05cd9518ba04d6fbe1cbcec27142788ac95
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=8d04980f38d58bea7ba721a6ff2e3d38dfdc0486
source = gtk-query-immodules-3.0.hook
source = typeahead.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5d12bc082f7c..7e11f7ffbc24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=gtk3-typeahead
-pkgver=3.24.30
+pkgver=3.24.30+62+g8d04980f38
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit - Typeahead feature enabled for file chooser widget"
arch=(x86_64)
@@ -12,15 +12,16 @@ license=(LGPL)
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
dconf libxcomposite libxdamage pango shared-mime-info at-spi2-atk
wayland libxkbcommon adwaita-icon-theme json-glib librsvg
- wayland-protocols desktop-file-utils mesa cantarell-fonts libcolord
- rest libcups libcanberra fribidi iso-codes libcloudproviders
+ desktop-file-utils mesa cantarell-fonts libcolord rest libcups
+ libcanberra fribidi iso-codes libcloudproviders tracker3
gtk-update-icon-cache)
-makedepends=(gobject-introspection gtk-doc git glib2-docs sassc meson)
+makedepends=(gobject-introspection gtk-doc git glib2-docs sassc meson
+ wayland-protocols)
provides=("gtk3=$pkgver" gtk3-print-backends libgtk-3.so libgdk-3.so libgailutil-3.so)
conflicts=(gtk3 gtk3-print-backends)
replaces=("gtk3-print-backends<=3.22.26-1")
install=gtk3.install
-_commit=d4e2d05cd9518ba04d6fbe1cbcec27142788ac95 # tags/3.24.30^0
+_commit=8d04980f38d58bea7ba721a6ff2e3d38dfdc0486 # gtk-3-24
source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
gtk-query-immodules-3.0.hook
typeahead.patch)
@@ -41,12 +42,13 @@ prepare() {
}
build() {
- CFLAGS+=" -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"
+ CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
local meson_options=(
-D broadway_backend=true
-D cloudproviders=true
- -D tracker3=false
+ -D tracker3=true
-D colord=yes
+ -D gtk_doc=false
-D examples=false \
-D demos=false \
-D man=true
@@ -57,7 +59,7 @@ build() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
install -Dm644 /dev/stdin "$pkgdir/usr/share/gtk-3.0/settings.ini" <<END
[Settings]