summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeija2019-07-14 15:00:27 +0200
committerJeija2019-07-14 15:00:27 +0200
commita6fa16b22ff5a3d68d18303773883e0e434c4a62 (patch)
treee72188c87902935c68bcf4cf6cf41c475fc702dc
parentf0c3307d853c72f3e14257837b97ed934ee9c732 (diff)
downloadaur-a6fa16b22ff5a3d68d18303773883e0e434c4a62.tar.gz
Update to GTK+ 3.24.10
GTK+ is now built using meson / ninja
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
2 files changed, 17 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea35068c8e79..10e2ebb35ac1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.24.8
+ pkgver = 3.24.10
pkgrel = 1
url = https://www.gtk.org/
install = gtk3.install
@@ -11,6 +11,7 @@ pkgbase = gtk3-typeahead
makedepends = git
makedepends = glib2-docs
makedepends = sassc
+ makedepends = meson
depends = atk
depends = cairo
depends = libxcursor
@@ -39,11 +40,12 @@ pkgbase = gtk3-typeahead
depends = libcups
depends = libcanberra
depends = fribidi
- provides = gtk3=3.24.8
+ depends = iso-codes
+ provides = gtk3=3.24.10
provides = gtk3-print-backends
conflicts = gtk3
replaces = gtk3-print-backends<=3.22.26-1
- source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=5428379fad31f1637c920d97a3d0303f606bfb6e
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=3642629767ec54c4079f7d90a9ea780a225bfe5e
source = settings.ini
source = gtk-query-immodules-3.0.hook
source = typeahead.patch
diff --git a/PKGBUILD b/PKGBUILD
index 3a4e6e964a0b..66702a05356a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.24.8
+pkgver=3.24.10
pkgrel=1
conflicts=(gtk3)
provides=("gtk3=$pkgver" gtk3-print-backends)
@@ -13,10 +13,10 @@ install=gtk3.install
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
- cantarell-fonts colord rest libcups libcanberra fribidi)
-makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
+ cantarell-fonts colord rest libcups libcanberra fribidi iso-codes)
+makedepends=(gobject-introspection gtk-doc git glib2-docs sassc meson)
license=(LGPL)
-_commit=5428379fad31f1637c920d97a3d0303f606bfb6e # tags/3.24.8^0
+_commit=3642629767ec54c4079f7d90a9ea780a225bfe5e # tags/3.24.10^0
source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
settings.ini
gtk-query-immodules-3.0.hook
@@ -31,32 +31,22 @@ prepare() {
# Typeahead-specific changes
patch gtk/gtkfilechooserwidget.c -i $srcdir/typeahead.patch
-
- NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd gtk
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-schemas-compile \
- --enable-x11-backend \
- --enable-broadway-backend \
- --enable-wayland-backend \
- --enable-gtk-doc
-
- #https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ CFLAGS+=" -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"
+ arch-meson gtk build \
+ -D broadway_backend=true \
+ -D colord=yes \
+ -D gtk_doc=true \
+ -D man=true
+ ninja -C build
}
package() {
install=gtk3.install
- DESTDIR="$pkgdir" make -C gtk install
+ DESTDIR="$pkgdir" meson install -C build
install -Dt "$pkgdir/usr/share/gtk-3.0" -m644 settings.ini
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-query-immodules-3.0.hook