summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-12 08:38:01 -0600
committerMark Wagie2021-04-12 08:38:01 -0600
commitbbb7c54742a13dc46054cd0db3e3279ba7e7a5d2 (patch)
tree7159a6bd6fc25ddf80c6f09954f4dc9d45f2b5d3
parent2425674ac3eaba6959fa66dd0d2f26ab6e323ac1 (diff)
downloadaur-bbb7c54742a13dc46054cd0db3e3279ba7e7a5d2.tar.gz
3.24.28-4
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebb0e7d22b4f..eeb733e087cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtk3-typeahead
pkgdesc = GObject-based multi-platform GUI toolkit - Typeahead feature enabled for file chooser widget
pkgver = 3.24.28
- pkgrel = 2
+ pkgrel = 4
url = https://www.gtk.org/
install = gtk3.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2ff4b25cec3d..adbf68bb5779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=gtk3-typeahead
pkgver=3.24.28
-pkgrel=2
+pkgrel=4
pkgdesc="GObject-based multi-platform GUI toolkit - Typeahead feature enabled for file chooser widget"
arch=(x86_64)
url="https://www.gtk.org/"
@@ -41,17 +41,18 @@ prepare() {
}
build() {
- # https://gitlab.gnome.org/GNOME/gtk/-/commit/df4b564d69cc7d2e751537eff61259b36f37e9e5
- CFLAGS+=" -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS -DG_DISABLE_ASSERT"
-
- arch-meson gtk build \
- -D broadway_backend=true \
- -D cloudproviders=true \
- -D tracker3=false \
- -D colord=yes \
+ CFLAGS+=" -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"
+ local meson_options=(
+ -D broadway_backend=true
+ -D cloudproviders=true
+ -D tracker3=false
+ -D colord=yes
-D examples=false \
-D demos=false \
-D man=true
+ )
+
+ arch-meson gtk build "${meson_options[@]}"
meson compile -C build
}