summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeija2018-09-18 08:52:30 +0200
committerJeija2018-09-18 08:52:30 +0200
commitcf0f099171232e5002d4888fdb34efa0ec6f7a5e (patch)
treef04bc1bb501aa5102ae8e2aed6cf903d90750c15
parente18be7c233abef2211230f2dfccebbfcb5d60e64 (diff)
downloadaur-cf0f099171232e5002d4888fdb34efa0ec6f7a5e.tar.gz
Update to GTK+ 3.24.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--typeahead.patch16
3 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d74916b9cc98..40f907c7d82e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sun Apr 1 18:44:43 UTC 2018
+# Tue Sep 18 06:40:17 UTC 2018
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.22.29+60+ge42d8598ca
+ pkgver = 3.24.0+33+g8fd2d461fc
pkgrel = 1
- url = http://www.gtk.org/
+ url = https://www.gtk.org/
install = gtk3.install
arch = x86_64
license = LGPL
@@ -40,18 +40,18 @@ pkgbase = gtk3-typeahead
depends = rest
depends = libcups
depends = libcanberra
- provides = gtk3=3.22.29+60+ge42d8598ca
+ provides = gtk3=3.24.0+33+g8fd2d461fc
provides = gtk3-print-backends
conflicts = gtk3
replaces = gtk3-print-backends<=3.22.26-1
- source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=e42d8598ca892587a1029c458a19c86fd4867877
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=8fd2d461fce6da655060880fdb183a9f1e0b957c
source = settings.ini
source = gtk-query-immodules-3.0.hook
source = typeahead.patch
sha256sums = SKIP
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845
- sha256sums = 5006fa1dcea9aa74766196ec5c18e5172d7287195c2a49ffcd0adc13bc6e62c1
+ sha256sums = 3b94b53ee720e24e999e6fe40de269ec5b6ddfcbab64fb1a14e7d89256651607
pkgname = gtk3-typeahead
install = gtk3.install
diff --git a/PKGBUILD b/PKGBUILD
index 89477eadf988..7f9a4c9a677f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.22.29+60+ge42d8598ca
+pkgver=3.24.0+33+g8fd2d461fc
pkgrel=1
conflicts=(gtk3)
provides=("gtk3=$pkgver" gtk3-print-backends)
replaces=("gtk3-print-backends<=3.22.26-1")
pkgdesc="GTK+ 3 with typeahead feature enabled for the file chooser widget"
arch=(x86_64)
-url="http://www.gtk.org/"
+url="https://www.gtk.org/"
install=gtk3.install
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
@@ -16,7 +16,7 @@ depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 d
cantarell-fonts colord rest libcups libcanberra)
makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
license=(LGPL)
-_commit=e42d8598ca892587a1029c458a19c86fd4867877 # gtk-3-22
+_commit=8fd2d461fce6da655060880fdb183a9f1e0b957c # gtk-3-24
source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
settings.ini
gtk-query-immodules-3.0.hook
@@ -24,7 +24,7 @@ source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
sha256sums=('SKIP'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845'
- '5006fa1dcea9aa74766196ec5c18e5172d7287195c2a49ffcd0adc13bc6e62c1')
+ '3b94b53ee720e24e999e6fe40de269ec5b6ddfcbab64fb1a14e7d89256651607')
prepare() {
cd gtk
@@ -56,10 +56,9 @@ build() {
package() {
install=gtk3.install
- cd gtk
- make DESTDIR="$pkgdir" install
- install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
- install -Dm644 ../gtk-query-immodules-3.0.hook "$pkgdir/usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook"
+ DESTDIR="$pkgdir" make -C gtk install
+ install -Dt "$pkgdir/usr/share/gtk-3.0" -m644 settings.ini
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-query-immodules-3.0.hook
# gtk-update-icon-cache will be provided in a separate package
rm "$pkgdir/usr/bin/gtk-update-icon-cache"
diff --git a/typeahead.patch b/typeahead.patch
index 1b3961888780..921820880589 100644
--- a/typeahead.patch
+++ b/typeahead.patch
@@ -1,4 +1,4 @@
-@@ -1391,6 +1391,12 @@
+@@ -1390,6 +1390,12 @@
GtkFileChooserWidget *impl = (GtkFileChooserWidget *) widget;
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -11,7 +11,7 @@
if (should_trigger_location_entry (impl, event))
{
if (priv->action == GTK_FILE_CHOOSER_ACTION_OPEN ||
-@@ -1400,12 +1406,6 @@
+@@ -1399,12 +1405,6 @@
return TRUE;
}
}
@@ -24,7 +24,7 @@
if (GTK_WIDGET_CLASS (gtk_file_chooser_widget_parent_class)->key_press_event (widget, event))
return TRUE;
-@@ -2477,7 +2477,7 @@
+@@ -2427,7 +2427,7 @@
{
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -33,7 +33,7 @@
gtk_tree_view_column_set_sort_column_id (priv->list_name_column, MODEL_COL_NAME);
gtk_tree_view_column_set_sort_column_id (priv->list_time_column, MODEL_COL_TIME);
-@@ -4391,6 +4391,7 @@
+@@ -4338,6 +4338,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->browse_files_model));
update_columns (impl, FALSE, _("Modified"));
@@ -41,7 +41,7 @@
file_list_set_sort_column_ids (impl);
set_sort_column (impl);
profile_msg (" gtk_tree_view_set_model end", NULL);
-@@ -7151,10 +7152,6 @@
+@@ -7098,10 +7099,6 @@
{
GList *l, *files, *files_with_info, *infos;
GFile *file;
@@ -52,7 +52,7 @@
files = NULL;
files_with_info = NULL;
-@@ -7182,8 +7179,6 @@
+@@ -7129,8 +7126,6 @@
g_list_free_full (infos, g_object_unref);
gtk_stack_set_visible_child_name (GTK_STACK (impl->priv->browse_files_stack), "list");
@@ -61,7 +61,7 @@
}
/* Callback used from GtkSearchEngine when the query is done running */
-@@ -7480,6 +7475,7 @@
+@@ -7427,6 +7422,7 @@
gtk_tree_sortable_set_sort_column_id (GTK_TREE_SORTABLE (priv->recent_model),
GTK_TREE_SORTABLE_DEFAULT_SORT_COLUMN_ID,
GTK_SORT_DESCENDING);
@@ -69,7 +69,7 @@
}
typedef struct
-@@ -7497,7 +7493,7 @@
+@@ -7444,7 +7440,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->recent_model));