summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeija2015-12-01 18:40:51 +0100
committerJeija2015-12-01 18:40:51 +0100
commitf3297e1cf32ac8b4df6e645d0665d42e781f76e2 (patch)
treec489a48113ad534d618ea58b846de378e390c30b
parent9982835257f1abd0e5a07ca00ef32c01252156b1 (diff)
downloadaur-f3297e1cf32ac8b4df6e645d0665d42e781f76e2.tar.gz
Update to GTK+ 3.18.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--typeahead.patch12
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7081ef0db5f5..9f4dba8bc856 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.18.3
+ pkgver = 3.18.5
pkgrel = 1
url = http://www.gtk.org/
install = gtk3.install
@@ -32,14 +32,14 @@ pkgbase = gtk3-typeahead
depends = librsvg
depends = gtk-update-icon-cache
optdepends = libcanberra: gtk3-widget-factory demo
- provides = gtk3=3.18.3
+ provides = gtk3=3.18.5
conflicts = gtk3
- source = https://download.gnome.org/sources/gtk+/3.18/gtk+-3.18.3.tar.xz
+ source = https://download.gnome.org/sources/gtk+/3.18/gtk+-3.18.5.tar.xz
source = settings.ini
source = typeahead.patch
- sha256sums = f3c76791f93f51e260b03676f83007730b9875a0a9bf5cd42442e2f14e593546
+ sha256sums = 107aeb9a4244ce3c044becdd6dffc32d83202595181597180d4c736302a71852
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
- sha256sums = b915590f309e27a5c430ee692edaff23e51064fc86ff8e159629ef13e4d86646
+ sha256sums = e0c43f9565567bad1284beb028718a75eac20930b25bf53ccfbee9513bc68d15
pkgname = gtk3-typeahead
install = gtk3.install
diff --git a/PKGBUILD b/PKGBUILD
index 681abebc7f86..19a46536398a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.18.3
+pkgver=3.18.5
pkgrel=1
conflicts=(gtk3)
-provides=('gtk3=3.18.3')
+provides=('gtk3=3.18.5')
pkgdesc="GTK+ 3 with typeahead feature enabled for the file chooser widget"
arch=(i686 x86_64)
url="http://www.gtk.org/"
@@ -17,9 +17,9 @@ makedepends=(gobject-introspection libcanberra)
license=(LGPL)
source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
settings.ini typeahead.patch)
-sha256sums=('f3c76791f93f51e260b03676f83007730b9875a0a9bf5cd42442e2f14e593546'
+sha256sums=('107aeb9a4244ce3c044becdd6dffc32d83202595181597180d4c736302a71852'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
- 'b915590f309e27a5c430ee692edaff23e51064fc86ff8e159629ef13e4d86646')
+ 'e0c43f9565567bad1284beb028718a75eac20930b25bf53ccfbee9513bc68d15')
prepare() {
cd gtk+-$pkgver
diff --git a/typeahead.patch b/typeahead.patch
index 4abfab88cfb2..3c652833ffbf 100644
--- a/typeahead.patch
+++ b/typeahead.patch
@@ -1,3 +1,5 @@
+--- gtkfilechooserwidget.c 2015-12-01 18:26:09.210321811 +0100
++++ gtkfilechooserwidget-topatch.c 2015-12-01 18:26:42.030363978 +0100
@@ -1382,12 +1382,6 @@
return TRUE;
}
@@ -11,7 +13,7 @@
if (GTK_WIDGET_CLASS (gtk_file_chooser_widget_parent_class)->key_press_event (widget, event))
return TRUE;
-@@ -2456,7 +2450,7 @@
+@@ -2457,7 +2451,7 @@
{
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -20,7 +22,7 @@
gtk_tree_view_column_set_sort_column_id (priv->list_name_column, MODEL_COL_NAME);
gtk_tree_view_column_set_sort_column_id (priv->list_time_column, MODEL_COL_TIME);
-@@ -4351,6 +4345,7 @@
+@@ -4352,6 +4346,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->browse_files_model));
update_columns (impl, FALSE, _("Modified"));
@@ -28,7 +30,7 @@
file_list_set_sort_column_ids (impl);
set_sort_column (impl);
profile_msg (" gtk_tree_view_set_model end", NULL);
-@@ -7087,10 +7082,6 @@
+@@ -7088,10 +7083,6 @@
{
GList *l, *files, *files_with_info, *infos;
GFile *file;
@@ -39,7 +41,7 @@
files = NULL;
files_with_info = NULL;
-@@ -7118,8 +7109,6 @@
+@@ -7119,8 +7110,6 @@
g_list_free_full (infos, g_object_unref);
gtk_stack_set_visible_child_name (GTK_STACK (impl->priv->browse_files_stack), "list");
@@ -48,7 +50,7 @@
}
/* Callback used from GtkSearchEngine when the query is done running */
-@@ -7453,7 +7442,7 @@
+@@ -7454,7 +7443,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->recent_model));