summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhorsemanoffaith2015-12-31 14:13:46 -0800
committerhorsemanoffaith2015-12-31 14:13:46 -0800
commit997f7df4823dd563b0aaec996215d1c5356d9c03 (patch)
treeae4f405f7e50d3a7e8a3e1f633f4aaa8e0576b8b
downloadaur-997f7df4823dd563b0aaec996215d1c5356d9c03.tar.gz
Initial import
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD90
-rw-r--r--gtk3.install25
3 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdcba03a0f54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# Thu Dec 31 22:10:01 UTC 2015
+pkgbase = gtk3-ubuntu
+ pkgdesc = GObject-based multi-platform toolkit (v3)
+ pkgver = 3.18.6
+ pkgrel = 1
+ url = http://www.gtk.org/
+ install = gtk3.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ depends = atk
+ depends = cairo
+ depends = gtk-update-icon-cache
+ depends = libcups
+ depends = libepoxy
+ depends = libxcursor
+ depends = libxinerama
+ depends = libxrandr
+ depends = libxi
+ depends = libxcomposite
+ depends = libxdamage
+ depends = pango
+ depends = shared-mime-info
+ depends = colord
+ depends = at-spi2-atk
+ depends = wayland
+ depends = libxkbcommon
+ depends = adwaita-icon-theme
+ depends = json-glib
+ depends = rest
+ provides = gtk3=3.18.6
+ conflicts = gtk3
+ source = http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.18/gtk+-3.18.6.tar.xz
+ source = http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_3.18.6-1ubuntu1~wily1.debian.tar.xz
+ sha512sums = a606bfeb7e6991c9c367d6c93d04d70daed6c59b95d1ef14b971acb32b23e71894b0aef16b4c673e1cb2ae0fd08de3f65b7aa5512fd74253efe30f16b0dbac11
+ sha512sums = 03296946286788d96572b7a17381191ee86d30736f652f678190b0c305ab70b10c65b0d732e213745bb24e44c3981c7dcafb1e83d0c519deef440fa25a36e00f
+
+pkgname = gtk3-ubuntu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b503b93c9ae5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Michael Healy <horsemanoffaith@gmail.com>
+
+# vercheck-pkgbuild: auto
+# vercheck-ubuntu: name=gtk+3.0, repo=wily
+# vercheck-archlinux: name=gtk3, repo=extra, arch=x86_64
+# vercheck-gnome: name=gtk+, majorver=3.18
+# vercheck-ppa: name=gtk+3.0, url=ppa:gnome3-team/gnome3-staging
+
+_use_ppa=true
+
+pkgname=gtk3-ubuntu
+_ppa_rel=1ubuntu1~wily1
+#_ubuntu_rel=0ubuntu3.3
+#_ubuntu_ver=3.16.7
+pkgver=3.18.6
+pkgrel=1
+pkgdesc="GObject-based multi-platform toolkit (v3)"
+arch=(i686 x86_64)
+url="http://www.gtk.org/"
+install=gtk3.install
+depends=(atk cairo gtk-update-icon-cache libcups libepoxy libxcursor libxinerama
+ libxrandr libxi libxcomposite libxdamage pango shared-mime-info
+ colord at-spi2-atk wayland libxkbcommon adwaita-icon-theme
+ json-glib rest)
+makedepends=(gobject-introspection)
+provides=("gtk3=${pkgver}")
+conflicts=(gtk3)
+license=(LGPL)
+source=("http://ftp.gnome.org/pub/GNOME/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz")
+
+if [[ "${_use_ppa}" != "true" ]]; then
+ source+=("https://launchpad.net/ubuntu/+archive/primary/+files/gtk+3.0_${_ubuntu_ver:-${pkgver}}-${_ubuntu_rel}.debian.tar.xz")
+else
+ source+=("http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_${_ppa_ver:-${pkgver}}-${_ppa_rel}.debian.tar.xz")
+fi
+
+sha512sums=('a606bfeb7e6991c9c367d6c93d04d70daed6c59b95d1ef14b971acb32b23e71894b0aef16b4c673e1cb2ae0fd08de3f65b7aa5512fd74253efe30f16b0dbac11'
+ '03296946286788d96572b7a17381191ee86d30736f652f678190b0c305ab70b10c65b0d732e213745bb24e44c3981c7dcafb1e83d0c519deef440fa25a36e00f')
+
+prepare() {
+ cd "gtk+-${pkgver}"
+
+ # Apply Ubuntu Patches
+ echo > ../debian/patches/series
+
+ # https://bugs.launchpad.net/indicator-messages/+bug/1088162
+ # Dependency check: grep -R ubuntu-private.h * | cut -d/ -f1
+ echo 'ubuntu_gtk_custom_menu_items.patch' >> ../debian/patches/series
+ # Do not allow offscreen widgets to grab the cursor
+ echo '016_no_offscreen_widgets_grabbing.patch' >> ../debian/patches/series
+ echo '017_no_offscreen_device_grabbing.patch' >> ../debian/patches/series
+ # Allow printing to printers advertised using Avahi/Bonjour when CUPS 1.6
+ echo 'print-dialog-show-options-of-remote-dnssd-printers.patch' >> ../debian/patches/series
+ # Unity-specific
+ #echo '0001-Add-style-classes-to-the-title-buttons.patch' >> ../debian/patches/series
+ echo 'message-dialog-restore-traditional-look-on-unity.patch' >> ../debian/patches/series
+ # Other
+ echo 'bzg_gtkcellrenderer_grabbing_modifier.patch' >> ../debian/patches/series
+ for i in $(grep -v '#' ../debian/patches/series); do
+ msg "Applying ${i} ..."
+ patch -p1 -i "../debian/patches/${i}"
+ done
+}
+
+build() {
+ cd "gtk+-${pkgver}"
+
+ autoreconf -vfi
+
+ #CXX=/bin/false ./configure \
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-schemas-compile \
+ --enable-x11-backend \
+ --enable-broadway-backend \
+ --enable-wayland-backend
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd "gtk+-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -f "$pkgdir/usr/bin/gtk-update-icon-cache"
+}
diff --git a/gtk3.install b/gtk3.install
new file mode 100644
index 000000000000..92341331ab9d
--- /dev/null
+++ b/gtk3.install
@@ -0,0 +1,25 @@
+post_install() {
+ /usr/bin/gtk-query-immodules-3.0 --update-cache
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+ /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ echo "If you want to use the global menus and you are not using Unity, you will need"
+ echo "to add the following to ~/.config/gtk-3.0/settings.ini"
+ echo
+ echo "********************************"
+ echo "[Settings]"
+ echo "gtk-shell-shows-menubar = 1"
+ echo "********************************"
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ rm -f /usr/lib/gtk-3.0/3.0.0/immodules.cache
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+ /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}