summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcharlie52015-07-28 23:17:41 +1000
committercharlie52015-07-28 23:17:41 +1000
commit2877d1f2d37d282ea1559340e09daa25c5b6046b (patch)
tree365148014497f3e4736ec9a83f53c5b1b34a6f29
downloadaur-2877d1f2d37d282ea1559340e09daa25c5b6046b.tar.gz
Initial import.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD53
-rw-r--r--patch-Makefile.in19
-rw-r--r--patch-projects-Makefile.in15
4 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5113c56f8007
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gtkada
+ pkgdesc = GtkAda is a Gtk3 binding for Ada using the OOP and other features of this programming language
+ pkgver = 2015
+ pkgrel = 1
+ url = http://libre.adacore.com/libre/tools/GtkAda/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-ada
+ depends = gtk3
+ source = http://mirrors.cdn.adacore.com/art/db00d9243e8d34c0da0a583c22903272f2d28135
+ source = patch-Makefile.in
+ source = patch-projects-Makefile.in
+ md5sums = c152b45c9f768aef92cf325bfb2ca138
+ md5sums = 4fee2f1951c7f6f65e6009973af482c6
+ md5sums =
+
+pkgname = gtkada
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c703c58ec7de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Patrick Kelly <kameo76890 at gmail dot com>
+# Contributor: Georgios Tsalikis <aliverius somewhere near tsalikis and a net>
+# Contributor: Julian Leyh <julian@vgai.de>
+# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=gtkada
+pkgver=2015
+pkgrel=1
+
+pkgdesc="GtkAda is a Gtk3 binding for Ada using the OOP and other features of this programming language"
+arch=('i686' 'x86_64')
+url="http://libre.adacore.com/libre/tools/GtkAda/"
+license=('GPL')
+
+depends=("gtk3")
+makedepends=("gcc-ada")
+
+source=(http://mirrors.cdn.adacore.com/art/db00d9243e8d34c0da0a583c22903272f2d28135
+ patch-Makefile.in
+ patch-projects-Makefile.in)
+
+md5sums=('c152b45c9f768aef92cf325bfb2ca138'
+ '88657345aace9e2020f74854daa64ef2'
+ '7143323e2c631df019fafc109b432703')
+
+
+
+prepare()
+{
+ cd "$srcdir/$pkgname-gpl-$pkgver-src"
+
+ patch -Np0 -i "$srcdir/patch-Makefile.in"
+ patch -Np0 -i "$srcdir/patch-projects-Makefile.in"
+}
+
+
+
+build()
+{
+ cd "$srcdir/$pkgname-gpl-$pkgver-src"
+
+ ./configure --prefix=/usr --with-GL=no
+ DESTDIR=$pkgdir make -j1 # It doesn't build with -jn where n>1
+}
+
+
+
+package()
+{
+ cd "$srcdir/$pkgname-gpl-$pkgver-src"
+
+ DESTDIR=$pkgdir make -j1 install
+}
diff --git a/patch-Makefile.in b/patch-Makefile.in
new file mode 100644
index 000000000000..b71e2b950476
--- /dev/null
+++ b/patch-Makefile.in
@@ -0,0 +1,19 @@
+*** Makefile.in-orig 2015-07-28 23:01:10.096835001 +1000
+--- Makefile.in 2015-07-28 23:01:30.790148852 +1000
+***************
+*** 41,47 ****
+ BUILD_STATIC=@BUILD_STATIC@
+ TARNAME=@PACKAGE_TARNAME@
+ VERSION=@PACKAGE_VERSION@
+! DESTDIR=
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ includedir=${DESTDIR}@includedir@
+--- 41,47 ----
+ BUILD_STATIC=@BUILD_STATIC@
+ TARNAME=@PACKAGE_TARNAME@
+ VERSION=@PACKAGE_VERSION@
+! #DESTDIR=
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ includedir=${DESTDIR}@includedir@
diff --git a/patch-projects-Makefile.in b/patch-projects-Makefile.in
new file mode 100644
index 000000000000..67e2cc0b54bf
--- /dev/null
+++ b/patch-projects-Makefile.in
@@ -0,0 +1,15 @@
+*** projects/Makefile.in-orig 2015-07-28 23:09:18.133199940 +1000
+--- projects/Makefile.in 2015-07-28 23:09:29.229862562 +1000
+***************
+*** 1,5 ****
+ MKDIR = mkdir -p
+! DESTDIR=
+ prefix = @prefix@
+ libdir = @libdir@
+ incdir = @includedir@/gtkada
+--- 1,5 ----
+ MKDIR = mkdir -p
+! #DESTDIR=
+ prefix = @prefix@
+ libdir = @libdir@
+ incdir = @includedir@/gtkada