summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2016-06-11 20:23:15 +1000
committerRod Kay2016-06-11 20:23:15 +1000
commit606c98ab8bd596bfa818fa90e76bc85254199cc4 (patch)
treebbee84dd9b0588216acec935a63769fccb70a95c
parent198b8f0f656ba0a4be6016e95fb0d6fc1296822b (diff)
downloadaur-606c98ab8bd596bfa818fa90e76bc85254199cc4.tar.gz
Added support for openGL.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--patch-Makefile.in21
-rw-r--r--patch-aclocal.m413
-rw-r--r--patch-gtkglarea.c11
-rw-r--r--patch-projects-Makefile.in15
-rw-r--r--patch-testgtk.gpr19
7 files changed, 84 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ffeea14022f..8f36f8ca286e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jun 5 03:00:31 UTC 2016
+# Sat Jun 11 10:22:41 UTC 2016
pkgbase = gtkada
pkgdesc = GtkAda is a Gtk3 binding for Ada using the OOP and other features of this programming language
pkgver = 2016
@@ -15,9 +15,15 @@ pkgbase = gtkada
source = http://mirrors.cdn.adacore.com/art/5739985fc7a447658e0affae
source = patch-shared.gpr.in
source = patch-Makefile.in
+ source = patch-aclocal.m4
+ source = patch-gtkglarea.c
+ source = patch-testgtk.gpr
sha1sums = 024aeb4e6a3d48059b5a80b90d606f760cc05e97
sha1sums = 5d165fac792018dceae026083f5c335738879c8d
- sha1sums = a21e5671e0a9eb6e31cb14170676ee4382e32a45
+ sha1sums = 237efb4ca634752fe21ce299b4261bb1fded2d52
+ sha1sums = 5716bb623634c88e7e04849ca7fc000d76cb4882
+ sha1sums = cab6c699945ff8b5af0c5de0fd0f088012aba114
+ sha1sums = 1a4069100cca7d2df9de23562f6ef0ede537b57a
pkgname = gtkada
diff --git a/PKGBUILD b/PKGBUILD
index 5b4e5b80a808..1909b1147184 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,17 @@ makedepends=("gcc-ada")
source=(http://mirrors.cdn.adacore.com/art/5739985fc7a447658e0affae
patch-shared.gpr.in
- patch-Makefile.in)
+ patch-Makefile.in
+ patch-aclocal.m4
+ patch-gtkglarea.c
+ patch-testgtk.gpr)
sha1sums=('024aeb4e6a3d48059b5a80b90d606f760cc05e97'
'5d165fac792018dceae026083f5c335738879c8d'
- 'a21e5671e0a9eb6e31cb14170676ee4382e32a45')
+ '237efb4ca634752fe21ce299b4261bb1fded2d52'
+ '5716bb623634c88e7e04849ca7fc000d76cb4882'
+ 'cab6c699945ff8b5af0c5de0fd0f088012aba114'
+ '1a4069100cca7d2df9de23562f6ef0ede537b57a')
@@ -31,6 +37,9 @@ prepare()
patch -Np0 -i "$srcdir/patch-shared.gpr.in"
patch -Np0 -i "$srcdir/patch-Makefile.in"
+ patch -Np0 -i "$srcdir/patch-aclocal.m4"
+ patch -Np0 -i "$srcdir/patch-gtkglarea.c"
+ patch -Np0 -i "$srcdir/patch-testgtk.gpr"
}
@@ -39,8 +48,9 @@ build()
{
cd "$srcdir/$pkgname-gpl-$pkgver-src"
- ./configure --prefix=/usr --with-GL=no
- DESTDIR=$pkgdir make -j1 # It doesn't build with -jn where n>1
+ autoconf
+ ./configure --prefix=/usr
+ DESTDIR=$pkgdir make -j1 # It doesn't build with -jn where n>1
}
diff --git a/patch-Makefile.in b/patch-Makefile.in
index 820a7a4f6ed5..199e6f42ee3a 100644
--- a/patch-Makefile.in
+++ b/patch-Makefile.in
@@ -1,5 +1,5 @@
-*** Makefile.in 2016-06-03 08:00:16.667424520 +1000
---- Makefile.in-new 2016-06-03 07:58:24.034086565 +1000
+*** Makefile.in 2016-04-26 22:46:18.000000000 +1000
+--- Makefile.in-new 2016-06-11 20:11:44.708679466 +1000
***************
*** 35,41 ****
BUILD_STATIC=@BUILD_STATIC@
@@ -18,6 +18,23 @@
exec_prefix=@exec_prefix@
libdir=@libdir@
***************
+*** 93,99 ****
+ ifeq (${HAVE_OPENGL}, True)
+ ${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(@F) --build-name=$(@F) \
+ --sources-subdir=include/gtkada/gtkada_gl.$(@F) \
+! --lib-subdir=${libdir}/gtkada/gtkada_gl.$(@F) \
+ -Psrc/opengl/gtkada_gl.gpr
+ endif
+
+--- 93,99 ----
+ ifeq (${HAVE_OPENGL}, True)
+ ${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(@F) --build-name=$(@F) \
+ --sources-subdir=include/gtkada/gtkada_gl.$(@F) \
+! --lib-subdir=lib/gtkada/gtkada_gl.$(@F) \
+ -Psrc/opengl/gtkada_gl.gpr
+ endif
+
+***************
*** 107,113 ****
${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
--mode=usage -Psrc/tools/tools.gpr
diff --git a/patch-aclocal.m4 b/patch-aclocal.m4
new file mode 100644
index 000000000000..550a737d8784
--- /dev/null
+++ b/patch-aclocal.m4
@@ -0,0 +1,13 @@
+*** aclocal.m4 2016-06-11 19:18:23.281881426 +1000
+--- aclocal.m4-new 2016-06-11 19:18:39.538548759 +1000
+***************
+*** 426,431 ****
+--- 426,433 ----
+ ;;
+ esac
+
++ GL_LIBS+=" -lm -lX11"
++
+ AC_SUBST(GL_LIBS)
+ AC_SUBST(GL_CFLAGS)
+ AC_SUBST(HAVE_OPENGL)
diff --git a/patch-gtkglarea.c b/patch-gtkglarea.c
new file mode 100644
index 000000000000..4763f6cf10c9
--- /dev/null
+++ b/patch-gtkglarea.c
@@ -0,0 +1,11 @@
+--- src/opengl/gtkglarea.c
++++ src/opengl/gtkglarea.c
+@@ -20,6 +20,7 @@
+ #include <stdarg.h>
+
+ #include "gdkgl.h"
++#define __GI_SCANNER__
+ #include "gtkglarea.h"
+
+ static void gtk_gl_area_class_init (GtkGLAreaClass *klass);
+
diff --git a/patch-projects-Makefile.in b/patch-projects-Makefile.in
deleted file mode 100644
index 67e2cc0b54bf..000000000000
--- a/patch-projects-Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
-*** projects/Makefile.in-orig 2015-07-28 23:09:18.133199940 +1000
---- projects/Makefile.in 2015-07-28 23:09:29.229862562 +1000
-***************
-*** 1,5 ****
- MKDIR = mkdir -p
-! DESTDIR=
- prefix = @prefix@
- libdir = @libdir@
- incdir = @includedir@/gtkada
---- 1,5 ----
- MKDIR = mkdir -p
-! #DESTDIR=
- prefix = @prefix@
- libdir = @libdir@
- incdir = @includedir@/gtkada
diff --git a/patch-testgtk.gpr b/patch-testgtk.gpr
new file mode 100644
index 000000000000..ece333637a1b
--- /dev/null
+++ b/patch-testgtk.gpr
@@ -0,0 +1,19 @@
+--- testgtk/testgtk.gpr
++++ testgtk/testgtk.gpr
+@@ -21,13 +21,13 @@
+ -- --
+ ------------------------------------------------------------------------------
+
+-with "gtkada";
++with "opengl/testgtk_opengl";
+
+ project TestGtk is
+
+ for Languages use ("Ada");
+ for Main use ("testgtk.adb", "test_rtree.adb");
+- for Source_Dirs use ("./", "opengl");
++ for Source_Dirs use ("./");
+ for Object_Dir use "obj/";
+ for Exec_Dir use ".";
+
+