summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2022-12-15 21:21:07 +0530
committertxtsd2022-12-15 21:21:07 +0530
commit6f500d780134871d8870d0eb3ba73afb29673013 (patch)
treebf64736ea55e357c1fcce95a57fe13b4af22dcc4
parent7b3148b3d1a50157979c8e7fa657b6c6e0725455 (diff)
downloadaur-6f500d780134871d8870d0eb3ba73afb29673013.tar.gz
upgpkg: gtkcord4-bin 0.0.6-1
Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD24
3 files changed, 29 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 900301d72df8..df706bc90e28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtkcord4-bin
pkgdesc = Discord client written in go and gtk4, binary release
- pkgver = 0.0.4
+ pkgver = 0.0.6
pkgrel = 1
url = https://github.com/diamondburned/gtkcord4
arch = x86_64
@@ -11,13 +11,13 @@ pkgbase = gtkcord4-bin
provides = gtkcord4
conflicts = gtkcord4
conflicts = gtkcord4-git
- source_x86_64 = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.4-2/gtkcord4-linux-x86_64.tar.gz
- source_x86_64 = gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git
- sha256sums_x86_64 = SKIP
- sha256sums_x86_64 = SKIP
- source_aarch64 = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.4-2/gtkcord4-linux-aarch64.tar.gz
- source_aarch64 = gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git
- sha256sums_aarch64 = SKIP
- sha256sums_aarch64 = SKIP
+ source_x86_64 = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.6/gtkcord4-linux-x86_64.tar.gz
+ source_x86_64 = gtkcord4.desktop::https://raw.githubusercontent.com/diamondburned/gtkcord4/v0.0.6/.nix/com.github.diamondburned.gtkcord4.desktop
+ sha256sums_x86_64 = dd1811c84d15883f9741bf01d2936a7c2fcd176b7237e75d9c87919ef76aa822
+ sha256sums_x86_64 = 8a2bffbe6e33af6f0b79366fb153114f2de3e16b538cc303d40ddd1841d7d1df
+ source_aarch64 = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.6/gtkcord4-linux-aarch64.tar.gz
+ source_aarch64 = gtkcord4.desktop::https://raw.githubusercontent.com/diamondburned/gtkcord4/v0.0.6/.nix/com.github.diamondburned.gtkcord4.desktop
+ sha256sums_aarch64 = 763372815fa17e012c12cfc61deee25fc0b0a081fac18aa9a737cfd3c06742f7
+ sha256sums_aarch64 = 8a2bffbe6e33af6f0b79366fb153114f2de3e16b538cc303d40ddd1841d7d1df
pkgname = gtkcord4-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7d58ddecd730
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+
+*.tar.zst
+*.tar.gz
+*.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 41600b459112..9a23dc35f317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: esrh - https://esrh.me
-# Desktop file from gtkcord4-git by dawson dias
+# Maintainer: txtsd <aur.archlinux@ihavea.quest>
pkgname=gtkcord4-bin
_pkgname=gtkcord4
-pkgver=0.0.4
+pkgver=0.0.6
pkgrel=1
pkgdesc='Discord client written in go and gtk4, binary release'
arch=('x86_64' 'aarch64')
@@ -13,15 +13,19 @@ provides=('gtkcord4')
conflicts=('gtkcord4' 'gtkcord4-git')
depends=('gtk4' 'gobject-introspection')
-source_x86_64=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.4-2/gtkcord4-linux-x86_64.tar.gz'
- 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
-sha256sums_x86_64=('SKIP' 'SKIP')
+source_x86_64=("https://github.com/diamondburned/gtkcord4/releases/download/v${pkgver}/gtkcord4-linux-x86_64.tar.gz"
+ "${_pkgname}.desktop::https://raw.githubusercontent.com/diamondburned/gtkcord4/v${pkgver}/.nix/com.github.diamondburned.gtkcord4.desktop")
+source_aarch64=("https://github.com/diamondburned/gtkcord4/releases/download/v${pkgver}/gtkcord4-linux-aarch64.tar.gz"
+ "${_pkgname}.desktop::https://raw.githubusercontent.com/diamondburned/gtkcord4/v${pkgver}/.nix/com.github.diamondburned.gtkcord4.desktop")
+sha256sums_x86_64=('dd1811c84d15883f9741bf01d2936a7c2fcd176b7237e75d9c87919ef76aa822'
+ '8a2bffbe6e33af6f0b79366fb153114f2de3e16b538cc303d40ddd1841d7d1df')
+sha256sums_aarch64=('763372815fa17e012c12cfc61deee25fc0b0a081fac18aa9a737cfd3c06742f7'
+ '8a2bffbe6e33af6f0b79366fb153114f2de3e16b538cc303d40ddd1841d7d1df')
-source_aarch64=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.4-2/gtkcord4-linux-aarch64.tar.gz'
- 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
-sha256sums_aarch64=('SKIP' 'SKIP')
package() {
- install -Dm755 gtkcord4 "$pkgdir"/usr/bin/gtkcord4
- install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm755 gtkcord4 "${pkgdir}"/usr/bin/gtkcord4
+ install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ sed -i "s/Chat;/Chat;InstantMessaging;/" "${srcdir}/${_pkgname}.desktop"
+ install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
}