summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2022-08-03 11:27:51 -0400
committereshrh2022-08-03 11:27:51 -0400
commit9ab6801edb76118ee7dfeb4e4ad296f8c51bcd35 (patch)
treed8bba0050175b6c474478fd00dfcc6830d698289
parenta5e53e38b47fc6b6f6bf73127b6d582f7cc225a6 (diff)
downloadaur-9ab6801edb76118ee7dfeb4e4ad296f8c51bcd35.tar.gz
add aarch64
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05fad9e410fa..12195b4d6617 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,15 +4,20 @@ pkgbase = gtkcord4-bin
pkgrel = 1
url = https://github.com/diamondburned/gtkcord4
arch = x86_64
+ arch = aarch64
license = GPL3
depends = gtk4
depends = gobject-introspection
provides = gtkcord4
conflicts = gtkcord4
conflicts = gtkcord4-git
- source = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz
- source = gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git
- sha256sums = SKIP
- sha256sums = SKIP
+ source_x86_64 = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz
+ source_x86_64 = gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git
+ sha256sums_x86_64 = SKIP
+ sha256sums_x86_64 = SKIP
+ source_aarch64 = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-aarch64.tar.gz
+ source_aarch64 = gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git
+ sha256sums_aarch64 = SKIP
+ sha256sums_aarch64 = SKIP
pkgname = gtkcord4-bin
diff --git a/PKGBUILD b/PKGBUILD
index d9538486c734..a8d653fdf96f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,22 @@ _pkgname=gtkcord4
pkgver=0.0.3
pkgrel=1
pkgdesc='Discord client written in go and gtk4, binary release'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url='https://github.com/diamondburned/gtkcord4'
license=('GPL3')
provides=('gtkcord4')
conflicts=('gtkcord4' 'gtkcord4-git')
depends=('gtk4' 'gobject-introspection')
-source=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz'
- 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
-sha256sums=('SKIP' 'SKIP')
+
+source_x86_64=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz'
+ 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
+sha256sums_x86_64=('SKIP' 'SKIP')
+
+source_aarch64=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-aarch64.tar.gz'
+ 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
+sha256sums_aarch64=('SKIP' 'SKIP')
package() {
- tar -xzf gtkcord4-linux-x86_64.tar.gz
install -Dm755 gtkcord4 "$pkgdir"/usr/bin/gtkcord4
install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
}