summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2022-07-08 00:32:52 -0400
committereshrh2022-07-08 00:32:52 -0400
commita5e53e38b47fc6b6f6bf73127b6d582f7cc225a6 (patch)
treee287aef50931e3fb30d6ee8db185da2306faa724
downloadaur-a5e53e38b47fc6b6f6bf73127b6d582f7cc225a6.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05fad9e410fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gtkcord4-bin
+ pkgdesc = Discord client written in go and gtk4, binary release
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/diamondburned/gtkcord4
+ arch = x86_64
+ license = GPL3
+ depends = gtk4
+ depends = gobject-introspection
+ provides = gtkcord4
+ conflicts = gtkcord4
+ conflicts = gtkcord4-git
+ source = https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz
+ source = gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gtkcord4-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9538486c734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: esrh - https://esrh.me
+# Desktop file from gtkcord4-git by dawson dias
+
+pkgname=gtkcord4-bin
+_pkgname=gtkcord4
+pkgver=0.0.3
+pkgrel=1
+pkgdesc='Discord client written in go and gtk4, binary release'
+arch=('x86_64')
+url='https://github.com/diamondburned/gtkcord4'
+license=('GPL3')
+provides=('gtkcord4')
+conflicts=('gtkcord4' 'gtkcord4-git')
+depends=('gtk4' 'gobject-introspection')
+source=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz'
+ 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
+sha256sums=('SKIP' 'SKIP')
+
+package() {
+ tar -xzf gtkcord4-linux-x86_64.tar.gz
+ install -Dm755 gtkcord4 "$pkgdir"/usr/bin/gtkcord4
+ install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}