summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2022-04-17 19:55:07 +0530
committertxtsd2022-04-17 19:59:25 +0530
commit9be80d3ebc28aa97d8328d84e1dd73b4b421e2d4 (patch)
treedc85dd2088cd4db2beea80044937208e0b9e00c0
downloadaur-9be80d3ebc28aa97d8328d84e1dd73b4b421e2d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
-rw-r--r--gtkcord4.desktop9
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..991c878a9336
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gtkcord4-git
+ pkgdesc = Discord client written in go and gtk4
+ pkgver = r18.3a9dba7
+ pkgrel = 1
+ url = https://github.com/diamondburned/gtkcord4
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ depends = gtk4
+ provides = gtkcord4
+ conflicts = gtkcord4
+ source = git+https://github.com/diamondburned/gtkcord4
+ source = gtkcord4.desktop
+ sha256sums = SKIP
+ sha256sums = 1b1fd0dcaeecaad57a4ee4e204605bd95302dd914ae0198eccdd1f3af79e3d10
+
+pkgname = gtkcord4-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e50b78e97dcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Dawson Dias <thexerothermicsclerodermoid@gmail.com>
+
+pkgname=gtkcord4-git
+_pkgname=gtkcord4
+pkgver=r18.3a9dba7
+pkgrel=1
+pkgdesc='Discord client written in go and gtk4'
+arch=('any')
+url='https://github.com/diamondburned/gtkcord4'
+license=('GPL3')
+depends=('gtk4')
+provides=('gtkcord4')
+conflicts=('gtkcord4')
+makedepends=('git' 'go')
+source=('git+https://github.com/diamondburned/gtkcord4'
+ 'gtkcord4.desktop')
+sha256sums=('SKIP'
+ '1b1fd0dcaeecaad57a4ee4e204605bd95302dd914ae0198eccdd1f3af79e3d10')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ # add config flags as per https://wiki.archlinux.org/index.php/Go_package_guidelines
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
+
+ # check if user has already set their GoLang path
+ if [[ -z "${GOPATH}" ]]; then
+ export GOPATH="${srcdir}/go"
+ fi
+ cd "$_pkgname"
+ go mod tidy
+ go build -trimpath
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ # install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ # install -Dm644 logo.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/gtkcord.png"
+}
+
diff --git a/gtkcord4.desktop b/gtkcord4.desktop
new file mode 100644
index 000000000000..fb1c1ecbe9bc
--- /dev/null
+++ b/gtkcord4.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=gtkcord
+Comment=A lightweight Discord client which uses GTK4 for the user interface.
+Exec=gtkcord4
+Icon=gtkcord
+Terminal=false
+Type=Application
+Categories=Network;InstantMessaging;P2P;
+