summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892015-09-24 15:22:57 +0200
committerPhoton892015-09-24 15:22:57 +0200
commit1520bf8691c487aa3803c4ff8b5ea104d01133a2 (patch)
tree49df6e693a9449312449289408ec338d3df39256
downloadaur-1520bf8691c487aa3803c4ff8b5ea104d01133a2.tar.gz
initial reupload of deleted package since dependency of lightspeed missing
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..713f9936118a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gtkglarea1
+ pkgdesc = OpenGL context provider for GTK+
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = http://www.mono-project.com/GtkGLArea
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk
+ depends = mesa
+ options = !libtool
+ source = http://sourceforge.net/projects/openev/files/gtkglarea/gtkglarea-1.2.3/gtkglarea-1.2.3.tar.gz/download
+ md5sums = 44f6804c1a9db61393e18680c81ae602
+
+pkgname = gtkglarea1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2ef6143d06e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Mainrainer: Michael Kogan <michael dot kogan at gmx dot net >
+
+
+pkgname=gtkglarea1
+_pkgname=gtkglarea
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="OpenGL context provider for GTK+"
+arch=('i686' 'x86_64')
+url="http://www.mono-project.com/GtkGLArea"
+license=('GPL')
+depends=('gtk' 'mesa')
+options=('!libtool')
+source=("http://sourceforge.net/projects/openev/files/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz/download")
+md5sums=('44f6804c1a9db61393e18680c81ae602')
+
+_optimal_make_jobs() {
+ if [ -r /proc/cpuinfo ]; then
+ local core_count=$(grep -Fc processor /proc/cpuinfo)
+ else
+ local core_count=0
+ fi
+
+ if [ $core_count -gt 1 ]; then
+ echo -n $[$core_count-1]
+ else
+ echo -n 1
+ fi
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ msg 'Running configure...'
+ ./configure --prefix=/usr
+
+ msg 'Running make'
+ make -j$(_optimal_make_jobs)
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}