summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-08 22:39:48 +0100
committerCarsten Teibes2014-01-08 22:39:48 +0100
commitba4f12a680141c6f39fa783438e877491d4acde0 (patch)
treef4662ff394afcbf745f20c83157c66ccb8523c6e
parent43f3bfc8974fcfdcf8c222ac363bab5f9da413f1 (diff)
downloadaur-ba4f12a680141c6f39fa783438e877491d4acde0.tar.gz
Cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b064b4c2bf4c..0695b45fed60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = gtkhash
- pkgdesc = A GTK+ utility for computing message digests or checksums.
+ pkgdesc = A GTK+ utility for computing message digests or checksums
pkgver = 0.7.0
pkgrel = 2
url = http://gtkhash.sourceforge.net/
@@ -15,10 +15,8 @@ pkgbase = gtkhash
optdepends = nemo: filemanager plugin
source = http://downloads.sourceforge.net/gtkhash/gtkhash-0.7.0.tar.xz
source = gtkhash.desktop
- md5sums = f80567fdd8c4435e03b837d54f38f1bb
- md5sums = SKIP
sha256sums = 161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd
- sha256sums = SKIP
+ sha256sums = f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388
pkgname = gtkhash
diff --git a/PKGBUILD b/PKGBUILD
index 5ae432c053f0..d2532586952e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
# Contributor: Jan Böhringer <janboe@gmail.com>
# Contributor: Frédérik Paradis <fredy_14@live.fr>
# Contributor: GI_Jack <GI_Jack@hushmail.com>
@@ -13,19 +13,17 @@ _thunar_plugin=n
pkgname=gtkhash
pkgver=0.7.0
pkgrel=2
-pkgdesc="A GTK+ utility for computing message digests or checksums."
+pkgdesc="A GTK+ utility for computing message digests or checksums"
arch=('i686' 'x86_64' 'mips64el')
url="http://gtkhash.sourceforge.net/"
license=('GPL')
makedepends=('intltool')
depends=('dconf')
install=$pkgname.install
-source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz
- gtkhash.desktop)
-md5sums=('f80567fdd8c4435e03b837d54f38f1bb'
- 'SKIP')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz"
+ "gtkhash.desktop")
sha256sums=('161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd'
- 'SKIP')
+ 'f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388')
# gtk version
if [ "$_gtk_version" = "3" ]; then
@@ -62,15 +60,14 @@ build() {
./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
--enable-linux-crypto --enable-nettle $_pkgoptions
-
make
}
package() {
cd $pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ make DESTDIR="$pkgdir/" install
# install desktop entry
- install -Dm644 ../gtkhash.desktop $pkgdir/usr/share/applications/gtkhash.desktop
+ install -Dm644 ../gtkhash.desktop "$pkgdir"/usr/share/applications/gtkhash.desktop
}