summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2024-04-09 15:39:22 +0200
committerFabioLolix2024-04-09 15:39:22 +0200
commit69b043d75fd5808f887529751c1289698647e43f (patch)
tree2d1f844c0df32e88a38b483bc2e4f7d110e170d8
parent9fd67b54e9581d9060f2290ca7619af562d81d0c (diff)
downloadaur-gtkhash-git.tar.gz
revision
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
-rw-r--r--gtkhash.install12
3 files changed, 31 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8747ab8c314e..58d9a5fb5044 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = gtkhash-git
- pkgdesc = A cross-platform desktop utility for computing message digests or checksums (development version).
- pkgver = v1.4.r64.g3afea16
+ pkgdesc = A cross-platform desktop utility for computing message digests or checksums
+ pkgver = 1.5.r35.ge85ab4d
pkgrel = 1
- url = https://github.com/tristanheaven/gtkhash
- arch = i686
+ url = https://github.com/gtkhash/gtkhash
arch = x86_64
+ arch = i686
license = GPL2
makedepends = git
depends = dconf
@@ -13,8 +13,7 @@ pkgbase = gtkhash-git
depends = gtk3
provides = gtkhash
conflicts = gtkhash
- source = gtkhash::git+https://github.com/tristanheaven/gtkhash.git
- md5sums = SKIP
+ source = git+https://github.com/gtkhash/gtkhash.git
+ sha256sums = SKIP
pkgname = gtkhash-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3236d2344653..2f603d831432 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,42 @@
-# Maintainer: carstene1ns - https://git.io/ctPKG
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: carstene1ns - https://git.io/ctPKG
pkgname=gtkhash-git
-pkgver=v1.4.r64.g3afea16
+pkgver=1.5.r35.ge85ab4d
pkgrel=1
-pkgdesc='A cross-platform desktop utility for computing message digests or checksums (development version).'
-arch=('i686' 'x86_64')
-url='https://github.com/tristanheaven/gtkhash'
-license=('GPL2')
-makedepends=('git')
-depends=('dconf' 'nettle' 'libb2' 'gtk3')
-conflicts=('gtkhash')
-provides=('gtkhash')
-source=(gtkhash::"git+https://github.com/tristanheaven/gtkhash.git")
-md5sums=('SKIP')
+pkgdesc="A cross-platform desktop utility for computing message digests or checksums"
+arch=(x86_64 i686)
+url="https://github.com/gtkhash/gtkhash"
+license=(GPL2)
+depends=(dconf nettle libb2 gtk3)
+makedepends=(git)
+conflicts=(gtkhash)
+provides=(gtkhash)
+source=("git+https://github.com/gtkhash/gtkhash.git")
+sha256sums=('SKIP')
pkgver() {
cd gtkhash
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
- git describe --long --tags | sed 's/-/.r/;s/-/./'
+prepare() {
+ cd gtkhash
+ ./autogen.sh
}
build() {
cd gtkhash
+ ./configure \
+ --prefix=/usr \
+ --disable-schemas-compile \
+ --enable-gtkhash \
+ --enable-linux-crypto \
+ --enable-nettle
- ./autogen.sh
- ./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
- --enable-linux-crypto --enable-nettle
make
}
package() {
- make -C gtkhash DESTDIR="$pkgdir/" install
+ make -C gtkhash DESTDIR="${pkgdir}" install
}
diff --git a/gtkhash.install b/gtkhash.install
deleted file mode 100644
index a432ada8586d..000000000000
--- a/gtkhash.install
+++ /dev/null
@@ -1,12 +0,0 @@
-
-post_install() {
- glib-compile-schemas /usr/share/glib-2.0/schemas
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}