summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2021-04-18 19:39:03 +0200
committerCarsten Teibes2021-04-18 19:39:03 +0200
commit9fd67b54e9581d9060f2290ca7619af562d81d0c (patch)
tree5c036f189ff21ff75b93847c4a717a68d2811134
parent84f524786eac244f42070edc00b95557bcfa3ef3 (diff)
downloadaur-9fd67b54e9581d9060f2290ca7619af562d81d0c.tar.gz
[upd] separate file manager plugins
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD55
2 files changed, 18 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1df87ad577e4..8747ab8c314e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,20 @@
pkgbase = gtkhash-git
- pkgdesc = A GTK+ utility for computing message digests or checksums (development version).
- pkgver = 0.7.0.r4.ga01ad64
+ pkgdesc = A cross-platform desktop utility for computing message digests or checksums (development version).
+ pkgver = v1.4.r64.g3afea16
pkgrel = 1
- url = http://gtkhash.sourceforge.net/
+ url = https://github.com/tristanheaven/gtkhash
arch = i686
arch = x86_64
- license = GPL
- makedepends = intltool
+ license = GPL2
makedepends = git
- makedepends = nemo
- makedepends = libnautilus-extension
- makedepends = thunar
depends = dconf
depends = nettle
+ depends = libb2
depends = gtk3
provides = gtkhash
conflicts = gtkhash
source = gtkhash::git+https://github.com/tristanheaven/gtkhash.git
- source = gtkhash.desktop
- sha256sums = SKIP
- sha256sums = f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388
+ md5sums = SKIP
pkgname = gtkhash-git
- install = gtkhash.install
-
-pkgname = gtkhash-nemo-git
- pkgdesc = A GTK+ utility for computing message digests or checksums (development version). - Nemo filemanager plugin
- depends = gtkhash-git
- depends = nemo
-
-pkgname = gtkhash-nautilus-git
- pkgdesc = A GTK+ utility for computing message digests or checksums (development version). - Nautilus filemanager plugin
- depends = gtkhash-git
- depends = nautilus
-
-pkgname = gtkhash-thunar-git
- pkgdesc = A GTK+ utility for computing message digests or checksums (development version). - Thunar filemanager plugin
- depends = gtkhash-git
- depends = thunar
diff --git a/PKGBUILD b/PKGBUILD
index b54f4ad30dcc..3236d2344653 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,18 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns - https://git.io/ctPKG
-pkgbase=gtkhash-git
-pkgname=(gtkhash-git gtkhash-nemo-git gtkhash-nautilus-git gtkhash-thunar-git)
-pkgver=0.7.0.r4.ga01ad64
+pkgname=gtkhash-git
+pkgver=v1.4.r64.g3afea16
pkgrel=1
-pkgdesc='A GTK+ utility for computing message digests or checksums (development version).'
+pkgdesc='A cross-platform desktop utility for computing message digests or checksums (development version).'
arch=('i686' 'x86_64')
-url='http://gtkhash.sourceforge.net/'
-license=('GPL')
-makedepends=('intltool' 'git' 'nemo' 'libnautilus-extension' 'thunar') # ← remove FMs here!
-depends=('dconf' 'nettle' 'gtk3')
+url='https://github.com/tristanheaven/gtkhash'
+license=('GPL2')
+makedepends=('git')
+depends=('dconf' 'nettle' 'libb2' 'gtk3')
conflicts=('gtkhash')
provides=('gtkhash')
-source=(gtkhash::"git+https://github.com/tristanheaven/gtkhash.git"
- "gtkhash.desktop")
-sha256sums=('SKIP'
- 'f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388')
+source=(gtkhash::"git+https://github.com/tristanheaven/gtkhash.git")
+md5sums=('SKIP')
pkgver() {
cd gtkhash
@@ -28,38 +25,10 @@ build() {
./autogen.sh
./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
- --enable-linux-crypto --enable-nettle --with-gtk=3.0 \
- --enable-nemo --enable-nautilus --enable-thunar # ← remove FMs here!
+ --enable-linux-crypto --enable-nettle
make
}
-package_gtkhash-git() {
- install=gtkhash.install
-
+package() {
make -C gtkhash DESTDIR="$pkgdir/" install
- # install desktop entry
- install -Dm644 gtkhash.desktop "$pkgdir"/usr/share/applications/gtkhash.desktop
- # remove filemanager plugins
- rm -rf "$pkgdir"/usr/lib
-}
-
-package_gtkhash-nemo-git() {
- pkgdesc+=' - Nemo filemanager plugin'
- depends=('gtkhash-git' 'nemo')
-
- make -C gtkhash/src/nemo DESTDIR="$pkgdir/" install
-}
-
-package_gtkhash-nautilus-git() {
- pkgdesc+=' - Nautilus filemanager plugin'
- depends=('gtkhash-git' 'nautilus')
-
- make -C gtkhash/src/nautilus DESTDIR="$pkgdir/" install
-}
-
-package_gtkhash-thunar-git() {
- pkgdesc+=' - Thunar filemanager plugin'
- depends=('gtkhash-git' 'thunar')
-
- make -C gtkhash/src/thunar DESTDIR="$pkgdir/" install
}