summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-12-05 03:33:46 +0100
committerCarsten Teibes2013-12-05 03:33:46 +0100
commitdcb02d8aefdfe8f8b308cbb2f0b0083efe2e18e3 (patch)
tree8da280f19e0310d72fb89e94ee3dc3576ac33a3d
downloadaur-dcb02d8aefdfe8f8b308cbb2f0b0083efe2e18e3.tar.gz
[add] gtkhash-git
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD81
-rw-r--r--gtkhash.desktop8
-rw-r--r--gtkhash.install12
4 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0648fb2d6ed9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gtkhash-git
+ pkgdesc = A GTK+ utility for computing message digests or checksums (development version).
+ pkgver = 0.7.0.4.ga01ad64
+ pkgrel = 1
+ url = http://gtkhash.sourceforge.net/
+ install = gtkhash.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = nemo
+ depends = dconf
+ depends = gtk3
+ optdepends = nemo: filemanager plugin
+ provides = gtkhash
+ conflicts = gtkhash
+ source = gtkhash::git://github.com/tristanheaven/gtkhash.git
+ source = gtkhash.desktop
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = gtkhash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19494133436a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+
+##### OPTIONS #####
+_gtk_version=3
+_nemo_plugin=y
+_nautilus_plugin=n
+_thunar_plugin=n
+###################
+
+_pkgbase=gtkhash
+pkgname=$_pkgbase-git
+pkgver=0.7.0.4.ga01ad64
+pkgrel=1
+pkgdesc='A GTK+ utility for computing message digests or checksums (development version).'
+arch=('i686' 'x86_64')
+url='http://gtkhash.sourceforge.net/'
+license=('GPL')
+makedepends=('intltool')
+depends=('dconf')
+install=$_pkgbase.install
+source=("$_pkgbase::git://github.com/tristanheaven/gtkhash.git"
+ "$_pkgbase.desktop")
+conflicts=("$_pkgbase")
+provides=("$_pkgbase")
+md5sums=('SKIP' 'SKIP')
+
+# gtk version
+if [ "$_gtk_version" = "3" ]; then
+ _pkgoptions="$_pkgoptions --with-gtk=3.0"
+ depends=("${depends[@]}" "gtk3")
+else
+ _pkgoptions="$_pkgoptions --with-gtk=2.0"
+ depends=("${depends[@]}" "gtk2")
+fi
+
+# nemo plugin
+if [ "$_nemo_plugin" = "y" ]; then
+ _pkgoptions="$_pkgoptions --enable-nemo"
+ makedepends=("${makedepends[@]}" "nemo")
+ optdepends=("${optdepends[@]}" "nemo: filemanager plugin")
+fi
+
+# nautilus plugin
+if [ "$_nautilus_plugin" = "y" ]; then
+ _pkgoptions="$_pkgoptions --enable-nautilus"
+ makedepends=("${makedepends[@]}" "libnautilus-extension")
+ optdepends=("${optdepends[@]}" "nautilus: filemanager plugin")
+fi
+
+# thunar plugin
+if [ "$_thunar_plugin" = "y" ]; then
+ _pkgoptions="$_pkgoptions --enable-thunar"
+ makedepends=("${makedepends[@]}" "thunar")
+ optdepends=("${optdepends[@]}" "thunar: filemanager plugin")
+fi
+
+pkgver() {
+ cd $_pkgbase
+
+ local ver="$(git describe --long)"
+ printf "%s" "${ver//-/.}"
+}
+
+build() {
+ cd $_pkgbase
+
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
+ --enable-linux-crypto --enable-nettle $_pkgoptions
+
+ make
+}
+
+package() {
+ cd $_pkgbase
+
+ make DESTDIR=$pkgdir install
+
+ # install desktop entry
+ install -Dm644 ../gtkhash.desktop $pkgdir/usr/share/applications/gtkhash.desktop
+}
diff --git a/gtkhash.desktop b/gtkhash.desktop
new file mode 100644
index 000000000000..737449ccb714
--- /dev/null
+++ b/gtkhash.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=gtkhash
+Exec=gtkhash
+Icon=calc
+Terminal=false
+Categories=Utility;GNOME;GTK;
diff --git a/gtkhash.install b/gtkhash.install
new file mode 100644
index 000000000000..a432ada8586d
--- /dev/null
+++ b/gtkhash.install
@@ -0,0 +1,12 @@
+
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}