summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2021-12-29 16:26:08 -0600
committerSam Burgos2021-12-29 16:26:08 -0600
commit6c97220eff6b2f59549029b4bde31845fd6b1e8c (patch)
tree79c4c6884fa78e2a490b3411b7252da8638f2aa6
downloadaur-6c97220eff6b2f59549029b4bde31845fd6b1e8c.tar.gz
added new gtkhash-nemo package to separate from standalone application and other filemanager plugins
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD59
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..236973e10fbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gtkhash-nemo
+ pkgdesc = A GTK+ utility for computing message digests or checksums (Gtkhash with Nemo filemanager plugin)
+ pkgver = 1.4
+ pkgrel = 4
+ url = https://github.com/tristanheaven/gtkhash
+ arch = x86_64
+ license = GPL
+ makedepends = dconf
+ makedepends = gtk3
+ makedepends = intltool
+ makedepends = librsvg
+ makedepends = nemo
+ makedepends = nettle
+ makedepends = xdg-utils
+ depends = dconf
+ depends = gtk3
+ depends = libb2
+ depends = nemo
+ depends = nettle
+ provides = gtkhash-nemo
+ conflicts = gtkhash
+ conflicts = gtkhash-caja
+ conflicts = gtkhash-nautilus
+ conflicts = gtkhash-thunar
+ source = https://github.com/tristanheaven/gtkhash/releases/download/v1.4/gtkhash-1.4.tar.xz
+ sha256sums = 20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4
+
+pkgname = gtkhash-nemo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bf20a831e6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Sam Burgos < santiago dot burgos1089 at gmail dot com >
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Jan Böhringer <janboe@gmail.com>
+# Contributor: Frédérik Paradis <fredy_14@live.fr>
+# Contributor: GI_Jack <GI_Jack@hushmail.com>
+
+pkgname=gtkhash-nemo
+pkgver=1.4
+pkgrel=4
+pkgdesc="A GTK+ utility for computing message digests or checksums (Gtkhash with Nemo filemanager plugin)"
+arch=('x86_64')
+url="https://github.com/tristanheaven/gtkhash"
+license=('GPL')
+depends=(
+ 'dconf'
+ 'gtk3'
+ 'libb2'
+ 'nemo'
+ 'nettle'
+)
+
+makedepends=(
+ 'dconf'
+ 'gtk3'
+ 'intltool'
+ 'librsvg'
+ 'nemo'
+ 'nettle'
+ 'xdg-utils'
+)
+provides=(${pkgname})
+conflicts=(
+ gtkhash
+ gtkhash-caja
+ gtkhash-nautilus
+ gtkhash-thunar
+)
+source=("${url}/releases/download/v$pkgver/gtkhash-$pkgver.tar.xz")
+sha256sums=('20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4')
+
+build() {
+ cd gtkhash-$pkgver
+
+ ./configure --prefix=/usr \
+ --disable-schemas-compile \
+ --enable-gtkhash \
+ --enable-linux-crypto \
+ --enable-nettle \
+ --disable-blake2 \
+ --with-gtk=3.0 \
+ --enable-nemo
+
+ make
+}
+
+package() {
+
+ make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
+}