summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2015-06-10 23:55:57 +0800
committerFelix Yan2015-06-10 23:55:57 +0800
commit79a4dfc36a6d59fb67a5d2a5996d63d30c5f39d8 (patch)
treedd39fd0649a319a4ac413a6b917faba4a660c91f
downloadaur-79a4dfc36a6d59fb67a5d2a5996d63d30c5f39d8.tar.gz
gtkhotkey dropped from [community]
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bed82ec9b745
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gtkhotkey
+ pkgdesc = Platform independent hotkey handling for Gtk+ applications
+ pkgver = 0.2.1
+ pkgrel = 9
+ url = https://launchpad.net/gtkhotkey
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = intltool
+ depends = gtk2
+ source = http://launchpad.net/gtkhotkey/0.2/0.2.1/+download/gtkhotkey-0.2.1.tar.gz
+ md5sums = bfdc73e68e9adbe0d506d31a25862914
+
+pkgname = gtkhotkey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e8f487f41e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 113836 2014-07-01 06:39:41Z fyan $
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: kiefer <jorgelmadrid@gmail.com>
+# Contributor: Alessio Sergi <asergi at archlinux dot us>
+# Contributor: Gaute Hope <eg@gaute.vetsj.com>
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+pkgname=gtkhotkey
+pkgver=0.2.1
+pkgrel=9
+pkgdesc="Platform independent hotkey handling for Gtk+ applications"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/gtkhotkey"
+license=('LGPL3')
+depends=('gtk2')
+makedepends=('intltool')
+source=("http://launchpad.net/$pkgname/0.2/$pkgver/+download/$pkgname-$pkgver.tar.gz")
+md5sums=('bfdc73e68e9adbe0d506d31a25862914')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # doc path fix
+ sed -i '/gtkhotkeydocdir/s/\${prefix}/\${datadir}/g' Makefile.{am,in}
+
+ # glib2 fix
+ sed -i 's|glib/gquark\.h|glib.h|' src/gtk-hotkey-error.h
+ sed -i 's|glib/gtypes\.h|glib.h|' src/x11/tomboykeybinder.h
+
+ ./configure --prefix=/usr \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}