summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNixuge2024-03-11 21:46:36 +0100
committerNixuge2024-03-11 21:46:36 +0100
commite620f8e88de8c0671789408080ed6dd96a49c72e (patch)
treeb1f570fdfaede0ef8cc24dd695bd24e032d1169f
parent5a268eae7488d4f1f105de61635f4c80426f7da3 (diff)
downloadaur-e620f8e88de8c0671789408080ed6dd96a49c72e.tar.gz
Renamed to DesktopPatcher
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31a8e8e22861..90874ac04869 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = gtkpickeradder-hook
- pkgdesc = A pacman hook to make numerous apps use the GTK file picker by changing their .desktop file
- pkgver = 1.0.0
+ pkgdesc = A pacman hook to make some apps behave nicer, including using the wayland ozone platform, the gtk file picker & zooming qt apps
+ pkgver = v1.0.0.r13.g24f35c2
pkgrel = 1
- url = https://github.com/Nixuge/GTKPickerAdder
+ url = https://github.com/Nixuge/DesktopPatcher
arch = any
license = WTFPL
depends = python
- source = https://github.com/Nixuge/GTKPickerAdder/archive/refs/tags/v1.0.0.tar.gz
- sha256sums = 92418ce77da0a1a04147b2be9b74a9fa49958de9deca6d1d178a5aaf6ed184bc
+ source = git+https://github.com/Nixuge/DesktopPatcher
+ sha256sums = SKIP
pkgname = gtkpickeradder-hook
diff --git a/PKGBUILD b/PKGBUILD
index 09e17372852c..9e19ccd77940 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Nixuge
pkgname=gtkpickeradder-hook
-pkgver=1.0.0
+pkgver=v1.0.0.r13.g24f35c2
pkgrel=1
-pkgdesc='A pacman hook to make numerous apps use the GTK file picker by changing their .desktop file'
-url=https://github.com/Nixuge/GTKPickerAdder
+pkgdesc='A pacman hook to make some apps behave nicer, including using the wayland ozone platform, the gtk file picker & zooming qt apps'
+url=https://github.com/Nixuge/DesktopPatcher
arch=(any)
license=(WTFPL)
depends=('python')
-source=("https://github.com/Nixuge/GTKPickerAdder/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('92418ce77da0a1a04147b2be9b74a9fa49958de9deca6d1d178a5aaf6ed184bc')
+source=("git+https://github.com/Nixuge/DesktopPatcher")
+sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/DesktopPatcher"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
package() {
- cd "GTKPickerAdder-${pkgver}"
-
+ cd "${srcdir}/DesktopPatcher"
+
# License
install -Dm644 \
"LICENSE" \
@@ -22,11 +26,11 @@ package() {
# Hook
install -Dm644 \
- "gtkpicker-adder.hook" \
- "${pkgdir}/etc/pacman.d/hooks/gtkpicker-adder.hook"
+ "desktop_patcher.hook" \
+ "${pkgdir}/etc/pacman.d/hooks/desktop_patcher.hook"
# Py file going w the hook
install -Dm644 \
- "gtkpicker-adder.py" \
- "${pkgdir}/etc/pacman.d/hooks/gtkpicker-adder.py"
+ "desktop_patcher.py" \
+ "${pkgdir}/etc/pacman.d/hooks/desktop_patcher.py"
}