summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoeny Ang2015-07-07 16:20:01 +0800
committerJoeny Ang2015-07-07 16:20:01 +0800
commitb55e3d4a3b4aad17877dac1d999b58215d2dc8cf (patch)
tree17922555516ef0fb9b01711cc69ae15239955c3c
downloadaur-gtkpod1.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD46
-rw-r--r--gtkpod.install11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4069c857e42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = gtkpod1
+ pkgdesc = A platform-independent GUI for Apple's iPod using GTK2 (old version)
+ pkgver = 1.0.0
+ pkgrel = 2
+ url = http://gtkpod.sourceforge.net/
+ install = gtkpod.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = MPL
+ makedepends = intltool
+ depends = awk
+ depends = libgpod>=0.8.0
+ depends = libid3tag
+ depends = flac
+ depends = libvorbis
+ depends = curl
+ depends = libglade
+ depends = hicolor-icon-theme
+ depends = gcc-libs
+ optdepends = vorbis-tools: OGG support
+ optdepends = id3v2: mp3 conversion support
+ conflicts = gtkpod
+ options = !libtool
+ source = http://downloads.sourceforge.net/project/gtkpod/gtkpod/gtkpod-1.0.0/gtkpod-1.0.0.tar.gz
+ source = http://mp4v2.googlecode.com/files/mp4v2-1.9.1.tar.bz2
+ md5sums = cadd402dcd1cfbedda0357bf24965a7c
+ md5sums = 986701929ef15b03155ac4fb16444797
+
+pkgname = gtkpod1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f16cc6fded0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Joeny Ang <ang(dot)joeny(at)gmail(dot)com>
+# Submitter: Andy Kiss <vithon985(at)gmail(dot)com>
+# Contributor: Kevin Piche <kevin(at)archlinux(dot)org>
+# Contributor: Aaron Griffin <aaron(at)archlinux(dot)org>
+
+pkgname=gtkpod1
+pkgver=1.0.0
+pkgrel=2
+pkgdesc="A platform-independent GUI for Apple's iPod using GTK2 (old version)"
+arch=('i686' 'x86_64')
+url="http://gtkpod.sourceforge.net/"
+license=('GPL' 'MPL')
+depends=('awk' 'libgpod>=0.8.0' 'libid3tag' 'flac' 'libvorbis' 'curl' 'libglade' 'hicolor-icon-theme' 'gcc-libs')
+makedepends=('intltool')
+optdepends=('vorbis-tools: OGG support'
+ 'id3v2: mp3 conversion support')
+conflicts=('gtkpod')
+options=('!libtool')
+install=gtkpod.install
+source=("http://downloads.sourceforge.net/project/gtkpod/gtkpod/gtkpod-${pkgver}/gtkpod-${pkgver}.tar.gz"
+ "http://mp4v2.googlecode.com/files/mp4v2-1.9.1.tar.bz2")
+md5sums=('cadd402dcd1cfbedda0357bf24965a7c'
+ '986701929ef15b03155ac4fb16444797')
+
+build() {
+ # build libmp4v2 1.9.1
+ cd "${srcdir}/mp4v2-1.9.1"
+ ./configure --prefix=/usr
+ make
+
+ # build gtkpod 1.0.0
+ cd "${srcdir}/gtkpod-${pkgver}"
+ sed -i 's#python#python2#' scripts/sync-palm-jppy.py
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/gtkpod-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # copy libmp4v2.so.1.9.1
+ install -m755 -d "${pkgdir}/usr/lib"
+ install -m644 "${srcdir}/mp4v2-1.9.1/.libs/libmp4v2.so.1.9.1" "${pkgdir}/usr/lib"
+ ln -s "/usr/lib/libmp4v2.so.1.9.1" "${pkgdir}/usr/lib/libmp4v2.so.1"
+}
diff --git a/gtkpod.install b/gtkpod.install
new file mode 100644
index 000000000000..17ca8f78a655
--- /dev/null
+++ b/gtkpod.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}