summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2018-12-21 01:19:28 +0100
committerPellegrino Prevete2018-12-21 01:19:28 +0100
commit71de17c2f92dc57b833010c11114ec78dd8115e9 (patch)
tree15663834166021d5ba8669e3091749791a3ea05c
downloadaur-71de17c2f92dc57b833010c11114ec78dd8115e9.tar.gz
added PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..695e07a77ca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gtksourceview
+ pkgdesc = GNOME library that extends GtkTextView
+ pkgver = 1.8.5
+ pkgrel = 1
+ url = http://www.gnome.org/
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ license = GPL
+ source = http://ftp.gnome.org/pub/gnome/sources/gtksourceview/1.8/gtksourceview-1.8.5.tar.gz
+ sha256sums = 36727b1cd5ed311af0c0418c9617f69bc31cc97e2dfef05ba1cc6ce1fb513c9e
+
+pkgname = gtksourceview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36afd98068e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Rafael Ferreira <josephgbr@archlinux.info>
+
+pkgname=gtksourceview
+pkgver=1.8.5
+pkgrel=1
+pkgdesc='GNOME library that extends GtkTextView'
+url='http://www.gnome.org/'
+arch=('x86_64' 'i686')
+license=('LGPL' 'GPL')
+
+#depends=('pango' 'libart-lgpl' 'libxml2' 'libgnomecups' 'libgcrypt' 'bzip2')
+#makedepends=('intltool' 'pkgconfig' 'addinclude')
+#replaces=('libgnomeprint-cups')
+#conflicts=('libgnomeprint-cups')
+#options=('!libtool')
+source=("http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.8/$pkgname-$pkgver.tar.gz")
+sha256sums=('36727b1cd5ed311af0c0418c9617f69bc31cc97e2dfef05ba1cc6ce1fb513c9e')
+
+#prepare() {
+# cd "$pkgname-$pkgver"
+
+# patch -p0 -i "$srcdir/patch-freetype-2.5.1.diff"
+# patch -p0 -i "$srcdir/patch-freetype-2.9.1.diff"
+# addinclude "$pkgname/modules/cups/gnome-print-cups-transport.c" stdio
+# cd "$srcdir"
+# patch -p0 -i libgnomeprint-2.18.8-bison3.patch
+#}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ CPPFLAGS=-D_GNU_SOURCE ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static --enable-gtk-doc=no --disable-build-tests --disable-gnomeprint
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: