summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-06-20 14:51:02 +0300
committerArtem Vorotnikov2015-06-20 14:51:02 +0300
commit0fea4ac8d664f78dd4468118b38c0424e24b66ff (patch)
tree760b68532eabd09aa17f650fceb7f56823bd9ea9
downloadaur-0fea4ac8d664f78dd4468118b38c0424e24b66ff.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00e6b3c50374
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gtksourceview-highlight-asciidoc
+ pkgdesc = Asciidoc syntax highlighting for gtksourceview
+ pkgver = LATEST
+ pkgrel = 1
+ url = https://github.com/gmate
+ arch = any
+ license = GPL
+ source = https://github.com/gmate/gmate/raw/master/lang-specs/asciidoc.lang
+ sha512sums = SKIP
+
+pkgname = gtksourceview2-highlight-asciidoc
+ depends = gtksourceview2
+ conflicts = asciidoc-gtk-highlight
+
+pkgname = gtksourceview3-highlight-asciidoc
+ depends = gtksourceview3
+ conflicts = asciidoc-gtk-highlight
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8201ad507a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgbase=gtksourceview-highlight-asciidoc
+pkgname=('gtksourceview2-highlight-asciidoc' 'gtksourceview3-highlight-asciidoc')
+pkgver=LATEST
+pkgrel=1
+pkgdesc='Asciidoc syntax highlighting for gtksourceview'
+arch=('any')
+url=('https://github.com/gmate')
+license=('GPL')
+source=('https://github.com/gmate/gmate/raw/master/lang-specs/asciidoc.lang')
+sha512sums=('SKIP')
+
+package_gtksourceview2-highlight-asciidoc() {
+ conflicts=('asciidoc-gtk-highlight')
+ depends=('gtksourceview2')
+
+ install -m644 -D asciidoc.lang "$pkgdir/usr/share/gtksourceview-2.0/language-specs/asciidoc.lang"
+}
+
+package_gtksourceview3-highlight-asciidoc() {
+ conflicts=('asciidoc-gtk-highlight')
+ depends=('gtksourceview3')
+
+ install -m644 -D asciidoc.lang "$pkgdir/usr/share/gtksourceview-3.0/language-specs/asciidoc.lang"
+}
+